CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  What's the CVSS score of your company?
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

10web : Security Vulnerabilities

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
1 CVE-2021-25047 79 XSS 2022-01-10 2022-01-18
4.3
None Remote Medium Not required None Partial None
The 10Web Social Photo Feed WordPress plugin before 1.4.29 was affected by a reflected Cross-Site Scripting (XSS) vulnerability in the wdi_apply_changes admin page, allowing an attacker to perform such attack against any logged in users
2 CVE-2021-25041 79 XSS 2021-12-06 2021-12-07
4.3
None Remote Medium Not required None Partial None
The Photo Gallery by 10Web WordPress plugin before 1.5.68 is vulnerable to Reflected Cross-Site Scripting (XSS) issues via the bwg_album_breadcrumb_0 and shortcode_id GET parameters passed to the bwg_frontend_data AJAX action
3 CVE-2021-24526 79 XSS 2021-08-16 2021-08-23
3.5
None Remote Medium ??? None Partial None
The Form Maker by 10Web – Mobile-Friendly Drag & Drop Contact Form Builder WordPress plugin before 1.13.60 does not escape its Form Title before outputting it in an attribute when editing a form in the admin dashboard, leading to an authenticated Stored Cross-Site Scripting issue
4 CVE-2021-24363 22 Dir. Trav. 2021-08-16 2021-08-23
4.0
None Remote Low ??? None Partial None
The Photo Gallery by 10Web – Mobile-Friendly Image Gallery WordPress plugin before 1.5.75 did not ensure that uploaded files are kept inside its uploads folder, allowing high privilege users to put images/SVG anywhere in the filesystem via a path traversal vector
5 CVE-2021-24362 79 Exec Code XSS 2021-08-16 2021-08-23
4.3
None Remote Medium Not required None Partial None
The Photo Gallery by 10Web – Mobile-Friendly Image Gallery WordPress plugin before 1.5.75 did not ensure that uploaded SVG files added to a gallery do not contain malicious content. As a result, users allowed to add images to gallery can upload an SVG file containing JavaScript code, which will be executed when accessing the image directly (ie in the /wp-content/uploads/photo-gallery/ folder), leading to a Cross-Site Scripting (XSS) issue
6 CVE-2021-24310 79 XSS 2021-06-01 2021-06-09
3.5
None Remote Medium ??? None Partial None
The Photo Gallery by 10Web - Mobile-Friendly Image Gallery WordPress plugin before 1.5.67 did not properly sanitise the gallery title, allowing high privilege users to create one with XSS payload in it, which will be triggered when another user will view the gallery list or the affected gallery in the admin dashboard. This is due to an incomplete fix of CVE-2019-16117
7 CVE-2021-24291 79 XSS 2021-05-14 2021-05-21
4.3
None Remote Medium Not required None Partial None
The Photo Gallery by 10Web – Mobile-Friendly Image Gallery WordPress plugin before 1.5.69 was vulnerable to Reflected Cross-Site Scripting (XSS) issues via the gallery_id, tag, album_id and _id GET parameters passed to the bwg_frontend_data AJAX action (available to both unauthenticated and authenticated users)
8 CVE-2021-24139 89 Sql 2021-03-18 2021-03-22
7.5
None Remote Low Not required Partial Partial Partial
Unvalidated input in the Photo Gallery (10Web Photo Gallery) WordPress plugin, versions before 1.5.55, leads to SQL injection via the frontend/models/model.php bwg_search_x parameter.
9 CVE-2021-24132 89 Sql 2021-03-18 2021-03-24
6.5
None Remote Low ??? Partial Partial Partial
The Slider by 10Web WordPress plugin, versions before 1.2.36, in the bulk_action, export_full and save_slider_db functionalities of the plugin were vulnerable, allowing a high privileged user (Admin), or medium one such as Contributor+ (if "Role Options" is turn on for other users) to perform a SQL Injection attacks.
10 CVE-2020-9335 79 XSS 2020-02-25 2020-02-25
3.5
None Remote Medium ??? None Partial None
Multiple stored XSS vulnerabilities exist in the 10Web Photo Gallery plugin before 1.5.46 WordPress. Successful exploitation of this vulnerability would allow a authenticated admin user to inject arbitrary JavaScript code that is viewed by other users.
11 CVE-2019-16119 89 Sql 2019-09-08 2019-09-10
7.5
None Remote Low Not required Partial Partial Partial
SQL injection in the photo-gallery (10Web Photo Gallery) plugin before 1.5.35 for WordPress exists via the admin/controllers/Albumsgalleries.php album_id parameter.
12 CVE-2019-16118 79 XSS 2019-09-08 2019-09-10
4.3
None Remote Medium Not required None Partial None
Cross site scripting (XSS) in the photo-gallery (10Web Photo Gallery) plugin before 1.5.35 for WordPress exists via admin/controllers/Options.php.
13 CVE-2019-16117 79 XSS 2019-09-08 2019-09-10
4.3
None Remote Medium Not required None Partial None
Cross site scripting (XSS) in the photo-gallery (10Web Photo Gallery) plugin before 1.5.35 for WordPress exists via admin/models/Galleries.php.
14 CVE-2019-14798 22 Dir. Trav. File Inclusion 2019-08-09 2019-08-14
4.0
None Remote Low ??? Partial None None
The 10Web Photo Gallery plugin before 1.5.25 for WordPress has Authenticated Local File Inclusion via directory traversal in the wp-admin/admin-ajax.php?action=shortcode_bwg tagtext parameter.
15 CVE-2019-14797 79 XSS 2019-08-09 2019-08-14
3.5
None Remote Medium ??? None Partial None
The 10Web Photo Gallery plugin before 1.5.23 for WordPress has authenticated stored XSS.
16 CVE-2019-14313 89 Exec Code Sql 2019-07-30 2019-08-13
10.0
None Remote Low Not required Complete Complete Complete
A SQL injection vulnerability exists in the 10Web Photo Gallery plugin before 1.5.31 for WordPress. Successful exploitation of this vulnerability would allow a remote attacker to execute arbitrary SQL commands on the affected system via filemanager/model.php.
17 CVE-2019-11590 352 Dir. Trav. CSRF File Inclusion 2019-04-29 2020-08-24
6.8
None Remote Medium Not required Partial Partial Partial
The 10Web Form Maker plugin before 1.13.5 for WordPress allows CSRF via the wp-admin/admin-ajax.php action parameter, with resultant local file inclusion via directory traversal, because there can be a discrepancy between the $_POST['action'] value and the $_GET['action'] value, and the latter is unsanitized.
18 CVE-2019-10866 89 Sql 2019-05-23 2019-08-03
7.5
None Remote Low Not required Partial Partial Partial
In the Form Maker plugin before 1.13.3 for WordPress, it's possible to achieve SQL injection in the function get_labels_parameters in the file form-maker/admin/models/Submissions_fm.php with a crafted value of the /models/Submissioc parameter.
19 CVE-2017-12977 89 Sql 2017-08-21 2019-07-08
6.5
None Remote Low ??? Partial Partial Partial
The Web-Dorado "Photo Gallery by WD - Responsive Photo Gallery" plugin before 1.3.51 for WordPress has a SQL injection vulnerability related to bwg_edit_tag() in photo-gallery.php and edit_tag() in admin/controllers/BWGControllerTags_bwg.php. It is exploitable by administrators via the tag_id parameter.
20 CVE-2015-9380 352 CSRF 2019-08-30 2019-09-03
6.8
None Remote Medium Not required Partial Partial Partial
The photo-gallery plugin before 1.2.42 for WordPress has CSRF.
21 CVE-2015-2324 79 XSS 2018-02-19 2019-07-08
3.5
None Remote Medium ??? None Partial None
Cross-site scripting (XSS) vulnerability in the filemanager in the Photo Gallery plugin before 1.2.13 for WordPress allows remote authenticated users with edit permission to inject arbitrary web script or HTML via unspecified vectors.
22 CVE-2015-1394 79 XSS 2020-02-08 2020-02-11
3.5
None Remote Medium ??? None Partial None
Multiple cross-site scripting (XSS) vulnerabilities in the Photo Gallery plugin before 1.2.11 for WordPress allow remote authenticated users to inject arbitrary web script or HTML via the (1) sort_by, (2) sort_order, (3) items_view, (4) dir, (5) clipboard_task, (6) clipboard_files, (7) clipboard_src, or (8) clipboard_dest parameters in an addImages action to wp-admin/admin-ajax.php.
23 CVE-2015-1393 89 Exec Code Sql 2015-02-02 2019-07-08
6.5
None Remote Low ??? Partial Partial Partial
SQL injection vulnerability in the Photo Gallery plugin before 1.2.11 for WordPress allows remote authenticated users to execute arbitrary SQL commands via the asc_or_desc parameter in a create gallery request in the galleries_bwg page to wp-admin/admin.php.
24 CVE-2015-1055 89 Exec Code Sql 2015-01-16 2019-07-08
7.5
None Remote Low Not required Partial Partial Partial
SQL injection vulnerability in the Photo Gallery plugin 1.2.7 for WordPress allows remote attackers to execute arbitrary SQL commands via the order_by parameter in a GalleryBox action to wp-admin/admin-ajax.php.
25 CVE-2014-9312 434 2017-08-28 2019-07-08
6.5
None Remote Low ??? Partial Partial Partial
Unrestricted File Upload vulnerability in Photo Gallery 1.2.5.
Total number of vulnerabilities : 25   Page : 1 (This Page)
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.