CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  What's the CVSS score of your company?
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Cpanel : Security Vulnerabilities Published In 2020 (Cross Site Scripting (XSS))

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
1 CVE-2020-29137 79 XSS 2020-11-27 2020-12-01
4.3
None Remote Medium Not required None Partial None
cPanel before 90.0.17 allows self-XSS via the WHM Transfer Tool interface (SEC-577).
2 CVE-2020-26115 79 XSS 2020-09-25 2020-09-25
4.3
None Remote Medium Not required None Partial None
cPanel before 90.0.10 allows self XSS via the Cron Editor interface (SEC-574).
3 CVE-2020-26114 79 XSS 2020-09-25 2020-09-25
4.3
None Remote Medium Not required None Partial None
cPanel before 90.0.10 allows self XSS via the Cron Jobs interface (SEC-573).
4 CVE-2020-26113 79 XSS 2020-09-25 2020-09-29
4.3
None Remote Medium Not required None Partial None
cPanel before 90.0.10 allows self XSS via WHM Manage API Tokens interfaces (SEC-569).
5 CVE-2020-26111 79 XSS 2020-09-25 2020-09-29
4.3
None Remote Medium Not required None Partial None
cPanel before 90.0.10 allows self XSS via the WHM Edit DNS Zone interface (SEC-566).
6 CVE-2020-26110 79 XSS 2020-09-25 2020-09-29
4.3
None Remote Medium Not required None Partial None
cPanel before 88.0.13 allows self XSS via DNS Zone Manager DNSSEC interfaces (SEC-564).
7 CVE-2020-10114 79 XSS 2020-03-17 2020-03-19
4.3
None Remote Medium Not required None Partial None
cPanel before 84.0.20 allows stored self-XSS via the HTML file editor (SEC-535).
8 CVE-2020-10113 79 XSS 2020-03-17 2020-03-19
4.3
None Remote Medium Not required None Partial None
cPanel before 84.0.20 allows self XSS via a temporary character-set specification (SEC-515).
9 CVE-2019-20497 79 XSS 2020-03-17 2020-03-19
3.5
None Remote Medium ??? None Partial None
cPanel before 82.0.18 allows stored XSS via WHM Backup Restoration (SEC-533).
10 CVE-2019-20493 79 XSS 2020-03-17 2020-03-18
4.3
None Remote Medium Not required None Partial None
cPanel before 82.0.18 allows self-XSS because JSON string escaping is mishandled (SEC-520).
11 CVE-2012-6449 79 XSS 2020-02-10 2020-02-13
3.5
None Remote Medium ??? None Partial None
The clientconf.html and detailbw.html pages in x3 in cPanel & WHM 11.34.0 (build 8) have a XSS vulnerability.
12 CVE-2012-6448 79 XSS 2020-01-27 2020-01-29
4.3
None Remote Medium Not required None Partial None
Cross-site Scripting (XSS) in cPanel WebHost Manager (WHM) 11.34.0 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Total number of vulnerabilities : 12   Page : 1 (This Page)
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.