CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  What's the CVSS score of your company?
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Cpanel : Security Vulnerabilities (CVSS score between 5 and 5.99)

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
1 CVE-2021-38589 2021-08-11 2021-08-20
5.5
None Remote Low ??? None Partial Partial
In cPanel before 96.0.13, scripts/fix-cpanel-perl does not properly restrict the overwriting of files (SEC-588).
2 CVE-2021-38587 668 2021-08-11 2021-08-20
5.0
None Remote Low Not required None Partial None
In cPanel before 96.0.13, scripts/fix-cpanel-perl mishandles the creation of temporary files (SEC-586).
3 CVE-2021-26267 Bypass 2021-01-26 2021-02-03
5.0
None Remote Low Not required None Partial None
cPanel before 92.0.9 allows a MySQL user (who has an old-style password hash) to bypass suspension (SEC-579).
4 CVE-2021-26266 Bypass 2021-01-26 2021-02-03
5.0
None Remote Low Not required None Partial None
cPanel before 92.0.9 allows a Reseller to bypass the suspension lock (SEC-578).
5 CVE-2020-26112 2020-09-25 2020-09-29
5.0
None Remote Low Not required None Partial None
The email quota cache in cPanel before 90.0.10 allows overwriting of files.
6 CVE-2020-26109 Bypass 2020-09-25 2020-09-29
5.0
None Remote Low Not required None Partial None
cPanel before 88.0.13 allows bypass of a protection mechanism that attempted to restrict package modification (SEC-557).
7 CVE-2020-26107 326 2020-09-25 2021-07-21
5.0
None Remote Low Not required Partial None None
cPanel before 88.0.3, upon an upgrade, establishes predictable PowerDNS API keys (SEC-561).
8 CVE-2020-26106 532 2020-09-25 2021-07-21
5.0
None Remote Low Not required Partial None None
cPanel before 88.0.3 has weak permissions (world readable) for the proxy subdomains log file (SEC-558).
9 CVE-2020-26105 522 2020-09-25 2021-07-21
5.0
None Remote Low Not required Partial None None
In cPanel before 88.0.3, insecure chkservd test credentials are used on a templated VM (SEC-554).
10 CVE-2020-26104 922 2020-09-25 2020-09-29
5.0
None Remote Low Not required Partial None None
In cPanel before 88.0.3, an insecure SRS secret is used on a templated VM (SEC-552).
11 CVE-2020-26103 521 2020-09-25 2020-09-29
5.0
None Remote Low Not required Partial None None
In cPanel before 88.0.3, an insecure site password is used for Mailman on a templated VM (SEC-551).
12 CVE-2020-26102 863 2020-09-25 2021-07-21
5.0
None Remote Low Not required Partial None None
In cPanel before 88.0.3, an insecure auth policy API key is used by Dovecot on a templated VM (SEC-550).
13 CVE-2020-26101 522 2020-09-25 2021-07-21
5.0
None Remote Low Not required Partial None None
In cPanel before 88.0.3, insecure RNDC credentials are used for BIND on a templated VM (SEC-549).
14 CVE-2020-26099 Bypass 2020-09-25 2020-09-29
5.0
None Remote Low Not required None Partial None
cPanel before 88.0.3 allows attackers to bypass the SMTP greylisting protection mechanism (SEC-491).
15 CVE-2020-12785 862 2020-05-11 2021-07-21
5.5
None Remote Low ??? Partial Partial None
cPanel before 86.0.14 allows attackers to obtain access to the current working directory via the account backup feature (SEC-540).
16 CVE-2020-12784 20 2020-05-11 2021-07-21
5.0
None Remote Low Not required None None Partial
cPanel before 86.0.14 allows remote attackers to trigger a bandwidth suspension via mail log strings (SEC-505).
17 CVE-2020-10116 863 Bypass 2020-03-17 2021-07-21
5.0
None Remote Low Not required None Partial None
cPanel before 84.0.20 allows attackers to bypass intended restrictions on features and demo accounts via WebDisk UAPI calls (SEC-541).
18 CVE-2019-20491 Bypass 2020-03-16 2020-08-24
5.5
None Remote Low ??? Partial Partial None
cPanel before 82.0.18 allows attackers to leverage virtual mail accounts in order to bypass account suspensions (SEC-508).
19 CVE-2019-14411 2019-07-30 2020-08-24
5.0
None Remote Low Not required None Partial None
cPanel before 78.0.2 does not properly restrict demo accounts from writing to files via the DCV UAPI (SEC-473).
20 CVE-2019-14397 2019-07-30 2020-08-24
5.0
None Remote Low Not required None Partial None
cPanel before 80.0.5 allows demo accounts to modify arbitrary files via the extractfile API1 call (SEC-496).
21 CVE-2019-14388 2019-07-30 2020-08-24
5.0
None Remote Low Not required None Partial None
cPanel before 82.0.2 allows unauthenticated file creation because Exim log parsing is mishandled (SEC-507).
22 CVE-2018-20929 601 2019-08-01 2019-08-08
5.8
None Remote Medium Not required Partial Partial None
cPanel before 70.0.23 allows an open redirect via the /unprotected/redirect.html endpoint (SEC-392).
23 CVE-2018-20905 732 Bypass 2019-08-01 2020-08-24
5.5
None Remote Low ??? Partial Partial None
cPanel before 71.9980.37 allows attackers to make API calls that bypass the backup feature restriction (SEC-429).
24 CVE-2018-20885 74 2019-08-01 2019-08-01
5.0
None Remote Low Not required None Partial None
cPanel before 74.0.0 allows Apache HTTP Server configuration injection because of DocumentRoot variable interpolation (SEC-416).
25 CVE-2018-20867 601 2019-07-30 2019-07-30
5.8
None Remote Medium Not required Partial Partial None
cPanel before 76.0.8 has an open redirect when resetting connections (SEC-462).
26 CVE-2017-18476 254 2019-08-05 2019-08-12
5.0
None Remote Low Not required Partial None None
Leech Protect in cPanel before 62.0.4 does not protect certain directories (SEC-205).
27 CVE-2017-18464 20 2019-08-05 2019-08-12
5.5
None Remote Low ??? None Partial Partial
cPanel before 62.0.17 allows arbitrary file-overwrite operations via the WHM Zone Template editor (SEC-226).
28 CVE-2017-18462 254 Bypass 2019-08-05 2019-08-12
5.0
None Remote Low Not required None Partial None
cPanel before 62.0.17 allows a CPHulk one-day ban bypass when IP based protection is enabled (SEC-224).
29 CVE-2017-18461 20 2019-08-02 2019-08-08
5.0
None Remote Low Not required None Partial None
cPanel before 62.0.17 allows does not preserve security policy questions across an account rename (SEC-223).
30 CVE-2017-18451 264 2019-08-02 2019-08-06
5.0
None Remote Low Not required Partial None None
cPanel before 64.0.21 allows attackers to read a user's crontab file during a short time interval upon a cPAddon upgrade (SEC-257).
31 CVE-2017-18448 22 Dir. Trav. 2019-08-02 2019-08-08
5.0
None Remote Low Not required Partial None None
cPanel before 64.0.21 allows certain file-read operations via a Serverinfo_manpage API call (SEC-252).
32 CVE-2017-18444 20 Exec Code 2019-08-02 2019-08-08
5.0
None Remote Low Not required None Partial None
cPanel before 64.0.21 allows demo accounts to execute SSH API commands (SEC-248).
33 CVE-2017-18443 20 2019-08-02 2019-08-08
5.0
None Remote Low Not required None Partial None
cPanel before 64.0.21 allows demo and suspended accounts to use SSH port forwarding (SEC-247).
34 CVE-2017-18442 77 Exec Code 2019-08-02 2019-08-07
5.0
None Remote Low Not required None Partial None
cPanel before 64.0.21 allows demo accounts to execute Cpanel::SPFUI API commands (SEC-246).
35 CVE-2017-18431 20 2019-08-02 2019-08-13
5.0
None Remote Low Not required None Partial None
cPanel before 66.0.1 does not reliably perform suspend/unsuspend operations on accounts (CPANEL-13941).
36 CVE-2017-18414 601 2019-08-02 2019-08-12
5.8
None Remote Medium Not required Partial Partial None
cPanel before 67.9999.103 allows an open redirect in /unprotected/redirect.html (SEC-300).
37 CVE-2017-18407 347 2019-08-02 2019-08-12
5.8
None Remote Medium Not required Partial Partial None
cPanel before 67.9999.103 does not enforce SSL hostname verification for the support-agreement download (SEC-279).
38 CVE-2017-18406 89 Sql 2019-08-02 2019-08-12
5.0
None Remote Low Not required None Partial None
cPanel before 67.9999.103 allows SQL injection during eximstats processing (SEC-276).
39 CVE-2017-18398 20 2019-08-02 2019-08-13
5.5
None Remote Low ??? Partial Partial None
DnsUtils in cPanel before 68.0.15 allows zone creation for hostname and account subdomains (SEC-331).
40 CVE-2017-5615 601 2017-03-03 2017-03-07
5.8
None Remote Medium Not required Partial Partial None
cgiemail and cgiecho allow remote attackers to inject HTTP headers via a newline character in the redirect location.
41 CVE-2017-5614 601 2017-03-03 2019-10-31
5.8
None Remote Medium Not required Partial Partial None
Open redirect vulnerability in cgiemail and cgiecho allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via vectors involving the (1) success or (2) failure parameter.
42 CVE-2016-10860 284 2019-08-01 2019-08-12
5.5
None Remote Low ??? None Partial Partial
cPanel before 11.54.0.0 allows unauthorized zone modification via the WHM API (SEC-66).
43 CVE-2016-10859 285 2019-08-01 2019-08-08
5.5
None Remote Low ??? Partial Partial None
cPanel before 11.54.0.0 allows unauthorized password changes via Webmail API commands (SEC-65).
44 CVE-2016-10847 74 2019-08-01 2019-08-08
5.5
None Remote Low ??? Partial Partial None
cPanel before 11.54.0.4 allows arbitrary file-read and file-write operations via scripts/fixmailboxpath (SEC-80).
45 CVE-2016-10843 77 Exec Code 2019-08-01 2019-08-08
5.5
None Remote Low ??? Partial Partial None
cPanel before 11.54.0.4 allows code execution in the context of shared users via JSON-API (SEC-76).
46 CVE-2016-10839 89 Sql 2019-08-01 2019-08-13
5.5
None Remote Low ??? Partial Partial None
cPanel before 11.54.0.4 allows SQL injection in bin/horde_update_usernames (SEC-71).
47 CVE-2016-10833 287 2019-08-01 2019-08-12
5.0
None Remote Low Not required Partial None None
cPanel before 55.9999.141 mishandles username-based blocking for PRE requests in cPHulkd (SEC-104).
48 CVE-2016-10830 284 Bypass 2019-08-01 2019-08-12
5.5
None Remote Low ??? Partial Partial None
cPanel before 55.9999.141 allows ACL bypass for AppConfig applications via magic_revision (SEC-100).
49 CVE-2016-10825 358 Bypass 2019-08-01 2019-08-12
5.5
None Remote Low ??? Partial Partial None
cPanel before 55.9999.141 allows attackers to bypass a Security Policy by faking static documents (SEC-92).
50 CVE-2016-10803 93 2019-08-07 2019-08-12
5.0
None Remote Low Not required None Partial None
cPanel before 57.9999.105 allows newline injection via LOC records (CPANEL-6923).
Total number of vulnerabilities : 63   Page : 1 (This Page)2
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.