CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  What's the CVSS score of your company?
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Automattic : Security Vulnerabilities

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
1 CVE-2021-32789 89 Sql 2021-07-26 2021-08-05
5.0
None Remote Low Not required Partial None None
woocommerce-gutenberg-products-block is a feature plugin for WooCommerce Gutenberg Blocks. An SQL injection vulnerability impacts all WooCommerce sites running the WooCommerce Blocks feature plugin between version 2.5.0 and prior to version 2.5.16. Via a carefully crafted URL, an exploit can be executed against the `wc/store/products/collection-data?calculate_attribute_counts[][taxonomy]` endpoint that allows the execution of a read only sql query. There are patches for many versions of this package, starting with version 2.5.16. There are no known workarounds aside from upgrading.
2 CVE-2021-24374 668 2021-06-21 2021-09-20
5.0
None Remote Low Not required Partial None None
The Jetpack Carousel module of the JetPack WordPress plugin before 9.8 allows users to create a "carousel" type image gallery and allows users to comment on the images. A security vulnerability was found within the Jetpack Carousel module by nguyenhg_vcs that allowed the comments of non-published page/posts to be leaked.
3 CVE-2021-24329 79 XSS 2021-06-01 2021-06-10
3.5
None Remote Medium ??? None Partial None
The WP Super Cache WordPress plugin before 1.7.3 did not properly sanitise its wp_cache_location parameter in its settings, which could lead to a Stored Cross-Site Scripting issue.
4 CVE-2021-24312 94 2021-06-01 2021-06-11
6.5
None Remote Low ??? Partial Partial Partial
The parameters $cache_path, $wp_cache_debug_ip, $wp_super_cache_front_page_text, $cache_scheduled_time, $cached_direct_pages used in the settings of WP Super Cache WordPress plugin before 1.7.3 result in RCE because they allow input of '$' and '\n'. This is due to an incomplete fix of CVE-2021-24209.
5 CVE-2021-24209 20 2021-04-05 2021-05-04
9.0
None Remote Low ??? Complete Complete Complete
The WP Super Cache WordPress plugin before 1.7.2 was affected by an authenticated (admin+) RCE in the settings page due to input validation failure and weak $cache_path check in the WP Super Cache Settings -> Cache Location option. Direct access to the wp-cache-config.php file is not prohibited, so this vulnerability can be exploited for a web shell injection.
6 CVE-2020-8215 120 DoS Exec Code Overflow 2020-07-20 2020-07-23
6.8
None Remote Medium Not required Partial Partial Partial
A buffer overflow is present in canvas version <= 1.6.9, which could lead to a Denial of Service or execution of arbitrary code when it processes a user-provided image.
7 CVE-2017-18356 94 +Priv 2019-01-15 2019-02-07
6.5
None Remote Low ??? Partial Partial Partial
In the Automattic WooCommerce plugin before 3.2.4 for WordPress, an attack is possible after gaining access to the target site with a user account that has at least Shop manager privileges. The attacker then constructs a specifically crafted string that will turn into a PHP object injection involving the includes/shortcodes/class-wc-shortcode-products.php WC_Shortcode_Products::get_products() use of cached queries within shortcodes.
8 CVE-2017-17058 22 Dir. Trav. 2017-11-29 2019-04-17
5.0
None Remote Low Not required Partial None None
** DISPUTED ** The WooCommerce plugin through 3.x for WordPress has a Directory Traversal Vulnerability via a /wp-content/plugins/woocommerce/templates/emails/plain/ URI, which accesses a parent directory. NOTE: a software maintainer indicates that Directory Traversal is not possible because all of the template files have "if (!defined('ABSPATH')) {exit;}" code.
9 CVE-2016-10763 79 XSS 2019-07-18 2019-07-18
3.5
None Remote Medium ??? None Partial None
The CampTix Event Ticketing plugin before 1.5 for WordPress allows XSS in the admin section via a ticket title or body.
10 CVE-2016-10762 77 2019-07-18 2019-07-18
5.1
None Remote High Not required Partial Partial Partial
The CampTix Event Ticketing plugin before 1.5 for WordPress allows CSV injection when the export tool is used.
11 CVE-2016-10706 79 XSS 2018-01-12 2018-01-24
4.3
None Remote Medium Not required None Partial None
The Jetpack plugin before 4.0.3 for WordPress has XSS via a crafted Vimeo link.
12 CVE-2016-10705 79 XSS 2018-01-12 2018-01-24
4.3
None Remote Medium Not required None Partial None
The Jetpack plugin before 4.0.4 for WordPress has XSS via the Likes module.
13 CVE-2015-9359 79 XSS 2019-08-28 2019-08-30
4.3
None Remote Medium Not required None Partial None
The Jetpack plugin before 3.4.3 for WordPress has XSS via add_query_arg() and remove_query_arg().
14 CVE-2015-9357 79 XSS 2019-08-28 2019-08-29
4.3
None Remote Medium Not required None Partial None
The akismet plugin before 3.1.5 for WordPress has XSS.
15 CVE-2014-0173 264 Bypass 2014-04-22 2017-08-29
5.8
None Remote Medium Not required Partial Partial None
The Jetpack plugin before 1.9 before 1.9.4, 2.0.x before 2.0.9, 2.1.x before 2.1.4, 2.2.x before 2.2.7, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.2, 2.6.x before 2.6.3, 2.7.x before 2.7.2, 2.8.x before 2.8.2, and 2.9.x before 2.9.3 for WordPress does not properly restrict access to the XML-RPC service, which allows remote attackers to bypass intended restrictions and publish posts via unspecified vectors. NOTE: some of these details are obtained from third party information.
16 CVE-2013-2011 116 Exec Code 2019-12-26 2020-01-02
6.8
None Remote Medium Not required Partial Partial Partial
WordPress W3 Super Cache Plugin before 1.3.2 contains a PHP code-execution vulnerability which could allow remote attackers to inject arbitrary code. This issue exists because of an incomplete fix for CVE-2013-2009.
17 CVE-2013-2010 74 1 Exec Code 2020-02-12 2020-02-14
7.5
None Remote Low Not required Partial Partial Partial
WordPress W3 Total Cache Plugin 0.9.2.8 has a Remote PHP Code Execution Vulnerability
18 CVE-2013-2009 Exec Code 2020-02-07 2020-02-10
6.8
None Remote Medium Not required Partial Partial Partial
WordPress WP Super Cache Plugin 1.2 has Remote PHP Code Execution
19 CVE-2013-2008 79 XSS 2020-02-07 2020-02-10
4.3
None Remote Medium Not required None Partial None
WordPress Super Cache Plugin 1.3 has XSS.
Total number of vulnerabilities : 19   Page : 1 (This Page)
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.