CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  What's the CVSS score of your company?
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Security Vulnerabilities (CVSS score between 4 and 4.99)

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
3301 CVE-2021-3921 352 CSRF 2021-11-13 2021-11-16
4.3
None Remote Medium Not required None Partial None
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
3302 CVE-2021-3916 22 Dir. Trav. 2021-11-05 2021-11-09
4.0
None Remote Low ??? Partial None None
bookstack is vulnerable to Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
3303 CVE-2021-3912 400 2021-11-11 2021-11-16
4.3
None Remote Medium Not required None None Partial
OctoRPKI tries to load the entire contents of a repository in memory, and in the case of a GZIP bomb, unzip it in memory, making it possible to create a repository that makes OctoRPKI run out of memory (and thus crash).
3304 CVE-2021-3911 252 2021-11-11 2021-11-16
4.3
None Remote Medium Not required None None Partial
If the ROA that a repository returns contains too many bits for the IP address then OctoRPKI will crash.
3305 CVE-2021-3906 434 2021-10-27 2021-11-03
4.0
None Remote Low ??? Partial None None
bookstack is vulnerable to Unrestricted Upload of File with Dangerous Type
3306 CVE-2021-3903 122 Overflow 2021-10-27 2021-11-17
4.6
None Local Low Not required Partial Partial Partial
vim is vulnerable to Heap-based Buffer Overflow
3307 CVE-2021-3900 352 CSRF 2021-10-27 2021-10-28
4.3
None Remote Medium Not required None Partial None
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
3308 CVE-2021-3882 311 +Info 2021-10-14 2021-10-20
4.0
None Remote High Not required Partial Partial None
LedgerSMB does not set the 'Secure' attribute on the session authorization cookie when the client uses HTTPS and the LedgerSMB server is behind a reverse proxy. By tricking a user to use an unencrypted connection (HTTP), an attacker may be able to obtain the authentication data by capturing network traffic. LedgerSMB 1.8 and newer switched from Basic authentication to using cookie authentication with encrypted cookies. Although an attacker can't access the information inside the cookie, nor the password of the user, possession of the cookie is enough to access the application as the user from which the cookie has been obtained. In order for the attacker to obtain the cookie, first of all the server must be configured to respond to unencrypted requests, the attacker must be suitably positioned to eavesdrop on the network traffic between the client and the server *and* the user must be tricked into using unencrypted HTTP traffic. Proper audit control and separation of duties limit Integrity impact of the attack vector. Users of LedgerSMB 1.8 are urged to upgrade to known-fixed versions. Users of LedgerSMB 1.7 or 1.9 are unaffected by this vulnerability and don't need to take action. As a workaround, users may configure their Apache or Nginx reverse proxy to add the Secure attribute at the network boundary instead of relying on LedgerSMB. For Apache, please refer to the 'Header always edit' configuration command in the mod_headers module. For Nginx, please refer to the 'proxy_cookie_flags' configuration command.
3309 CVE-2021-3875 122 Overflow 2021-10-15 2021-11-24
4.3
None Remote Medium Not required None None Partial
vim is vulnerable to Heap-based Buffer Overflow
3310 CVE-2021-3874 22 Dir. Trav. 2021-10-15 2021-10-20
4.0
None Remote Low ??? Partial None None
bookstack is vulnerable to Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
3311 CVE-2021-3863 79 XSS 2021-10-19 2021-10-21
4.3
None Remote Medium Not required None Partial None
snipe-it is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
3312 CVE-2021-3851 601 2021-10-19 2021-10-21
4.9
None Remote Medium ??? Partial Partial None
firefly-iii is vulnerable to URL Redirection to Untrusted Site
3313 CVE-2021-3834 79 XSS 2021-10-07 2021-10-14
4.3
None Remote Medium Not required None Partial None
Integria IMS in its 5.0.92 version does not filter correctly some fields related to the login.php file. An attacker could exploit this vulnerability in order to perform a cross-site scripting attack (XSS).
3314 CVE-2021-3824 79 XSS 2021-09-23 2021-09-29
4.3
None Remote Medium Not required None Partial None
OpenVPN Access Server 2.9.0 through 2.9.4 allow remote attackers to inject arbitrary web script or HTML via the web login page URL.
3315 CVE-2021-3812 79 XSS 2021-09-17 2021-09-28
4.3
None Remote Medium Not required None Partial None
adminlte is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
3316 CVE-2021-3811 79 XSS 2021-09-17 2021-09-28
4.3
None Remote Medium Not required None Partial None
adminlte is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
3317 CVE-2021-3801 697 2021-09-15 2021-09-28
4.3
None Remote Medium Not required None None Partial
prism is vulnerable to Inefficient Regular Expression Complexity
3318 CVE-2021-3788 863 2021-11-12 2021-11-16
4.6
None Local Low Not required Partial Partial Partial
An exposed debug interface was reported in some Motorola-branded Binatone Hubble Cameras that could allow an attacker with physical access unauthorized access to the device.
3319 CVE-2021-3787 522 2021-11-12 2021-11-16
4.6
None Local Low Not required Partial Partial Partial
A vulnerability was reported in some Motorola-branded Binatone Hubble Cameras that could allow an attacker with local access to obtain the MQTT credentials that could result in unauthorized access to backend Hubble services.
3320 CVE-2021-3783 79 XSS 2021-09-15 2021-09-23
4.3
None Remote Medium Not required None Partial None
yourls is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
3321 CVE-2021-3780 79 XSS 2021-09-15 2021-09-23
4.3
None Remote Medium Not required None Partial None
peertube is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
3322 CVE-2021-3774 311 2021-11-05 2021-11-09
4.3
None Remote Medium Not required Partial None None
Meross Smart Wi-Fi 2 Way Wall Switch (MSS550X), on its 3.1.3 version and before, creates an open Wi-Fi Access Point without the required security measures in its initial setup. This could allow a remote attacker to obtain the Wi-Fi SSID as well as the password configured by the user from Meross app via Http/JSON plain request.
3323 CVE-2021-3770 787 Overflow 2021-09-06 2021-11-30
4.6
None Local Low Not required Partial Partial Partial
vim is vulnerable to Heap-based Buffer Overflow
3324 CVE-2021-3758 918 2021-09-02 2021-09-10
4.0
None Remote Low ??? None Partial None
bookstack is vulnerable to Server-Side Request Forgery (SSRF)
3325 CVE-2021-3747 732 2021-10-01 2021-10-04
4.6
None Local Low Not required Partial Partial Partial
The MacOS version of Multipass, version 1.7.0, fixed in 1.7.2, accidentally installed the application directory with incorrect owner.
3326 CVE-2021-3731 1021 2021-08-23 2021-08-27
4.3
None Remote Medium Not required None Partial None
LedgerSMB does not sufficiently guard against being wrapped by other sites, making it vulnerable to 'clickjacking'. This allows an attacker to trick a targetted user to execute unintended actions.
3327 CVE-2021-3730 352 CSRF 2021-08-23 2021-08-26
4.3
None Remote Medium Not required None Partial None
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
3328 CVE-2021-3729 352 CSRF 2021-08-23 2021-08-26
4.3
None Remote Medium Not required None Partial None
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
3329 CVE-2021-3728 352 CSRF 2021-08-23 2021-08-26
4.3
None Remote Medium Not required None Partial None
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
3330 CVE-2021-3718 DoS 2021-11-12 2021-11-23
4.7
None Local Medium Not required None None Complete
A denial of service vulnerability was reported in some ThinkPad models that could cause a system to crash when the Enhanced Biometrics setting is enabled in BIOS.
3331 CVE-2021-3713 787 Exec Code 2021-08-25 2021-10-18
4.6
None Local Low Not required Partial Partial Partial
An out-of-bounds write flaw was found in the UAS (USB Attached SCSI) device emulation of QEMU in versions prior to 6.2.0-rc0. The device uses the guest supplied stream number unchecked, which can lead to out-of-bounds access to the UASDevice->data3 and UASDevice->status3 fields. A malicious guest user could use this flaw to crash QEMU or potentially achieve code execution with the privileges of the QEMU process on the host.
3332 CVE-2021-3710 22 Dir. Trav. 2021-10-01 2021-10-08
4.7
None Local Medium Not required Complete None None
An information disclosure via path traversal was discovered in apport/hookutils.py function read_file(). This issue affects: apport 2.14.1 versions prior to 2.14.1-0ubuntu3.29+esm8; 2.20.1 versions prior to 2.20.1-0ubuntu2.30+esm2; 2.20.9 versions prior to 2.20.9-0ubuntu7.26; 2.20.11 versions prior to 2.20.11-0ubuntu27.20; 2.20.11 versions prior to 2.20.11-0ubuntu65.3;
3333 CVE-2021-3683 352 CSRF 2021-11-13 2021-11-16
4.3
None Remote Medium Not required None Partial None
showdoc is vulnerable to Cross-Site Request Forgery (CSRF)
3334 CVE-2021-3680 326 2021-08-04 2021-08-11
4.0
None Remote Low ??? None Partial None
showdoc is vulnerable to Missing Cryptographic Step
3335 CVE-2021-3678 338 2021-08-04 2021-08-11
4.3
None Remote Medium Not required Partial None None
showdoc is vulnerable to Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG)
3336 CVE-2021-3671 476 2021-10-12 2021-10-19
4.0
None Remote Low ??? None None Partial
A null pointer de-reference was found in the way samba kerberos server handled missing sname in TGS-REQ (Ticket Granting Server - Request). An authenticated user could use this flaw to crash the samba server.
3337 CVE-2021-3646 79 XSS 2021-09-10 2021-09-21
4.3
None Remote Medium Not required None Partial None
btcpayserver is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
3338 CVE-2021-3636 287 2021-07-30 2021-08-09
4.1
None Local Network Low ??? Partial Partial None
It was found in OpenShift, before version 4.8, that the generated certificate for the in-cluster Service CA, incorrectly included additional certificates. The Service CA is automatically mounted into all pods, allowing them to safely connect to trusted in-cluster services that present certificates signed by the trusted Service CA. The incorrect inclusion of additional CAs in this certificate would allow an attacker that compromises any of the additional CAs to masquerade as a trusted in-cluster service.
3339 CVE-2021-3635 119 Overflow 2021-08-13 2021-08-23
4.9
None Local Low Not required None None Complete
A flaw was found in the Linux kernel netfilter implementation in versions prior to 5.5-rc7. A user with root (CAP_SYS_ADMIN) access is able to panic the system when issuing netfilter netflow commands.
3340 CVE-2021-3634 119 Overflow 2021-08-31 2021-10-18
4.0
None Remote Low ??? None None Partial
A flaw has been found in libssh in versions prior to 0.9.6. The SSH protocol keeps track of two shared secrets during the lifetime of the session. One of them is called secret_hash and the other session_id. Initially, both of them are the same, but after key re-exchange, previous session_id is kept and used as an input to new secret_hash. Historically, both of these buffers had shared length variable, which worked as long as these buffers were same. But the key re-exchange operation can also change the key exchange method, which can be based on hash of different size, eventually creating "secret_hash" of different size than the session_id has. This becomes an issue when the session_id memory is zeroed or when it is used again during second key re-exchange.
3341 CVE-2021-3630 787 2021-06-30 2021-07-15
4.3
None Remote Medium Not required None None Partial
An out-of-bounds write vulnerability was found in DjVuLibre in DJVU::DjVuTXT::decode() in DjVuText.cpp via a crafted djvu file which may lead to crash and segmentation fault. This flaw affects DjVuLibre versions prior to 3.5.28.
3342 CVE-2021-3626 269 2021-10-01 2021-10-05
4.6
None Local Low Not required Partial Partial Partial
The Windows version of Multipass before 1.7.0 allowed any local process to connect to the localhost TCP control socket to perform mounts from the operating system to a guest, allowing for privilege escalation.
3343 CVE-2021-3615 94 Exec Code 2021-08-17 2021-08-30
4.6
None Local Low Not required Partial Partial Partial
A vulnerability was reported in Lenovo Smart Camera X3, X5, and C2E that could allow code execution if a specific file exists on the attached SD card. This vulnerability is the same as CNVD-2021-45262.
3344 CVE-2021-3614 2021-07-16 2021-07-30
4.4
None Local Medium Not required Partial Partial Partial
A vulnerability was reported on some Lenovo Notebook systems that could allow an attacker with physical access to elevate privileges under certain conditions during a BIOS update performed by Lenovo Vantage.
3345 CVE-2021-3613 427 2021-07-02 2021-07-09
4.4
None Local Medium Not required Partial Partial Partial
OpenVPN Connect 3.2.0 through 3.3.0 allows local users to load arbitrary dynamic loadable libraries via an OpenSSL configuration file if present, which allows the user to run arbitrary code with the same privilege level as the main OpenVPN process (OpenVPNConnect.exe).
3346 CVE-2021-3606 427 2021-07-02 2021-07-09
4.4
None Local Medium Not required Partial Partial Partial
OpenVPN before version 2.5.3 on Windows allows local users to load arbitrary dynamic loadable libraries via an OpenSSL configuration file if present, which allows the user to run arbitrary code with the same privilege level as the main OpenVPN process (openvpn.exe).
3347 CVE-2021-3605 125 2021-08-25 2021-09-01
4.3
None Remote Medium Not required None None Partial
There's a flaw in OpenEXR's rleUncompress functionality in versions prior to 3.0.5. An attacker who is able to submit a crafted file to an application linked with OpenEXR could cause an out-of-bounds read. The greatest risk from this flaw is to application availability.
3348 CVE-2021-3579 276 2021-10-28 2021-11-28
4.6
None Local Low Not required Partial Partial Partial
Incorrect Default Permissions vulnerability in the bdservicehost.exe and Vulnerability.Scan.exe components as used in Bitdefender Endpoint Security Tools for Windows, Total Security allows a local attacker to elevate privileges to NT AUTHORITY\SYSTEM This issue affects: Bitdefender Endpoint Security Tools for Windows versions prior to 7.2.1.65. Bitdefender Total Security versions prior to 7.2.1.65.
3349 CVE-2021-3576 269 2021-10-28 2021-12-03
4.6
None Local Low Not required Partial Partial Partial
Execution with Unnecessary Privileges vulnerability in Bitdefender Endpoint Security Tools, Total Security allows a local attacker to elevate to 'NT AUTHORITY\System. Impersonation enables the server thread to perform actions on behalf of the client but within the limits of the client's security context. This issue affects: Bitdefender Endpoint Security Tools versions prior to 7.2.1.65. Bitdefender Total Security versions prior to 25.0.26.
3350 CVE-2021-3566 2021-08-05 2021-09-20
4.3
None Remote Medium Not required Partial None None
Prior to ffmpeg version 4.3, the tty demuxer did not have a 'read_probe' function assigned to it. By crafting a legitimate "ffconcat" file that references an image, followed by a file the triggers the tty demuxer, the contents of the second file will be copied into the output file verbatim (as long as the `-vcodec copy` option is passed to ffmpeg).
Total number of vulnerabilities : 38405   Page : 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 (This Page)68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558 559 560 561 562 563 564 565 566 567 568 569 570 571 572 573 574 575 576 577 578 579 580 581 582 583 584 585 586 587 588 589 590 591 592 593 594 595 596 597 598 599 600 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617 618 619 620 621 622 623 624 625 626 627 628 629 630 631 632 633 634 635 636 637 638 639 640 641 642 643 644 645 646 647 648 649 650 651 652 653 654 655 656 657 658 659 660 661 662 663 664 665 666 667 668 669 670 671 672 673 674 675 676 677 678 679 680 681 682 683 684 685 686 687 688 689 690 691 692 693 694 695 696 697 698 699 700 701 702 703 704 705 706 707 708 709 710 711 712 713 714 715 716 717 718 719 720 721 722 723 724 725 726 727 728 729 730 731 732 733 734 735 736 737 738 739 740 741 742 743 744 745 746 747 748 749 750 751 752 753 754 755 756 757 758 759 760 761 762 763 764 765 766 767 768 769
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.