CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  What's the CVSS score of your company?
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Security Vulnerabilities (CVSS score between 7 and 7.99)

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
1151 CVE-2021-23449 915 Exec Code 2021-10-18 2021-11-04
7.5
None Remote Low Not required Partial Partial Partial
This affects the package vm2 before 3.9.4 via a Prototype Pollution attack vector, which can lead to execution of arbitrary code on the host machine.
1152 CVE-2021-23448 913 2021-10-11 2021-10-19
7.5
None Remote Low Not required Partial Partial Partial
All versions of package config-handler are vulnerable to Prototype Pollution when loading config files.
1153 CVE-2021-23444 843 Bypass 2021-09-21 2021-10-02
7.5
None Remote Low Not required Partial Partial Partial
This affects the package jointjs before 3.4.2. A type confusion vulnerability can lead to a bypass of CVE-2020-28480 when the user-provided keys used in the path parameter are arrays in the setByPath function.
1154 CVE-2021-23442 915 2021-09-17 2021-09-28
7.5
None Remote Low Not required Partial Partial Partial
This affects all versions of package @cookiex/deep. The global proto object can be polluted using the __proto__ object.
1155 CVE-2021-23441 502 DoS Exec Code 2021-09-19 2021-09-30
7.5
None Remote Low Not required Partial Partial Partial
All versions of package com.jsoniter:jsoniter are vulnerable to Deserialization of Untrusted Data via malicious JSON strings. This may lead to a Denial of Service, and in certain cases, code execution.
1156 CVE-2021-23440 843 Bypass 2021-09-12 2021-11-03
7.5
None Remote Low Not required Partial Partial Partial
This affects the package set-value before <2.0.1, >=3.0.0 <4.0.1. A type confusion vulnerability can lead to a bypass of CVE-2019-10747 when the user-provided keys used in the path parameter are arrays.
1157 CVE-2021-23438 843 Bypass 2021-09-01 2021-09-10
7.5
None Remote Low Not required Partial Partial Partial
This affects the package mpath before 0.8.4. A type confusion vulnerability can lead to a bypass of CVE-2018-16490. In particular, the condition ignoreProperties.indexOf(parts[i]) !== -1 returns -1 if parts[i] is ['__proto__']. This is because the method that has been called if the input is an array is Array.prototype.indexOf() and not String.prototype.indexOf(). They behave differently depending on the type of the input.
1158 CVE-2021-23436 843 Bypass 2021-09-01 2021-09-10
7.5
None Remote Low Not required Partial Partial Partial
This affects the package immer before 9.0.6. A type confusion vulnerability can lead to a bypass of CVE-2020-28477 when the user-provided keys used in the path parameter are arrays. In particular, this bypass is possible because the condition (p === "__proto__" || p === "constructor") in applyPatches_ returns false if p is ['__proto__'] (or ['constructor']). The === operator (strict equality operator) returns false if the operands have different type.
1159 CVE-2021-23434 843 Bypass 2021-08-27 2021-10-04
7.5
None Remote Low Not required Partial Partial Partial
This affects the package object-path before 0.11.6. A type confusion vulnerability can lead to a bypass of CVE-2020-15256 when the path components used in the path parameter are arrays. In particular, the condition currentPath === '__proto__' returns false if currentPath is ['__proto__']. This is because the === operator returns always false when the type of the operands is different.
1160 CVE-2021-23432 2021-08-24 2021-08-31
7.5
None Remote Low Not required Partial Partial Partial
This affects all versions of package mootools. This is due to the ability to pass untrusted input to Object.merge()
1161 CVE-2021-23428 20 Dir. Trav. 2021-09-01 2021-09-09
7.5
None Remote Low Not required Partial Partial Partial
This affects all versions of package elFinder.NetCore. The Path.Combine(...) method is used to create an absolute file path. Due to missing sanitation of the user input and a missing check of the generated path its possible to escape the Files directory via path traversal
1162 CVE-2021-23427 20 2021-09-01 2021-09-09
7.5
None Remote Low Not required Partial Partial Partial
This affects all versions of package elFinder.NetCore. The ExtractAsync function within the FileSystem is vulnerable to arbitrary extraction due to insufficient validation.
1163 CVE-2021-23421 915 2021-08-11 2021-08-19
7.5
None Remote Low Not required Partial Partial Partial
All versions of package merge-change are vulnerable to Prototype Pollution via the utils.set function.
1164 CVE-2021-23418 611 2021-07-29 2021-08-05
7.5
None Remote Low Not required Partial Partial Partial
The package glances before 3.2.1 are vulnerable to XML External Entity (XXE) Injection via the use of Fault to parse untrusted XML data, which is known to be vulnerable to XML attacks.
1165 CVE-2021-23417 915 2021-07-28 2021-08-05
7.5
None Remote Low Not required Partial Partial Partial
All versions of package deepmergefn are vulnerable to Prototype Pollution via deepMerge function.
1166 CVE-2021-23412 77 Exec Code 2021-07-23 2021-08-02
7.5
None Remote Low Not required Partial Partial Partial
All versions of package gitlogplus are vulnerable to Command Injection via the main functionality, as options attributes are appended to the command to be executed without sanitization.
1167 CVE-2021-23410 502 2021-07-21 2021-07-29
7.5
None Remote Low Not required Partial Partial Partial
All versions of package msgpack are vulnerable to Deserialization of Untrusted Data via the unpack function. N.B: this affects the NPM package [msgpack](https://www.npmjs.com/package/msgpack) only, NOT the more popular package [@msgpack/msgpack](https://www.npmjs.com/package/@msgpack/msgpack).
1168 CVE-2021-23406 2021-08-24 2021-08-30
7.5
None Remote Low Not required Partial Partial Partial
This affects the package pac-resolver before 5.0.0. This can occur when used with untrusted input, due to unsafe PAC file handling. **NOTE:** The fix for this vulnerability is applied in the node-degenerator library, a dependency written by the same maintainer.
1169 CVE-2021-23403 915 2021-07-02 2021-07-06
7.5
None Remote Low Not required Partial Partial Partial
All versions of package ts-nodash are vulnerable to Prototype Pollution via the Merge() function due to lack of validation input.
1170 CVE-2021-23402 915 2021-07-02 2021-07-06
7.5
None Remote Low Not required Partial Partial Partial
All versions of package record-like-deep-assign are vulnerable to Prototype Pollution via the main functionality.
1171 CVE-2021-23399 20 Exec Code 2021-06-28 2021-07-01
7.5
None Remote Low Not required Partial Partial Partial
This affects all versions of package wincred. If attacker-controlled user input is given to the getCredential function, it is possible for an attacker to execute arbitrary commands. This is due to use of the child_process exec function without input sanitization.
1172 CVE-2021-23396 2021-06-17 2021-06-24
7.5
None Remote Low Not required Partial Partial Partial
All versions of package lutils are vulnerable to Prototype Pollution via the main (merge) function.
1173 CVE-2021-23390 94 Exec Code 2021-07-12 2021-07-14
7.5
None Remote Low Not required Partial Partial Partial
The package total4 before 0.0.43 are vulnerable to Arbitrary Code Execution via the U.set() and U.get() functions.
1174 CVE-2021-23389 94 Exec Code 2021-07-12 2021-07-14
7.5
None Remote Low Not required Partial Partial Partial
The package total.js before 3.4.9 are vulnerable to Arbitrary Code Execution via the U.set() and U.get() functions.
1175 CVE-2021-23383 2021-05-04 2021-06-18
7.5
None Remote Low Not required Partial Partial Partial
The package handlebars before 4.7.7 are vulnerable to Prototype Pollution when selecting certain compiling options to compile templates coming from an untrusted source.
1176 CVE-2021-23381 77 Exec Code 2021-04-18 2021-04-23
7.5
None Remote Low Not required Partial Partial Partial
This affects all versions of package killing. If attacker-controlled user input is given, it is possible for an attacker to execute arbitrary commands. This is due to use of the child_process exec function without input sanitization.
1177 CVE-2021-23380 77 Exec Code 2021-04-18 2021-04-23
7.5
None Remote Low Not required Partial Partial Partial
This affects all versions of package roar-pidusage. If attacker-controlled user input is given to the stat function of this package on certain operating systems, it is possible for an attacker to execute arbitrary commands. This is due to use of the child_process exec function without input sanitization.
1178 CVE-2021-23379 77 Exec Code 2021-04-18 2021-04-23
7.5
None Remote Low Not required Partial Partial Partial
This affects all versions of package portkiller. If (attacker-controlled) user input is given, it is possible for an attacker to execute arbitrary commands. This is due to use of the child_process exec function without input sanitization.
1179 CVE-2021-23378 77 Exec Code 2021-04-18 2021-04-22
7.5
None Remote Low Not required Partial Partial Partial
This affects all versions of package picotts. If attacker-controlled user input is given to the say function, it is possible for an attacker to execute arbitrary commands. This is due to use of the child_process exec function without input sanitization.
1180 CVE-2021-23377 77 Exec Code 2021-04-18 2021-04-22
7.5
None Remote Low Not required Partial Partial Partial
This affects all versions of package onion-oled-js. If attacker-controlled user input is given to the scroll function, it is possible for an attacker to execute arbitrary commands. This is due to use of the child_process exec function without input sanitization.
1181 CVE-2021-23376 77 Exec Code 2021-04-18 2021-04-22
7.5
None Remote Low Not required Partial Partial Partial
This affects all versions of package ffmpegdotjs. If attacker-controlled user input is given to the trimvideo function, it is possible for an attacker to execute arbitrary commands. This is due to use of the child_process exec function without input sanitization.
1182 CVE-2021-23375 77 Exec Code 2021-04-18 2021-04-22
7.5
None Remote Low Not required Partial Partial Partial
This affects all versions of package psnode. If attacker-controlled user input is given to the kill function, it is possible for an attacker to execute arbitrary commands. This is due to use of the child_process exec function without input sanitization.
1183 CVE-2021-23374 77 Exec Code 2021-04-18 2021-04-22
7.5
None Remote Low Not required Partial Partial Partial
This affects all versions of package ps-visitor. If attacker-controlled user input is given to the kill function, it is possible for an attacker to execute arbitrary commands. This is due to use of the child_process exec function without input sanitization.
1184 CVE-2021-23370 2021-04-12 2021-04-20
7.5
None Remote Low Not required Partial Partial Partial
This affects the package swiper before 6.5.1.
1185 CVE-2021-23369 Exec Code 2021-04-12 2021-06-08
7.5
None Remote Low Not required Partial Partial Partial
The package handlebars before 4.7.7 are vulnerable to Remote Code Execution (RCE) when selecting certain compiling options to compile templates coming from an untrusted source.
1186 CVE-2021-23356 77 Exec Code 2021-03-15 2021-03-18
7.5
None Remote Low Not required Partial Partial Partial
This affects all versions of package kill-process-by-name. If (attacker-controlled) user input is given, it is possible for an attacker to execute arbitrary commands. This is due to use of the child_process exec function without input sanitization in the index.js file.
1187 CVE-2021-23355 77 Exec Code 2021-03-15 2021-03-16
7.5
None Remote Low Not required Partial Partial Partial
This affects all versions of package ps-kill. If (attacker-controlled) user input is given to the kill function, it is possible for an attacker to execute arbitrary commands. This is due to use of the child_process exec function without input sanitization in the index.js file. PoC (provided by reporter): var ps_kill = require('ps-kill'); ps_kill.kill('$(touch success)',function(){});
1188 CVE-2021-23352 89 Sql 2021-03-09 2021-03-13
7.5
None Remote Low Not required Partial Partial Partial
This affects the package madge before 4.0.1. It is possible to specify a custom Graphviz path via the graphVizPath option parameter which when the .image(), .svg() or .dot() functions are called, is executed by the childprocess.exec function.
1189 CVE-2021-23344 94 Exec Code 2021-03-04 2021-03-05
7.5
None Remote Low Not required Partial Partial Partial
The package total.js before 3.4.8 are vulnerable to Remote Code Execution (RCE) via set.
1190 CVE-2021-23334 94 Exec Code 2021-02-11 2021-02-17
7.5
None Remote Low Not required Partial Partial Partial
All versions of package static-eval are vulnerable to Arbitrary Code Execution using FunctionExpressions and TemplateLiterals. PoC: var evaluate = require('static-eval'); var parse = require('esprima').parse; var src="(function (x) { return ${eval("console.log(global.process.mainModule.constructor._load('child_process').execSync('ls').toString())")} })()" var ast = parse(src).body[0].expression; evaluate(ast)
1191 CVE-2021-23330 77 2021-02-01 2021-02-04
7.5
None Remote Low Not required Partial Partial Partial
All versions of package launchpad are vulnerable to Command Injection via stop.
1192 CVE-2021-23326 77 2021-01-20 2021-03-30
7.5
None Remote Low Not required Partial Partial Partial
This affects the package @graphql-tools/git-loader before 6.2.6. The use of exec and execSync in packages/loaders/git/src/load-git.ts allows arbitrary command injection.
1193 CVE-2021-23281 94 Exec Code 2021-04-13 2021-04-20
7.5
None Remote Low Not required Partial Partial Partial
Eaton Intelligent Power Manager (IPM) prior to 1.69 is vulnerable to unauthenticated remote code execution vulnerability. IPM software does not sanitize the date provided via coverterCheckList action in meta_driver_srv.js class. Attackers can send a specially crafted packet to make IPM connect to rouge SNMP server and execute attacker-controlled code.
1194 CVE-2021-23277 Exec Code 2021-04-13 2021-04-21
7.5
None Remote Low Not required Partial Partial Partial
Eaton Intelligent Power Manager (IPM) prior to 1.69 is vulnerable to unauthenticated eval injection vulnerability. The software does not neutralize code syntax from users before using in the dynamic evaluation call in loadUserFile function under scripts/libs/utils.js. Successful exploitation can allow attackers to control the input to the function and execute attacker controlled commands.
1195 CVE-2021-23275 269 2021-06-29 2021-07-07
7.2
None Local Low Not required Complete Complete Complete
The Windows Installation component of TIBCO Software Inc.'s TIBCO Enterprise Runtime for R - Server Edition, TIBCO Enterprise Runtime for R - Server Edition, TIBCO Enterprise Runtime for R - Server Edition, TIBCO Spotfire Analytics Platform for AWS Marketplace, TIBCO Spotfire Server, TIBCO Spotfire Server, TIBCO Spotfire Server, TIBCO Spotfire Statistics Services, TIBCO Spotfire Statistics Services, and TIBCO Spotfire Statistics Services contains a vulnerability that theoretically allows a low privileged attacker with local access on some versions of the Windows operating system to insert malicious software. The affected component can be abused to execute the malicious software inserted by the attacker with the elevated privileges of the component. This vulnerability results from a lack of access restrictions on certain files and/or folders in the installation. Affected releases are TIBCO Software Inc.'s TIBCO Enterprise Runtime for R - Server Edition: versions 1.2.4 and below, TIBCO Enterprise Runtime for R - Server Edition: versions 1.3.0 and 1.3.1, TIBCO Enterprise Runtime for R - Server Edition: versions 1.4.0, 1.5.0, and 1.6.0, TIBCO Spotfire Analytics Platform for AWS Marketplace: versions 11.3.0 and below, TIBCO Spotfire Server: versions 10.3.12 and below, TIBCO Spotfire Server: versions 10.4.0, 10.5.0, 10.6.0, 10.6.1, 10.7.0, 10.8.0, 10.8.1, 10.9.0, 10.10.0, 10.10.1, 10.10.2, 10.10.3, and 10.10.4, TIBCO Spotfire Server: versions 11.0.0, 11.1.0, 11.2.0, and 11.3.0, TIBCO Spotfire Statistics Services: versions 10.3.0 and below, TIBCO Spotfire Statistics Services: versions 10.10.0, 10.10.1, and 10.10.2, and TIBCO Spotfire Statistics Services: versions 11.1.0, 11.2.0, and 11.3.0.
1196 CVE-2021-23274 1021 2021-03-23 2021-03-26
7.5
None Remote Low Not required Partial Partial Partial
The Config UI component of TIBCO Software Inc.'s TIBCO API Exchange Gateway and TIBCO API Exchange Gateway Distribution for TIBCO Silver Fabric contains a vulnerability that theoretically allows an unauthenticated attacker with network access to execute a clickjacking attack on the affected system. A successful attack using this vulnerability does not require human interaction from a person other than the attacker. Affected releases are TIBCO Software Inc.'s TIBCO API Exchange Gateway: versions 2.3.3 and below and TIBCO API Exchange Gateway Distribution for TIBCO Silver Fabric: versions 2.3.3 and below.
1197 CVE-2021-23217 Exec Code 2021-11-20 2021-11-24
7.2
None Local Low Not required Complete Complete Complete
NVIDIA GPU and Tegra hardware contain a vulnerability in the internal microcontroller which may allow a user with elevated privileges to instantiate a specifically timed DMA write to corrupt code execution, which may impact confidentiality, integrity, or availability.
1198 CVE-2021-23201 DoS 2021-11-20 2021-11-24
7.2
None Local Low Not required Complete Complete Complete
NVIDIA GPU and Tegra hardware contain a vulnerability in an internal microcontroller which may allow a user with elevated privileges to generate valid microcode. This could lead to information disclosure, data corruption, or denial of service of the device.
1199 CVE-2021-23039 2021-09-14 2021-09-27
7.1
None Remote Medium Not required None None Complete
On version 16.0.x before 16.0.1.2, 15.1.x before 15.1.3, 14.1.x before 14.1.2.8, and all versions of 13.1.x and 12.1.x, when IPSec is configured on a BIG-IP system, undisclosed requests from an authorized remote (IPSec) peer, which already has a negotiated Security Association, can cause the Traffic Management Microkernel (TMM) to terminate. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
1200 CVE-2021-23035 2021-09-14 2021-09-27
7.1
None Remote Medium Not required None None Complete
On BIG-IP 14.1.x before 14.1.4.4, when an HTTP profile is configured on a virtual server, after a specific sequence of packets, chunked responses can cause the Traffic Management Microkernel (TMM) to terminate. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Total number of vulnerabilities : 32999   Page : 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 (This Page)25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558 559 560 561 562 563 564 565 566 567 568 569 570 571 572 573 574 575 576 577 578 579 580 581 582 583 584 585 586 587 588 589 590 591 592 593 594 595 596 597 598 599 600 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617 618 619 620 621 622 623 624 625 626 627 628 629 630 631 632 633 634 635 636 637 638 639 640 641 642 643 644 645 646 647 648 649 650 651 652 653 654 655 656 657 658 659 660
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.