CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  What's the CVSS score of your company?
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Security Vulnerabilities Published In 2005(Overflow)

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
501 CVE-2005-0199 DoS Exec Code Overflow 2005-05-02 2017-07-11
7.5
None Remote Low Not required Partial Partial Partial
Integer underflow in the Lists_MakeMask() function in lists.c in ngIRCd before 0.8.2 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a long MODE line that causes an incorrect length calculation, which leads to a buffer overflow.
502 CVE-2005-0193 Exec Code Overflow 2005-01-22 2017-07-11
7.2
None Local Low Not required Complete Complete Complete
Buffer overflow in the (1) -v and (2) -a switches in mRouter in iSync 1.5 in Mac OS X 10.3.7 and earlier allows local users to execute arbitrary code.
503 CVE-2005-0191 Exec Code Overflow 2005-01-19 2017-11-16
5.1
None Remote High Not required Partial Partial Partial
Off-by-one buffer overflow in the processing of tags in Real Metadata Package (RMP) files in RealPlayer 10.5 (6.0.12.1040) and earlier could allow remote attackers to execute arbitrary code via a long tag.
504 CVE-2005-0187 Exec Code Overflow 2005-05-02 2017-07-11
7.5
None Remote Low Not required Partial Partial Partial
Stack-based buffer overflow in the SetSkin function in AtHoc toolbar allows remote attackers to execute arbitrary code via a long skin name.
505 CVE-2005-0185 Exec Code Overflow 2005-05-02 2017-07-11
7.5
None Remote Low Not required Partial Partial Partial
Stack-based buffer overflow in NodeManager Professional 2.00 allows remote attackers to execute arbitrary commands via a LinkDown-Trap packet that contains a long OCTET-STRING in the Trap variable-bindings field.
506 CVE-2005-0177 119 DoS Overflow 2005-03-07 2017-10-11
7.8
None Remote Low Not required None None Complete
nls_ascii.c in Linux before 2.6.8.1 uses an incorrect table size, which allows attackers to cause a denial of service (kernel crash) via a buffer overflow.
507 CVE-2005-0162 Exec Code Overflow 2005-01-26 2019-07-29
7.2
None Local Low Not required Complete Complete Complete
Stack-based buffer overflow in the get_internal_addresses function in the pluto application for Openswan 1.x before 1.0.9, and Openswan 2.x before 2.3.0, when compiled with XAUTH and PAM enabled, allows remote authenticated attackers to execute arbitrary code.
508 CVE-2005-0160 Exec Code Overflow 2005-02-22 2008-09-05
5.1
None Remote High Not required Partial Partial Partial
Multiple buffer overflows in unace 1.2b allow attackers to execute arbitrary code via (1) 2 overflows in ACE archives, (2) a long command line argument, or (3) certain "Ready for next volume" messages.
509 CVE-2005-0156 Exec Code Overflow 2005-02-07 2018-08-13
2.1
None Local Low Not required None Partial None
Buffer overflow in the PerlIO implementation in Perl 5.8.0, when installed with setuid support (sperl), allows local users to execute arbitrary code by setting the PERLIO_DEBUG variable and executing a Perl script whose full pathname contains a long directory tree.
510 CVE-2005-0140 Exec Code Overflow 2005-05-02 2017-07-11
7.5
None Remote Low Not required Partial Partial Partial
Buffer overflow in PeID allows attackers to execute arbitrary code via a PE file with an Import Address Table containing a long import library name.
511 CVE-2005-0124 DoS Exec Code Overflow 2005-04-14 2018-10-19
2.1
None Local Low Not required None None Partial
The coda_pioctl function in the coda functionality (pioctl.c) for Linux kernel 2.6.9 and 2.4.x before 2.4.29 may allow local users to cause a denial of service (crash) or execute arbitrary code via negative vi.in_size or vi.out_size values, which may trigger a buffer overflow.
512 CVE-2005-0121 Exec Code Overflow 2005-05-02 2017-07-11
4.6
None Local Low Not required Partial Partial Partial
Multiple buffer overflows in golddig 2.0 and earlier allow local users to execute arbitrary code via (1) a long map name command line argument or (2) a long username as recorded in the USER environment variable.
513 CVE-2005-0117 Exec Code Overflow 2005-01-11 2008-09-05
4.6
None Local Low Not required Partial Partial Partial
Buffer overflow in XShisen before 1.36 allows local users to execute arbitrary code via a long GECOS field.
514 CVE-2005-0115 Exec Code Overflow 2005-01-24 2017-07-11
7.5
None Remote Low Not required Partial Partial Partial
Stack-based buffer overflow in DataRescue Interactive Disassembler (IDA) Pro 4.7 allows attackers to execute arbitrary code via a PE file with an Import Address Table containing a long import library name.
515 CVE-2005-0111 Exec Code Overflow 2005-01-13 2011-03-08
7.5
None Remote Low Not required Partial Partial Partial
Stack-based buffer overflow in the websql CGI program in MySQL MaxDB 7.5.00 allows remote attackers to execute arbitrary code via a long password parameter.
516 CVE-2005-0102 Exec Code Overflow 2005-01-24 2018-10-03
7.2
None Local Low Not required Complete Complete Complete
Integer overflow in camel-lock-helper in Evolution 2.0.2 and earlier allows local users or remote malicious POP3 servers to execute arbitrary code via a length value of -1, which leads to a zero byte memory allocation and a buffer overflow.
517 CVE-2005-0101 Exec Code Overflow 2005-02-01 2017-07-11
7.5
None Remote Low Not required Partial Partial Partial
Buffer overflow in the socket_getline function in Newspost 2.1.1 and earlier allows remote malicious NNTP servers to execute arbitrary code via a long string without a newline character.
518 CVE-2005-0098 Exec Code Overflow 2005-03-08 2008-09-05
4.6
None Local Low Not required Partial Partial Partial
Multiple buffer overflows in the SDL port of abuse (abuse-SDL) before 2.00 allow local users to execute arbitrary code via the command line.
519 CVE-2005-0094 DoS Overflow 2005-01-15 2017-10-11
5.0
None Remote Low Not required None None Partial
Buffer overflow in the gopherToHTML function in the Gopher reply parser for Squid 2.5.STABLE7 and earlier allows remote malicious Gopher servers to cause a denial of service (crash) via crafted responses.
520 CVE-2005-0086 DoS Exec Code Overflow 2005-05-02 2017-10-11
7.5
None Remote Low Not required Partial Partial Partial
Heap-based buffer overflow in less in Red Hat Enterprise Linux 3 allows attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted file, as demonstrated using the UTF-8 locale.
521 CVE-2005-0084 Exec Code Overflow 2005-05-02 2017-10-11
7.5
None Remote Low Not required Partial Partial Partial
Buffer overflow in the X11 dissector in Ethereal 0.8.10 through 0.10.8 allows remote attackers to execute arbitrary code via a crafted packet.
522 CVE-2005-0079 DoS Overflow 2005-05-02 2017-07-11
4.6
None Local Low Not required Partial Partial Partial
Buffer overflow in xtrlock 2.0 allows local users to cause a denial of service (application crash) and hijack the desktop session.
523 CVE-2005-0076 Exec Code Overflow 2005-05-02 2017-07-11
7.2
None Local Low Not required Complete Complete Complete
Multiple buffer overflows in the XView library 3.2 may allow local users to execute arbitrary code via setuid applications that use the library.
524 CVE-2005-0074 Exec Code Overflow 2005-02-11 2008-09-05
7.2
None Local Low Not required Complete Complete Complete
Buffer overflow in pcdsvgaview in xpcd 2.08 allows local users to execute arbitrary code.
525 CVE-2005-0073 Exec Code Overflow 2005-05-02 2008-09-05
4.6
None Local Low Not required Partial Partial Partial
Buffer overflow in queue.c in a support script for sympa 3.3.3, when running setuid, allows local users to execute arbitrary code.
526 CVE-2005-0064 Exec Code Overflow 2005-05-02 2017-10-11
7.5
None Remote Low Not required Partial Partial Partial
Buffer overflow in the Decrypt::makeFileKey2 function in Decrypt.cc for xpdf 3.00 and earlier allows remote attackers to execute arbitrary code via a PDF file with a large /Encrypt /Length keyLength value.
527 CVE-2005-0060 Overflow +Priv 2005-05-02 2019-04-30
7.2
None Local Low Not required Complete Complete Complete
Buffer overflow in the font processing component of Microsoft Windows 2000, Windows XP SP1 and SP2, and Windows Server 2003 allows local users to gain privileges via a specially-designed application.
528 CVE-2005-0059 Exec Code Overflow 2005-05-02 2019-04-30
10.0
None Remote Low Not required Complete Complete Complete
Buffer overflow in the Message Queuing component of Microsoft Windows 2000 and Windows XP SP1 allows remote attackers to execute arbitrary code via a crafted message.
529 CVE-2005-0058 Exec Code Overflow 2005-08-10 2018-10-12
7.5
None Remote Low Not required Partial Partial Partial
Buffer overflow in the Telephony Application Programming Interface (TAPI) for Microsoft Windows 98, Windows 98 SE, Windows ME, Windows 2000, Windows XP, and Windows Server 2003 allows attackers to elevate privileges or execute arbitrary code via a crafted message.
530 CVE-2005-0057 Exec Code Overflow 2005-05-02 2019-04-30
7.5
None Remote Low Not required Partial Partial Partial
The Hyperlink Object Library for Windows 98, 2000, XP, and Server 2003 allows remote attackers to execute arbitrary code via a crafted link that triggers an "unchecked buffer" in the library, possibly due to a buffer overflow.
531 CVE-2005-0043 Exec Code Overflow 2005-05-02 2017-07-11
7.5
None Remote Low Not required Partial Partial Partial
Buffer overflow in Apple iTunes 4.7 allows remote attackers to execute arbitrary code via a long URL in (1) .m3u or (2) .pls playlist files.
532 CVE-2005-0033 DoS Overflow 2005-05-02 2017-07-11
5.0
None Remote Low Not required None None Partial
Buffer overflow in the code for recursion and glue fetching in BIND 8.4.4 and 8.4.5 allows remote attackers to cause a denial of service (crash) via queries that trigger the overflow in the q_usedns array that tracks nameservers and addresses.
533 CVE-2005-0022 Exec Code Overflow 2005-05-02 2017-10-11
4.6
None Local Low Not required Partial Partial Partial
Buffer overflow in the spa_base64_to_bits function in Exim before 4.43, as originally obtained from Samba code, and as called by the auth_spa_client function, may allow attackers to execute arbitrary code during SPA authentication.
534 CVE-2005-0021 Exec Code Overflow 2005-05-02 2017-10-11
7.2
None Local Low Not required Complete Complete Complete
Multiple buffer overflows in Exim before 4.43 may allow attackers to execute arbitrary code via (1) an IPv6 address with more than 8 components, as demonstrated using the -be command line option, which triggers an overflow in the host_aton function, or (2) the -bh command line option or dnsdb PTR lookup, which triggers an overflow in the dns_build_reverse function.
535 CVE-2005-0020 Exec Code Overflow 2005-04-14 2017-07-11
7.2
None Local Low Not required Complete Complete Complete
Buffer overflow in playmidi before 2.4 allows local users to execute arbitrary code.
536 CVE-2005-0016 Exec Code Overflow 2005-04-14 2017-07-11
7.2
None Local Low Not required Complete Complete Complete
Buffer overflow in the exported_display function in xatitv in gatos before 0.0.5 allows local users to execute arbitrary code.
537 CVE-2005-0014 Exec Code Overflow 2005-05-02 2018-10-19
7.5
None Remote Low Not required Partial Partial Partial
Buffer overflow in ncplogin in ncpfs before 2.2.6 allows remote malicious NetWare servers to execute arbitrary code on the NetWare client.
538 CVE-2005-0011 Exec Code Overflow 2005-05-02 2008-09-05
10.0
None Remote Low Not required Complete Complete Complete
Multiple vulnerabilities in fliccd, when installed setuid root as part of the kdeedu Kstars support for Instrument Neutral Distributed Interface (INDI) in KDE 3.3 to 3.3.2, allow local users and remote attackers to execute arbitrary code via stack-based buffer overflows.
539 CVE-2005-0005 Exec Code Overflow 2005-05-02 2017-10-11
7.5
None Remote Low Not required Partial Partial Partial
Heap-based buffer overflow in psd.c for ImageMagick 6.1.0, 6.1.7, and possibly earlier versions allows remote attackers to execute arbitrary code via a .PSD image file with a large number of layers.
540 CVE-2004-1311 DoS Exec Code Overflow 2005-01-10 2017-07-11
10.0
None Remote Low Not required Complete Complete Complete
Integer overflow in the real_setup_and_get_header function in real.c for Unix MPlayer 1.0pre5 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a Real RTSP streaming media file with a -1 content-length field, which leads to a heap-based buffer overflow.
541 CVE-2004-1310 Exec Code Overflow 2005-01-10 2017-07-11
10.0
None Remote Low Not required Complete Complete Complete
Stack-based buffer overflow in the asf_mmst_streaming.c functionality for MPlayer 1.0pre5 allows remote attackers to execute arbitrary code via a large MMST stream packet.
542 CVE-2004-1309 Exec Code Overflow 2005-01-10 2017-07-11
10.0
None Remote Low Not required Complete Complete Complete
Heap-based buffer overflow in the demux_open_bmp function in demux_bmp.c for Unix MPlayer 1.0pre5 allows remote attackers to execute arbitrary code via a bitmap (BMP) file containing a large biClrUsed field.
543 CVE-2004-1308 Exec Code Overflow 2005-01-10 2017-10-11
10.0
None Remote Low Not required Complete Complete Complete
Integer overflow in (1) tif_dirread.c and (2) tif_fax3.c for libtiff 3.5.7 and 3.7.0 allows remote attackers to execute arbitrary code via a TIFF file containing a TIFF_ASCII or TIFF_UNDEFINED directory entry with a -1 entry count, which leads to a heap-based buffer overflow.
544 CVE-2004-1304 Exec Code Overflow 2005-01-10 2017-07-11
10.0
None Remote Low Not required Complete Complete Complete
Stack-based buffer overflow in the ELF header parsing code in file before 4.12 allows attackers to execute arbitrary code via a crafted ELF file.
545 CVE-2004-1303 Exec Code Overflow 2005-01-10 2017-07-11
10.0
None Remote Low Not required Complete Complete Complete
Buffer overflow in the get function in get.c for Yanf 0.4 allows remote malicious web servers to execute arbitrary code via crafted HTTP responses.
546 CVE-2004-1301 Exec Code Overflow 2005-01-10 2017-07-11
10.0
None Remote Low Not required Complete Complete Complete
Buffer overflow in the book_format_sql function in format.c for xlreader 0.9.0 allows remote attackers to execute arbitrary code via a crafted Excel (XLS) file.
547 CVE-2004-1300 Exec Code Overflow 2005-01-10 2017-07-11
10.0
None Remote Low Not required Complete Complete Complete
Buffer overflow in the open_aiff_file function in demux_aiff.c for xine-lib (libxine) 1-rc7 allows remote attackers to execute arbitrary code via a crafted AIFF file.
548 CVE-2004-1299 Exec Code Overflow 2005-01-10 2017-07-11
10.0
None Remote Low Not required Complete Complete Complete
Buffer overflow in the get_attr function in html.c for vilistextum 2.6.6 allows remote attackers to execute arbitrary code via a crafted web page.
549 CVE-2004-1298 Exec Code Overflow 2005-01-10 2017-07-11
10.0
None Remote Low Not required Complete Complete Complete
Buffer overflow in the parse function in vb2c.c for vb2c 0.02 allows remote attackers to execute arbitrary code via a crafted FRM file.
550 CVE-2004-1297 Exec Code Overflow 2005-01-10 2017-07-11
10.0
None Remote Low Not required Complete Complete Complete
Buffer overflow in the process_font_table function in convert.c for unrtf 0.19.3 allows remote attackers to execute arbitrary code via a crafted RTF file.
Total number of vulnerabilities : 657   Page : 1 2 3 4 5 6 7 8 9 10 11 (This Page)12 13 14
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.