CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  What's the CVSS score of your company?
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Security Vulnerabilities Published In April 2021 (CVSS score >= 7)

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
1 CVE-2021-31875 787 Overflow 2021-04-29 2021-05-10
7.5
None Remote Low Not required Partial Partial Partial
In mjs_json.c in Cesanta MongooseOS mJS 1.26, a maliciously formed JSON string can trigger an off-by-one heap-based buffer overflow in mjs_json_parse, which can potentially lead to redirection of control flow.
2 CVE-2021-31873 190 Overflow 2021-04-30 2021-06-28
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in klibc before 2.0.9. Additions in the malloc() function may result in an integer overflow and a subsequent heap buffer overflow.
3 CVE-2021-31872 190 Overflow 2021-04-30 2021-06-28
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in klibc before 2.0.9. Multiple possible integer overflows in the cpio command on 32-bit systems may result in a buffer overflow or other security impact.
4 CVE-2021-31870 190 Overflow 2021-04-30 2021-06-28
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in klibc before 2.0.9. Multiplication in the calloc() function may result in an integer overflow and a subsequent heap buffer overflow.
5 CVE-2021-31784 787 DoS Exec Code 2021-04-26 2021-05-04
7.5
None Remote Low Not required Partial Partial Partial
An out-of-bounds write vulnerability exists in the file-reading procedure in Open Design Alliance Drawings SDK before 2021.6 on all supported by ODA platforms in static configuration. This can allow attackers to cause a crash, potentially enabling a denial of service attack (Crash, Exit, or Restart) or possible code execution.
6 CVE-2021-31776 428 2021-04-29 2021-05-13
7.2
None Local Low Not required Complete Complete Complete
Aviatrix VPN Client before 2.14.14 on Windows has an unquoted search path that enables local privilege escalation to the SYSTEM user, if the machine is misconfigured to allow unprivileged users to write to directories that are supposed to be restricted to administrators.
7 CVE-2021-31646 307 2021-04-26 2021-05-04
7.5
None Remote Low Not required Partial Partial Partial
Gestsup before 3.2.10 allows account takeover through the password recovery functionality (remote). The affected component is the file forgot_pwd.php - it uses a weak algorithm for the generation of password recovery tokens (the PHP uniqueid function), allowing a brute force attack.
8 CVE-2021-31597 295 2021-04-23 2021-12-08
7.5
None Remote Low Not required Partial Partial Partial
The xmlhttprequest-ssl package before 1.6.1 for Node.js disables SSL certificate validation by default, because rejectUnauthorized (when the property exists but is undefined) is considered to be false within the https.request function of Node.js. In other words, no certificate is ever rejected.
9 CVE-2021-31572 190 Overflow 2021-04-22 2021-06-02
7.5
None Remote Low Not required Partial Partial Partial
The kernel in Amazon Web Services FreeRTOS before 10.4.3 has an integer overflow in stream_buffer.c for a stream buffer.
10 CVE-2021-31571 190 Overflow 2021-04-22 2021-06-02
7.5
None Remote Low Not required Partial Partial Partial
The kernel in Amazon Web Services FreeRTOS before 10.4.3 has an integer overflow in queue.c for queue creation.
11 CVE-2021-31523 269 +Priv 2021-04-21 2021-04-29
7.2
None Local Low Not required Complete Complete Complete
The Debian xscreensaver 5.42+dfsg1-1 package for XScreenSaver has cap_net_raw enabled for the /usr/libexec/xscreensaver/sonar file, which allows local users to gain privileges because this is arguably incompatible with the design of the Mesa 3D Graphics library dependency.
12 CVE-2021-31414 Exec Code 2021-04-16 2021-04-21
7.5
None Remote Low Not required Partial Partial Partial
The unofficial vscode-rpm-spec extension before 0.3.2 for Visual Studio Code allows remote code execution via a crafted workspace configuration.
13 CVE-2021-31162 415 2021-04-14 2021-06-02
7.5
None Remote Low Not required Partial Partial Partial
In the standard library in Rust before 1.52.0, a double free can occur in the Vec::from_iter function if freeing the element panics.
14 CVE-2021-30503 863 Exec Code 2021-04-13 2021-04-23
7.5
None Remote Low Not required Partial Partial Partial
The unofficial GLSL Linting extension before 1.4.0 for Visual Studio Code allows remote code execution via a crafted glslangValidatorPath in the workspace configuration.
15 CVE-2021-30480 Exec Code 2021-04-09 2021-09-21
9.0
None Remote Low ??? Complete Complete Complete
Zoom Chat through 2021-04-09 on Windows and macOS allows certain remote authenticated attackers to execute arbitrary code without user interaction. An attacker must be within the same organization, or an external party who has been accepted as a contact. NOTE: this is specific to the Zoom Chat software, which is different from the chat feature of the Zoom Meetings and Zoom Video Webinars software.
16 CVE-2021-30476 2021-04-22 2021-04-29
7.5
None Remote Low Not required Partial Partial Partial
HashiCorp Terraform’s Vault Provider (terraform-provider-vault) did not correctly configure GCE-type bound labels for Vault’s GCP auth method. Fixed in 2.19.1.
17 CVE-2021-30463 59 +Priv 2021-04-08 2021-04-14
7.2
None Local Low Not required Complete Complete Complete
VestaCP through 0.9.8-24 allows attackers to gain privileges by creating symlinks to files for which they lack permissions. After reading the RKEY value from user.conf under the /usr/local/vesta/data/users/admin directory, the admin password can be changed via a /reset/?action=confirm&user=admin&code= URI. This occurs because chmod is used unsafely.
18 CVE-2021-30462 269 2021-04-08 2021-04-14
9.0
None Remote Low ??? Complete Complete Complete
VestaCP through 0.9.8-24 allows the admin user to escalate privileges to root because the Sudo configuration does not require a password to run /usr/local/vesta/bin scripts.
19 CVE-2021-30459 89 Sql 2021-04-14 2021-04-21
7.5
None Remote Low Not required Partial Partial Partial
A SQL Injection issue in the SQL Panel in Jazzband Django Debug Toolbar before 1.11.1, 2.x before 2.2.1, and 3.x before 3.2.1 allows attackers to execute SQL statements by changing the raw_sql input field of the SQL explain, analyze, or select form.
20 CVE-2021-30457 415 2021-04-07 2021-04-12
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in the id-map crate through 2021-02-26 for Rust. A double free can occur in remove_set upon a panic in a Drop impl.
21 CVE-2021-30456 415 2021-04-07 2021-04-12
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in the id-map crate through 2021-02-26 for Rust. A double free can occur in get_or_insert upon a panic of a user-provided f function.
22 CVE-2021-30455 415 2021-04-07 2021-04-12
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in the id-map crate through 2021-02-26 for Rust. A double free can occur in IdMap::clone_from upon a .clone panic.
23 CVE-2021-30454 119 Overflow 2021-04-07 2021-04-12
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in the outer_cgi crate before 0.2.1 for Rust. A user-provided Read instance receives an uninitialized memory buffer from KeyValueReader.
24 CVE-2021-30177 89 Exec Code Sql 2021-04-07 2021-04-13
7.5
None Remote Low Not required Partial Partial Partial
There is a SQL Injection vulnerability in PHP-Nuke 8.3.3 in the User Registration section, leading to remote code execution. This occurs because the U.S. state is not validated to be two letters, and the OrderBy field is not validated to be one of LASTNAME, CITY, or STATE.
25 CVE-2021-30176 89 Sql 2021-04-13 2021-04-14
7.5
None Remote Low Not required Partial Partial Partial
The ZEROF Expert pro/2.0 application for mobile devices allows SQL Injection via the Authorization header to the /v2/devices/add endpoint.
26 CVE-2021-30175 89 Sql 2021-04-13 2021-04-14
7.5
None Remote Low Not required Partial Partial Partial
ZEROF Web Server 1.0 (April 2021) allows SQL Injection via the /HandleEvent endpoint for the login page.
27 CVE-2021-30164 Bypass 2021-04-06 2021-06-02
7.5
None Remote Low Not required Partial Partial Partial
Redmine before 4.0.8 and 4.1.x before 4.1.2 allows attackers to bypass the add_issue_notes permission requirement by leveraging the Issues API.
28 CVE-2021-30149 434 2021-04-06 2021-04-08
7.5
None Remote Low Not required Partial Partial Partial
Composr 10.0.36 allows upload and execution of PHP files.
29 CVE-2021-30128 502 2021-04-27 2021-09-20
10.0
None Remote Low Not required Complete Complete Complete
Apache OFBiz has unsafe deserialization prior to 17.12.07 version
30 CVE-2021-30127 863 2021-04-03 2021-04-14
7.5
None Remote Low Not required Partial Partial Partial
TerraMaster F2-210 devices through 2021-04-03 use UPnP to make the admin web server accessible over the Internet on TCP port 8181, which is arguably inconsistent with the "It is only available on the local network" documentation. NOTE: manually editing /etc/upnp.json provides a partial but undocumented workaround.
31 CVE-2021-30072 787 Overflow 2021-04-02 2021-04-23
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in prog.cgi on D-Link DIR-878 1.30B08 devices. Because strcat is misused, there is a stack-based buffer overflow that does not require authentication.
32 CVE-2021-30000 89 Exec Code Sql 2021-04-02 2021-04-07
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in LATRIX 0.6.0. SQL injection in the txtaccesscode parameter of inandout.php leads to information disclosure and code execution.
33 CVE-2021-29999 787 Overflow 2021-04-13 2021-04-16
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in Wind River VxWorks through 6.8. There is a possible stack overflow in dhcp server.
34 CVE-2021-29998 787 Overflow 2021-04-13 2021-07-30
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in Wind River VxWorks before 6.5. There is a possible heap overflow in dhcp client.
35 CVE-2021-29942 787 2021-04-01 2021-04-06
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in the reorder crate through 2021-02-24 for Rust. swap_index can return uninitialized values if an iterator returns a len() that is too large.
36 CVE-2021-29941 787 2021-04-01 2021-04-06
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in the reorder crate through 2021-02-24 for Rust. swap_index has an out-of-bounds write if an iterator returns a len() that is too small.
37 CVE-2021-29940 415 2021-04-01 2021-04-06
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in the through crate through 2021-02-18 for Rust. There is a double free (in through and through_and) upon a panic of the map function.
38 CVE-2021-29939 787 2021-04-01 2021-04-06
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in the stackvector crate through 2021-02-19 for Rust. There is an out-of-bounds write in StackVec::extend if size_hint provides certain anomalous data.
39 CVE-2021-29937 2021-04-01 2021-04-06
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in the telemetry crate through 2021-02-17 for Rust. There is a drop of uninitialized memory if a value.clone() call panics within misc::vec_with_size().
40 CVE-2021-29936 908 2021-04-01 2021-04-06
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in the adtensor crate through 2021-01-11 for Rust. There is a drop of uninitialized memory via the FromIterator implementation for Vector and Matrix.
41 CVE-2021-29935 416 2021-04-01 2021-04-06
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in the rocket crate before 0.4.7 for Rust. uri::Formatter can have a use-after-free if a user-provided function panics.
42 CVE-2021-29934 125 2021-04-01 2021-04-06
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in PartialReader in the uu_od crate before 0.0.4 for Rust. Attackers can read the contents of uninitialized memory locations via a user-provided Read operation.
43 CVE-2021-29672 787 Exec Code Overflow 2021-04-26 2021-04-27
7.2
None Local Low Not required Complete Complete Complete
IBM Spectrum Protect Client 8.1.0.0-8 through 1.11.0 is vulnerable to a stack-based buffer overflow, caused by improper bounds checking when processing the current locale settings. A local attacker could overflow a buffer and execute arbitrary code on the system with elevated privileges or cause the application to crash. IBM X-Force ID: 199479
44 CVE-2021-29627 415 2021-04-07 2021-04-23
7.2
None Local Low Not required Complete Complete Complete
In FreeBSD 13.0-STABLE before n245050, 12.2-STABLE before r369525, 13.0-RC4 before p0, and 12.2-RELEASE before p6, listening socket accept filters implementing the accf_create callback incorrectly freed a process supplied argument string. Additional operations on the socket can lead to a double free or use after free.
45 CVE-2021-29465 94 Exec Code 2021-04-22 2021-04-27
7.5
None Remote Low Not required Partial Partial Partial
Discord-Recon is a bot for the Discord chat service. Versions of Discord-Recon 0.0.3 and prior contain a vulnerability in which a remote attacker is able to overwrite any file on the system with the command results. This can result in remote code execution when the user overwrite important files on the system. As a workaround, bot maintainers can edit their `setting.py` file then add `<` and `>` into the `RCE` variable inside of it to fix the issue without an update. The vulnerability is patched in version 0.0.4.
46 CVE-2021-29462 20 2021-04-20 2021-04-27
7.5
None Remote Low Not required Partial Partial Partial
The Portable SDK for UPnP Devices is an SDK for development of UPnP device and control point applications. The server part of pupnp (libupnp) appears to be vulnerable to DNS rebinding attacks because it does not check the value of the `Host` header. This can be mitigated by using DNS revolvers which block DNS-rebinding attacks. The vulnerability is fixed in version 1.14.6 and later.
47 CVE-2021-29461 94 Exec Code 2021-04-20 2021-06-07
9.0
None Remote Low ??? Complete Complete Complete
Discord Recon Server is a bot that allows one to do one's reconnaissance process from one's Discord. A vulnerability in Discord Recon Server prior to 0.0.3 could be exploited to read internal files from the system and write files into the system resulting in remote code execution. This issue has been fixed in version 0.0.3. As a workaround, one may copy the code from `assets/CommandInjection.py` in the Discord Recon Server code repository and overwrite vulnerable code from one's own Discord Recon Server implementation with code that contains the patch.
48 CVE-2021-29449 269 2021-04-14 2021-07-30
7.2
None Local Low Not required Complete Complete Complete
Pi-hole is a Linux network-level advertisement and Internet tracker blocking application. Multiple privilege escalation vulnerabilities were discovered in version 5.2.4 of Pi-hole core. See the referenced GitHub security advisory for details.
49 CVE-2021-29302 120 Exec Code Overflow 2021-04-12 2021-04-21
9.3
None Remote Medium Not required Complete Complete Complete
TP-Link TL-WR802N(US), Archer_C50v5_US v4_200 <= 2020.06 contains a buffer overflow vulnerability in the httpd process in the body message. The attack vector is: The attacker can get shell of the router by sending a message through the network, which may lead to remote code execution.
50 CVE-2021-29200 502 2021-04-27 2021-09-20
7.5
None Remote Low Not required Partial Partial Partial
Apache OFBiz has unsafe deserialization prior to 17.12.07 version An unauthenticated user can perform an RCE attack
Total number of vulnerabilities : 314   Page : 1 (This Page)2 3 4 5 6 7
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.