CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2022-27239

In cifs-utils through 6.14, a stack-based buffer overflow when parsing the mount.cifs ip= command-line argument could lead to local attackers gaining root privileges.
Publish Date : 2022-04-27 Last Update Date : 2022-06-03
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.2
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) OverflowGain privileges
CWE ID 787

- Products Affected By CVE-2022-27239

# Product Type Vendor Product Version Update Edition Language
1 OS Debian Debian Linux 9.0 * * * Version Details Vulnerabilities
2 OS Debian Debian Linux 10.0 * * * Version Details Vulnerabilities
3 OS Debian Debian Linux 11.0 * * * Version Details Vulnerabilities
4 Application HP Helion Openstack 8.0 * * * Version Details Vulnerabilities
5 Application Samba Cifs-utils * * * * Version Details Vulnerabilities
6 Application Suse Caas Platform 4.0 * * * Version Details Vulnerabilities
7 Application Suse Enterprise Storage 6.0 * * * Version Details Vulnerabilities
8 Application Suse Enterprise Storage 7.0 * * * Version Details Vulnerabilities
9 OS Suse Linux Enterprise Desktop 15 SP3 * * Version Details Vulnerabilities
10 OS Suse Linux Enterprise Desktop 15 SP4 * * Version Details Vulnerabilities
11 OS Suse Linux Enterprise High Performance Computing 12.0 SP5 * * Version Details Vulnerabilities
12 OS Suse Linux Enterprise High Performance Computing 15.0 SP1 * * Version Details Vulnerabilities
13 OS Suse Linux Enterprise High Performance Computing 15.0 SP1 * * Version Details Vulnerabilities
14 OS Suse Linux Enterprise High Performance Computing 15.0 SP2 * * Version Details Vulnerabilities
15 OS Suse Linux Enterprise High Performance Computing 15.0 SP2 * * Version Details Vulnerabilities
16 OS Suse Linux Enterprise High Performance Computing 15.0 SP3 * * Version Details Vulnerabilities
17 OS Suse Linux Enterprise High Performance Computing 15.0 - * * Version Details Vulnerabilities
18 OS Suse Linux Enterprise High Performance Computing 15.0 SP4 * * Version Details Vulnerabilities
19 OS Suse Linux Enterprise Micro 5.2 * * * Version Details Vulnerabilities
20 OS Suse Linux Enterprise Micro 5.2 * * * Version Details Vulnerabilities
21 Application Suse Linux Enterprise Point Of Service 11.0 SP3 * * Version Details Vulnerabilities
22 OS Suse Linux Enterprise Real Time 15.0 SP2 * * Version Details Vulnerabilities
23 OS Suse Linux Enterprise Server 11 SP4 * * Version Details Vulnerabilities
24 OS Suse Linux Enterprise Server 11 SP3 * * Version Details Vulnerabilities
25 OS Suse Linux Enterprise Server 12 SP5 * * Version Details Vulnerabilities
26 OS Suse Linux Enterprise Server 12 SP4 * * Version Details Vulnerabilities
27 OS Suse Linux Enterprise Server 12 SP4 * * Version Details Vulnerabilities
28 OS Suse Linux Enterprise Server 12 SP4 * * Version Details Vulnerabilities
29 OS Suse Linux Enterprise Server 12 SP3 * * Version Details Vulnerabilities
30 OS Suse Linux Enterprise Server 12 SP2 * * Version Details Vulnerabilities
31 OS Suse Linux Enterprise Server 12 SP3 * * Version Details Vulnerabilities
32 OS Suse Linux Enterprise Server 12 SP3 * * Version Details Vulnerabilities
33 OS Suse Linux Enterprise Server 12 SP3 * * Version Details Vulnerabilities
34 OS Suse Linux Enterprise Server 15 SP2 * * Version Details Vulnerabilities
35 OS Suse Linux Enterprise Server 15 - * * Version Details Vulnerabilities
36 OS Suse Linux Enterprise Server 15 SP1 * * Version Details Vulnerabilities
37 OS Suse Linux Enterprise Server 15 SP2 * * Version Details Vulnerabilities
38 OS Suse Linux Enterprise Server 15 * * * Version Details Vulnerabilities
39 OS Suse Linux Enterprise Server 15 SP3 * * Version Details Vulnerabilities
40 OS Suse Linux Enterprise Server 15 SP4 * * Version Details Vulnerabilities
41 OS Suse Linux Enterprise Server 15 SP1 * * Version Details Vulnerabilities
42 OS Suse Linux Enterprise Server 15 - * * Version Details Vulnerabilities
43 OS Suse Linux Enterprise Software Development Kit 12 SP5 * * Version Details Vulnerabilities
44 Application Suse Linux Enterprise Storage 7.1 * * * Version Details Vulnerabilities
45 Application Suse Manager Proxy 4.1 * * * Version Details Vulnerabilities
46 Application Suse Manager Proxy 4.2 * * * Version Details Vulnerabilities
47 Application Suse Manager Proxy 4.3 * * * Version Details Vulnerabilities
48 Application Suse Manager Retail Branch Server 4.1 * * * Version Details Vulnerabilities
49 Application Suse Manager Retail Branch Server 4.2 * * * Version Details Vulnerabilities
50 Application Suse Manager Retail Branch Server 4.3 * * * Version Details Vulnerabilities
51 Application Suse Manager Server 4.1 * * * Version Details Vulnerabilities
52 Application Suse Manager Server 4.2 * * * Version Details Vulnerabilities
53 Application Suse Manager Server 4.3 * * * Version Details Vulnerabilities
54 Application Suse Openstack Cloud 8.0 * * * Version Details Vulnerabilities
55 Application Suse Openstack Cloud 9.0 * * * Version Details Vulnerabilities
56 Application Suse Openstack Cloud Crowbar 8.0 * * * Version Details Vulnerabilities
57 Application Suse Openstack Cloud Crowbar 9.0 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Debian Debian Linux 3
HP Helion Openstack 1
Samba Cifs-utils 1
Suse Caas Platform 1
Suse Enterprise Storage 2
Suse Linux Enterprise Desktop 2
Suse Linux Enterprise High Performance Computing 8
Suse Linux Enterprise Micro 2
Suse Linux Enterprise Point Of Service 1
Suse Linux Enterprise Real Time 1
Suse Linux Enterprise Server 20
Suse Linux Enterprise Software Development Kit 1
Suse Linux Enterprise Storage 1
Suse Manager Proxy 3
Suse Manager Retail Branch Server 3
Suse Manager Server 3
Suse Openstack Cloud 2
Suse Openstack Cloud Crowbar 2

- References For CVE-2022-27239

https://lists.debian.org/debian-lts-announce/2022/05/msg00020.html
MLIST [debian-lts-announce] 20220516 [SECURITY] [DLA 3009-1] cifs-utils security update
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/5WBOLMANBYJILXQKRRK7OCR774PXJAYY/
FEDORA FEDORA-2022-34de4f833d
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/HXKZLJYJJEC3TIBFLXUORRMZUKG5W676/
FEDORA FEDORA-2022-7fda04ab5a
https://bugzilla.suse.com/show_bug.cgi?id=1197216
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QIYZ4L6SLSYJQ446VJAO2VGAESURQNSP/
FEDORA FEDORA-2022-eb2d3ca94d
https://www.debian.org/security/2022/dsa-5157
DEBIAN DSA-5157
https://github.com/piastry/cifs-utils/pull/7
http://wiki.robotz.com/index.php/Linux_CIFS_Utils_and_Samba
https://bugzilla.samba.org/show_bug.cgi?id=15025
https://github.com/piastry/cifs-utils/pull/7/commits/955fb147e97a6a74e1aaa65766de91e2c1479765

- Metasploit Modules Related To CVE-2022-27239

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.