CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2022-0492

A vulnerability was found in the Linux kernel’s cgroup_release_agent_write in the kernel/cgroup/cgroup-v1.c function. This flaw, under certain circumstances, allows the use of the cgroups v1 release_agent feature to escalate privileges and bypass the namespace isolation unexpectedly.
Publish Date : 2022-03-03 Last Update Date : 2022-06-03
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.4
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Bypass a restriction or similar
CWE ID 287

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2022:0819: kernel-rt security and bug fix update (Important) oval:com.redhat.rhsa:def:20220819 unix
RHSA-2022:0825: kernel security, bug fix, and enhancement update (Important) oval:com.redhat.rhsa:def:20220825 unix
RHSA-2022:0849: kpatch-patch security update (Important) oval:com.redhat.rhsa:def:20220849 unix
RHSA-2022:1417: kernel security update (Important) oval:com.redhat.rhsa:def:20221417 unix
RHSA-2022:4642: kernel security and bug fix update (Important) oval:com.redhat.rhsa:def:20224642 unix
RHSA-2022:4644: kernel-rt security and bug fix update (Important) oval:com.redhat.rhsa:def:20224644 unix
RHSA-2022:4655: kpatch-patch security update (Important) oval:com.redhat.rhsa:def:20224655 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2022-0492

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 14.04 * * * Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 16.04 * * * Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 18.04 * * * Version Details Vulnerabilities
4 OS Canonical Ubuntu Linux 20.04 * * * Version Details Vulnerabilities
5 OS Debian Debian Linux 9.0 * * * Version Details Vulnerabilities
6 OS Debian Debian Linux 10.0 * * * Version Details Vulnerabilities
7 OS Debian Debian Linux 11.0 * * * Version Details Vulnerabilities
8 OS Fedoraproject Fedora 35 * * * Version Details Vulnerabilities
9 OS Linux Linux Kernel * * * * Version Details Vulnerabilities
10 OS Linux Linux Kernel 5.17 RC1 * * Version Details Vulnerabilities
11 OS Linux Linux Kernel 5.17 RC2 * * Version Details Vulnerabilities
12 Hardware Netapp Baseboard Management Controller H300e - * * * Version Details Vulnerabilities
13 Hardware Netapp Baseboard Management Controller H300s - * * * Version Details Vulnerabilities
14 Hardware Netapp Baseboard Management Controller H410c - * * * Version Details Vulnerabilities
15 Hardware Netapp Baseboard Management Controller H410s - * * * Version Details Vulnerabilities
16 Hardware Netapp Baseboard Management Controller H500e - * * * Version Details Vulnerabilities
17 Hardware Netapp Baseboard Management Controller H500s - * * * Version Details Vulnerabilities
18 Hardware Netapp Baseboard Management Controller H700e - * * * Version Details Vulnerabilities
19 Hardware Netapp Baseboard Management Controller H700s - * * * Version Details Vulnerabilities
20 Hardware Netapp Hci Compute Node - * * * Version Details Vulnerabilities
21 Application Netapp Solidfire \& Hci Management Node - * * * Version Details Vulnerabilities
22 Application Netapp Solidfire\, Enterprise Sds \& Hci Storage Node - * * * Version Details Vulnerabilities
23 Application Redhat Codeready Linux Builder 8.0 * * * Version Details Vulnerabilities
24 Application Redhat Codeready Linux Builder 8.2 * * * Version Details Vulnerabilities
25 Application Redhat Codeready Linux Builder For Power Little Endian 8.0 * * * Version Details Vulnerabilities
26 Application Redhat Codeready Linux Builder For Power Little Endian 8.2 * * * Version Details Vulnerabilities
27 OS Redhat Enterprise Linux 8.0 * * * Version Details Vulnerabilities
28 OS Redhat Enterprise Linux Eus 8.2 * * * Version Details Vulnerabilities
29 OS Redhat Enterprise Linux For Ibm Z Systems 8.0 * * * Version Details Vulnerabilities
30 OS Redhat Enterprise Linux For Ibm Z Systems Eus 8.0 * * * Version Details Vulnerabilities
31 OS Redhat Enterprise Linux For Power Little Endian 8.0 * * * Version Details Vulnerabilities
32 OS Redhat Enterprise Linux For Power Little Endian Eus 8.0 * * * Version Details Vulnerabilities
33 OS Redhat Enterprise Linux For Real Time For Nfv Tus 8.0 * * * Version Details Vulnerabilities
34 OS Redhat Enterprise Linux For Real Time For Nfv Tus 8.2 * * * Version Details Vulnerabilities
35 OS Redhat Enterprise Linux For Real Time Tus 8.0 * * * Version Details Vulnerabilities
36 OS Redhat Enterprise Linux For Real Time Tus 8.2 * * * Version Details Vulnerabilities
37 OS Redhat Enterprise Linux Server Aus 8.2 * * * Version Details Vulnerabilities
38 OS Redhat Enterprise Linux Server For Power Little Endian Update Services For Sap Solutions 8.1 * * * Version Details Vulnerabilities
39 OS Redhat Enterprise Linux Server For Power Little Endian Update Services For Sap Solutions 8.2 * * * Version Details Vulnerabilities
40 OS Redhat Enterprise Linux Server Tus 8.2 * * * Version Details Vulnerabilities
41 OS Redhat Enterprise Linux Server Update Services For Sap Solutions 8.1 * * * Version Details Vulnerabilities
42 OS Redhat Enterprise Linux Server Update Services For Sap Solutions 8.2 * * * Version Details Vulnerabilities
43 Application Redhat Virtualization Host 4.0 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 4
Debian Debian Linux 3
Fedoraproject Fedora 1
Linux Linux Kernel 3
Netapp Baseboard Management Controller H300e 1
Netapp Baseboard Management Controller H300s 1
Netapp Baseboard Management Controller H410c 1
Netapp Baseboard Management Controller H410s 1
Netapp Baseboard Management Controller H500e 1
Netapp Baseboard Management Controller H500s 1
Netapp Baseboard Management Controller H700e 1
Netapp Baseboard Management Controller H700s 1
Netapp Hci Compute Node 1
Netapp Solidfire \& Hci Management Node 1
Netapp Solidfire\, Enterprise Sds \& Hci Storage Node 1
Redhat Codeready Linux Builder 2
Redhat Codeready Linux Builder For Power Little Endian 2
Redhat Enterprise Linux 1
Redhat Enterprise Linux Eus 1
Redhat Enterprise Linux For Ibm Z Systems 1
Redhat Enterprise Linux For Ibm Z Systems Eus 1
Redhat Enterprise Linux For Power Little Endian 1
Redhat Enterprise Linux For Power Little Endian Eus 1
Redhat Enterprise Linux For Real Time For Nfv Tus 2
Redhat Enterprise Linux For Real Time Tus 2
Redhat Enterprise Linux Server Aus 1
Redhat Enterprise Linux Server For Power Little Endian Update Services For Sap Solutions 2
Redhat Enterprise Linux Server Tus 1
Redhat Enterprise Linux Server Update Services For Sap Solutions 2
Redhat Virtualization Host 1

- References For CVE-2022-0492

https://www.debian.org/security/2022/dsa-5096
DEBIAN DSA-5096
https://security.netapp.com/advisory/ntap-20220419-0002/ CONFIRM
https://lists.debian.org/debian-lts-announce/2022/03/msg00011.html
MLIST [debian-lts-announce] 20220309 [SECURITY] [DLA 2940-1] linux security update
https://lists.debian.org/debian-lts-announce/2022/03/msg00012.html
MLIST [debian-lts-announce] 20220309 [SECURITY] [DLA 2941-1] linux-4.19 security update
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=24f6008564183aa120d07c03d9289519c2fe02af
http://packetstormsecurity.com/files/167386/Kernel-Live-Patch-Security-Notice-LSN-0086-1.html
https://www.debian.org/security/2022/dsa-5095
DEBIAN DSA-5095
http://packetstormsecurity.com/files/166444/Kernel-Live-Patch-Security-Notice-LSN-0085-1.html
https://bugzilla.redhat.com/show_bug.cgi?id=2051505

- Metasploit Modules Related To CVE-2022-0492

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.