CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2021-4104

JMSAppender in Log4j 1.2 is vulnerable to deserialization of untrusted data when the attacker has write access to the Log4j configuration. The attacker can provide TopicBindingName and TopicConnectionFactoryBindingName configurations causing JMSAppender to perform JNDI requests that result in remote code execution in a similar fashion to CVE-2021-44228. Note this issue only affects Log4j 1.2 when specifically configured to use JMSAppender, which is not the default. Apache Log4j 1.2 reached end of life in August 2015. Users should upgrade to Log4j 2 as it addresses numerous other issues from the previous versions.
Publish Date : 2021-12-14 Last Update Date : 2022-04-20
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.0
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication ???
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 502

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2021:5206: log4j security update (Moderate) oval:com.redhat.rhsa:def:20215206 unix
RHSA-2022:0290: parfait:0.5 security update (Important) oval:com.redhat.rhsa:def:20220290 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2021-4104

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Log4j 1.2 * * * Version Details Vulnerabilities
2 OS Fedoraproject Fedora 35 * * * Version Details Vulnerabilities
3 Application Oracle Retail Allocation 14.1.3.2 * * * Version Details Vulnerabilities
4 Application Oracle Retail Allocation 15.0.3.1 * * * Version Details Vulnerabilities
5 Application Oracle Retail Allocation 16.0.3 * * * Version Details Vulnerabilities
6 Application Oracle Retail Allocation 19.0.1 * * * Version Details Vulnerabilities
7 Application Oracle Utilities Testing Accelerator 6.0.0.1.1 * * * Version Details Vulnerabilities
8 Application Oracle Utilities Testing Accelerator 6.0.0.2.2 * * * Version Details Vulnerabilities
9 Application Oracle Utilities Testing Accelerator 6.0.0.3.1 * * * Version Details Vulnerabilities
10 Application Oracle Weblogic Server 12.2.1.3.0 * * * Version Details Vulnerabilities
11 Application Oracle Weblogic Server 12.2.1.4.0 * * * Version Details Vulnerabilities
12 Application Oracle Weblogic Server 14.1.1.0.0 * * * Version Details Vulnerabilities
13 Application Redhat Codeready Studio 12.0 * * * Version Details Vulnerabilities
14 OS Redhat Enterprise Linux 6.0 * * * Version Details Vulnerabilities
15 OS Redhat Enterprise Linux 7.0 * * * Version Details Vulnerabilities
16 OS Redhat Enterprise Linux 8.0 * * * Version Details Vulnerabilities
17 Application Redhat Integration Camel K - * * * Version Details Vulnerabilities
18 Application Redhat Integration Camel Quarkus - * * * Version Details Vulnerabilities
19 Application Redhat Jboss A-mq 6.0.0 * * * Version Details Vulnerabilities
20 Application Redhat Jboss A-mq 7 * * * Version Details Vulnerabilities
21 Application Redhat Jboss A-mq Streaming - * * * Version Details Vulnerabilities
22 Application Redhat Jboss Data Grid 7.0.0 * * * Version Details Vulnerabilities
23 Application Redhat Jboss Data Virtualization 6.0.0 * * * Version Details Vulnerabilities
24 Application Redhat Jboss Enterprise Application Platform 6.0.0 * * * Version Details Vulnerabilities
25 Application Redhat Jboss Enterprise Application Platform 7.0 * * * Version Details Vulnerabilities
26 Application Redhat Jboss Fuse 6.0.0 * * * Version Details Vulnerabilities
27 Application Redhat Jboss Fuse 7.0.0 * * * Version Details Vulnerabilities
28 Application Redhat Jboss Fuse Service Works 6.0 * * * Version Details Vulnerabilities
29 Application Redhat Jboss Operations Network 3.0 * * * Version Details Vulnerabilities
30 Application Redhat Jboss Web Server 3.0 * * * Version Details Vulnerabilities
31 Application Redhat Openshift Application Runtimes - * * * Version Details Vulnerabilities
32 Application Redhat Openshift Container Platform 4.6 * * * Version Details Vulnerabilities
33 Application Redhat Openshift Container Platform 4.7 * * * Version Details Vulnerabilities
34 Application Redhat Openshift Container Platform 4.8 * * * Version Details Vulnerabilities
35 Application Redhat Process Automation 7.0 * * * Version Details Vulnerabilities
36 Application Redhat Single Sign-on 7.0 * * * Version Details Vulnerabilities
37 Application Redhat Software Collections - * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Log4j 1
Fedoraproject Fedora 1
Oracle Retail Allocation 4
Oracle Utilities Testing Accelerator 3
Oracle Weblogic Server 3
Redhat Codeready Studio 1
Redhat Enterprise Linux 3
Redhat Integration Camel K 1
Redhat Integration Camel Quarkus 1
Redhat Jboss A-mq 2
Redhat Jboss A-mq Streaming 1
Redhat Jboss Data Grid 1
Redhat Jboss Data Virtualization 1
Redhat Jboss Enterprise Application Platform 2
Redhat Jboss Fuse 2
Redhat Jboss Fuse Service Works 1
Redhat Jboss Operations Network 1
Redhat Jboss Web Server 1
Redhat Openshift Application Runtimes 1
Redhat Openshift Container Platform 3
Redhat Process Automation 1
Redhat Single Sign-on 1
Redhat Software Collections 1

- References For CVE-2021-4104

https://github.com/apache/logging-log4j2/pull/608#issuecomment-990494126
https://www.cve.org/CVERecord?id=CVE-2021-44228
http://www.openwall.com/lists/oss-security/2022/01/18/3
MLIST [oss-security] 20220118 CVE-2022-23302: Deserialization of untrusted data in JMSSink in Apache Log4j 1.x
https://www.oracle.com/security-alerts/cpujan2022.html
https://www.kb.cert.org/vuls/id/930724
CERT-VN VU#930724
https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2021-0033 CONFIRM
https://security.netapp.com/advisory/ntap-20211223-0007/ CONFIRM
https://www.oracle.com/security-alerts/cpuapr2022.html
https://access.redhat.com/security/cve/CVE-2021-4104

- Metasploit Modules Related To CVE-2021-4104

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.