CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  What's the CVSS score of your company?
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2021-21342

XStream is a Java library to serialize objects to XML and back again. In XStream before version 1.4.16, there is a vulnerability where the processed stream at unmarshalling time contains type information to recreate the formerly written objects. XStream creates therefore new instances based on these type information. An attacker can manipulate the processed input stream and replace or inject objects, that result in a server-side forgery request. No user is affected, who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types. If you rely on XStream's default blacklist of the Security Framework, you will have to use at least version 1.4.16.
Publish Date : 2021-03-23 Last Update Date : 2021-11-30
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.4
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 918

- Products Affected By CVE-2021-21342

# Product Type Vendor Product Version Update Edition Language
1 OS Debian Debian Linux 9.0 * * * Version Details Vulnerabilities
2 OS Debian Debian Linux 10.0 * * * Version Details Vulnerabilities
3 OS Debian Debian Linux 11.0 * * * Version Details Vulnerabilities
4 OS Fedoraproject Fedora 33 * * * Version Details Vulnerabilities
5 OS Fedoraproject Fedora 34 * * * Version Details Vulnerabilities
6 OS Fedoraproject Fedora 35 * * * Version Details Vulnerabilities
7 Application Oracle Banking Virtual Account Management 14.2.0 * * * Version Details Vulnerabilities
8 Application Oracle Banking Virtual Account Management 14.3.0 * * * Version Details Vulnerabilities
9 Application Oracle Banking Virtual Account Management 14.5.0 * * * Version Details Vulnerabilities
10 Application Oracle Communications Policy Management 12.5.0 * * * Version Details Vulnerabilities
11 Application Xstream Project Xstream * * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Debian Debian Linux 3
Fedoraproject Fedora 3
Oracle Banking Virtual Account Management 3
Oracle Communications Policy Management 1
Xstream Project Xstream 1

- References For CVE-2021-21342

https://www.debian.org/security/2021/dsa-5004
DEBIAN DSA-5004
https://www.oracle.com//security-alerts/cpujul2021.html
N/A N/A
https://www.oracle.com/security-alerts/cpuoct2021.html
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/22KVR6B5IZP3BGQ3HPWIO2FWWCKT3DHP/
FEDORA FEDORA-2021-fbad11014a
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QGXIU3YDPG6OGTDHMBLAFN7BPBERXREB/
FEDORA FEDORA-2021-d894ca87dc
http://x-stream.github.io/changes.html#1.4.16
https://lists.apache.org/thread.html/r8244fd0831db894d5e89911ded9c72196d395a90ae655414d23ed0dd@%3Cusers.activemq.apache.org%3E
MLIST [activemq-users] 20210427 Release date for ActiveMQ v5.16.2 to fix CVEs
https://security.netapp.com/advisory/ntap-20210430-0002/ CONFIRM
https://github.com/x-stream/xstream/security/advisories/GHSA-hvv8-336g-rx3m CONFIRM
https://lists.debian.org/debian-lts-announce/2021/04/msg00002.html
MLIST [debian-lts-announce] 20210403 [SECURITY] [DLA 2616-1] libxstream-java security update
https://x-stream.github.io/security.html#workaround
https://lists.apache.org/thread.html/r9ac71b047767205aa22e3a08cb33f3e0586de6b2fac48b425c6e16b0@%3Cdev.jmeter.apache.org%3E
MLIST [jmeter-dev] 20210406 [GitHub] [jmeter] sseide opened a new pull request #655: update x-stream to 1.4.16 (from 1.4.15)
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PVPHZA7VW2RRSDCOIPP2W6O5ND254TU7/
FEDORA FEDORA-2021-5e376c0ed9
https://x-stream.github.io/CVE-2021-21342.html

- Metasploit Modules Related To CVE-2021-21342

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.