CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2019-3460

A heap data infoleak in multiple locations including L2CAP_PARSE_CONF_RSP was found in the Linux kernel before 5.1-rc1.
Publish Date : 2019-04-11 Last Update Date : 2022-04-22
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
3.3
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 20

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2019:2029: kernel security, bug fix, and enhancement update (Important) oval:com.redhat.rhsa:def:20192029 unix
RHSA-2019:2043: kernel-rt security and bug fix update (Important) oval:com.redhat.rhsa:def:20192043 unix
RHSA-2019:3309: kernel-rt security and bug fix update (Important) oval:com.redhat.rhsa:def:20193309 unix
RHSA-2019:3517: kernel security, bug fix, and enhancement update (Important) oval:com.redhat.rhsa:def:20193517 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2019-3460

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 14.04 * * * Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 16.04 * * * Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 18.04 * * * Version Details Vulnerabilities
4 OS Canonical Ubuntu Linux 18.10 * * * Version Details Vulnerabilities
5 OS Debian Debian Linux 8.0 * * * Version Details Vulnerabilities
6 OS Linux Linux Kernel * * * * Version Details Vulnerabilities
7 Application Redhat Codeready Linux Builder 8.0 * * * Version Details Vulnerabilities
8 OS Redhat Enterprise Linux 8.0 * * * Version Details Vulnerabilities
9 OS Redhat Enterprise Linux Desktop 7.0 * * * Version Details Vulnerabilities
10 OS Redhat Enterprise Linux Eus 8.1 * * * Version Details Vulnerabilities
11 OS Redhat Enterprise Linux Eus 8.2 * * * Version Details Vulnerabilities
12 OS Redhat Enterprise Linux Eus 8.4 * * * Version Details Vulnerabilities
13 OS Redhat Enterprise Linux For Real Time 7 * * * Version Details Vulnerabilities
14 OS Redhat Enterprise Linux For Real Time 8 * * * Version Details Vulnerabilities
15 OS Redhat Enterprise Linux For Real Time For Nfv 7 * * * Version Details Vulnerabilities
16 OS Redhat Enterprise Linux For Real Time For Nfv 8 * * * Version Details Vulnerabilities
17 OS Redhat Enterprise Linux For Real Time For Nfv Tus 8.2 * * * Version Details Vulnerabilities
18 OS Redhat Enterprise Linux For Real Time For Nfv Tus 8.4 * * * Version Details Vulnerabilities
19 OS Redhat Enterprise Linux For Real Time Tus 8.2 * * * Version Details Vulnerabilities
20 OS Redhat Enterprise Linux For Real Time Tus 8.4 * * * Version Details Vulnerabilities
21 OS Redhat Enterprise Linux Server 7.0 * * * Version Details Vulnerabilities
22 OS Redhat Enterprise Linux Server Aus 8.2 * * * Version Details Vulnerabilities
23 OS Redhat Enterprise Linux Server Aus 8.4 * * * Version Details Vulnerabilities
24 OS Redhat Enterprise Linux Server Tus 8.2 * * * Version Details Vulnerabilities
25 OS Redhat Enterprise Linux Server Tus 8.4 * * * Version Details Vulnerabilities
26 OS Redhat Enterprise Linux Workstation 7.0 * * * Version Details Vulnerabilities
27 Application Redhat Virtualization Host 4.0 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 4
Debian Debian Linux 1
Linux Linux Kernel 1
Redhat Codeready Linux Builder 1
Redhat Enterprise Linux 1
Redhat Enterprise Linux Desktop 1
Redhat Enterprise Linux Eus 3
Redhat Enterprise Linux For Real Time 2
Redhat Enterprise Linux For Real Time For Nfv 2
Redhat Enterprise Linux For Real Time For Nfv Tus 2
Redhat Enterprise Linux For Real Time Tus 2
Redhat Enterprise Linux Server 1
Redhat Enterprise Linux Server Aus 2
Redhat Enterprise Linux Server Tus 2
Redhat Enterprise Linux Workstation 1
Redhat Virtualization Host 1

- References For CVE-2019-3460

https://lists.debian.org/debian-lts-announce/2019/05/msg00042.html
MLIST [debian-lts-announce] 20190528 [SECURITY] [DLA 1799-2] linux security update
http://www.openwall.com/lists/oss-security/2019/06/27/2
MLIST [oss-security] 20190627 Re: linux-distros membership application - Microsoft
https://access.redhat.com/errata/RHSA-2020:0740
REDHAT RHSA-2020:0740
https://access.redhat.com/errata/RHSA-2019:3309
REDHAT RHSA-2019:3309
https://access.redhat.com/errata/RHSA-2019:3517
REDHAT RHSA-2019:3517
https://access.redhat.com/errata/RHSA-2019:2043
REDHAT RHSA-2019:2043
http://www.openwall.com/lists/oss-security/2019/06/27/7
MLIST [oss-security] 20190627 Re: linux-distros membership application - Microsoft
http://www.openwall.com/lists/oss-security/2019/06/28/2
MLIST [oss-security] 20190628 Re: linux-distros membership application - Microsoft
http://www.openwall.com/lists/oss-security/2019/06/28/1
MLIST [oss-security] 20190628 Re: linux-distros membership application - Microsoft
https://lists.debian.org/debian-lts-announce/2019/05/msg00041.html
MLIST [debian-lts-announce] 20190528 [SECURITY] [DLA 1799-1] linux security update
https://bugzilla.redhat.com/show_bug.cgi?id=1663179 CONFIRM
https://lore.kernel.org/linux-bluetooth/20190110062917.GB15047@kroah.com/
MLIST [linux-bluetooth] 20190110 [PATCH 2/2] Bluetooth: check the buffer size for some messages before parsing
https://git.kernel.org/linus/af3d5d1c87664a4f150fcf3534c6567cb19909b0 CONFIRM
https://lists.debian.org/debian-lts-announce/2019/05/msg00002.html
MLIST [debian-lts-announce] 20190503 [SECURITY] [DLA 1771-1] linux-4.9 security update
https://people.canonical.com/~ubuntu-security/cve/2019/CVE-2019-3460.html CONFIRM
https://marc.info/?l=oss-security&m=154721580222522&w=2
MLIST [oss-security] 20190111 Linux kernel: Bluetooth: two remote infoleaks (CVE-2019-3459, CVE-2019-3460)
https://access.redhat.com/errata/RHSA-2019:2029
REDHAT RHSA-2019:2029
http://www.openwall.com/lists/oss-security/2019/08/12/1
MLIST [oss-security] 20190811 Re: linux-distros membership application - Microsoft

- Metasploit Modules Related To CVE-2019-3460

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.