CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2019-10126

A flaw was found in the Linux kernel. A heap based buffer overflow in mwifiex_uap_parse_tail_ies function in drivers/net/wireless/marvell/mwifiex/ie.c might lead to memory corruption and possibly other consequences.
Publish Date : 2019-06-14 Last Update Date : 2021-10-28
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) OverflowMemory corruption
CWE ID 787

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2019:3055: kernel security and bug fix update (Important) oval:com.redhat.rhsa:def:20193055 unix
RHSA-2019:3076: kpatch-patch security update (Important) oval:com.redhat.rhsa:def:20193076 unix
RHSA-2019:3089: kernel-rt security and bug fix update (Important) oval:com.redhat.rhsa:def:20193089 unix
RHSA-2019:3309: kernel-rt security and bug fix update (Important) oval:com.redhat.rhsa:def:20193309 unix
RHSA-2019:3517: kernel security, bug fix, and enhancement update (Important) oval:com.redhat.rhsa:def:20193517 unix
RHSA-2020:0204: kernel security and bug fix update (Important) oval:com.redhat.rhsa:def:20200204 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2019-10126

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 14.04 * * * Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 16.04 * * * Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 18.04 * * * Version Details Vulnerabilities
4 OS Canonical Ubuntu Linux 19.04 * * * Version Details Vulnerabilities
5 OS Debian Debian Linux 8.0 * * * Version Details Vulnerabilities
6 OS Debian Debian Linux 9.0 * * * Version Details Vulnerabilities
7 OS Linux Linux Kernel - * * * Version Details Vulnerabilities
8 Application Netapp Active Iq Unified Manager * * * * Version Details Vulnerabilities
9 Application Netapp Hci Management Node - * * * Version Details Vulnerabilities
10 Application Netapp Solidfire - * * * Version Details Vulnerabilities
11 OS Opensuse Leap 15.0 * * * Version Details Vulnerabilities
12 OS Opensuse Leap 15.1 * * * Version Details Vulnerabilities
13 OS Redhat Enterprise Linux 8.0 * * * Version Details Vulnerabilities
14 OS Redhat Enterprise Linux Aus 8.2 * * * Version Details Vulnerabilities
15 OS Redhat Enterprise Linux Aus 8.4 * * * Version Details Vulnerabilities
16 OS Redhat Enterprise Linux Desktop 7.0 * * * Version Details Vulnerabilities
17 OS Redhat Enterprise Linux Eus 7.7 * * * Version Details Vulnerabilities
18 OS Redhat Enterprise Linux Eus 8.1 * * * Version Details Vulnerabilities
19 OS Redhat Enterprise Linux Eus 8.2 * * * Version Details Vulnerabilities
20 OS Redhat Enterprise Linux Eus 8.4 * * * Version Details Vulnerabilities
21 OS Redhat Enterprise Linux For Real Time 7 * * * Version Details Vulnerabilities
22 OS Redhat Enterprise Linux For Real Time 8 * * * Version Details Vulnerabilities
23 OS Redhat Enterprise Linux For Real Time For Nfv 7 * * * Version Details Vulnerabilities
24 OS Redhat Enterprise Linux For Real Time For Nfv Tus 8.2 * * * Version Details Vulnerabilities
25 OS Redhat Enterprise Linux For Real Time For Nfv Tus 8.4 * * * Version Details Vulnerabilities
26 OS Redhat Enterprise Linux For Real Time Tus 8.2 * * * Version Details Vulnerabilities
27 OS Redhat Enterprise Linux For Real Time Tus 8.4 * * * Version Details Vulnerabilities
28 OS Redhat Enterprise Linux Server 7.0 * * * Version Details Vulnerabilities
29 OS Redhat Enterprise Linux Server 8.0 * * * Version Details Vulnerabilities
30 OS Redhat Enterprise Linux Server Aus 7.7 * * * Version Details Vulnerabilities
31 OS Redhat Enterprise Linux Server Tus 7.7 * * * Version Details Vulnerabilities
32 OS Redhat Enterprise Linux Server Tus 8.2 * * * Version Details Vulnerabilities
33 OS Redhat Enterprise Linux Server Tus 8.4 * * * Version Details Vulnerabilities
34 OS Redhat Enterprise Linux Workstation 7.0 * * * Version Details Vulnerabilities
35 Application Redhat Virtualization 4.0 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 4
Debian Debian Linux 2
Linux Linux Kernel 1
Netapp Active Iq Unified Manager 1
Netapp Hci Management Node 1
Netapp Solidfire 1
Opensuse Leap 2
Redhat Enterprise Linux 1
Redhat Enterprise Linux Aus 2
Redhat Enterprise Linux Desktop 1
Redhat Enterprise Linux Eus 4
Redhat Enterprise Linux For Real Time 2
Redhat Enterprise Linux For Real Time For Nfv 1
Redhat Enterprise Linux For Real Time For Nfv Tus 2
Redhat Enterprise Linux For Real Time Tus 2
Redhat Enterprise Linux Server 2
Redhat Enterprise Linux Server Aus 1
Redhat Enterprise Linux Server Tus 3
Redhat Enterprise Linux Workstation 1
Redhat Virtualization 1

- References For CVE-2019-10126

https://access.redhat.com/errata/RHSA-2019:3517
REDHAT RHSA-2019:3517
https://access.redhat.com/errata/RHSA-2019:3309
REDHAT RHSA-2019:3309
https://access.redhat.com/errata/RHSA-2020:0174
REDHAT RHSA-2020:0174
https://access.redhat.com/errata/RHSA-2020:0204
REDHAT RHSA-2020:0204
https://usn.ubuntu.com/4118-1/
UBUNTU USN-4118-1
https://access.redhat.com/errata/RHSA-2019:3055
REDHAT RHSA-2019:3055
https://access.redhat.com/errata/RHSA-2019:3076
REDHAT RHSA-2019:3076
https://access.redhat.com/errata/RHSA-2019:3089
REDHAT RHSA-2019:3089
http://packetstormsecurity.com/files/154951/Kernel-Live-Patch-Security-Notice-LSN-0058-1.html
http://packetstormsecurity.com/files/154245/Kernel-Live-Patch-Security-Notice-LSN-0054-1.html
https://usn.ubuntu.com/4093-1/
UBUNTU USN-4093-1
https://support.f5.com/csp/article/K95593121 CONFIRM
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10126 CONFIRM
https://www.debian.org/security/2019/dsa-4465
DEBIAN DSA-4465
https://usn.ubuntu.com/4094-1/
UBUNTU USN-4094-1
https://usn.ubuntu.com/4095-2/
UBUNTU USN-4095-2
https://usn.ubuntu.com/4095-1/
UBUNTU USN-4095-1
http://packetstormsecurity.com/files/153702/Slackware-Security-Advisory-Slackware-14.2-kernel-Updates.html
https://seclists.org/bugtraq/2019/Jul/33
BUGTRAQ 20190722 [slackware-security] Slackware 14.2 kernel (SSA:2019-202-01)
http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00025.html
SUSE openSUSE-SU-2019:1757
http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00014.html
SUSE openSUSE-SU-2019:1716
https://security.netapp.com/advisory/ntap-20190710-0002/ CONFIRM
https://usn.ubuntu.com/4117-1/
UBUNTU USN-4117-1
http://www.securityfocus.com/bid/108817
BID 108817 Linux Kernel 'mwifiex_uap_parse_tail_ies()' Heap Buffer Overflow Vulnerability Release Date:2019-06-17
https://seclists.org/bugtraq/2019/Jun/26
BUGTRAQ 20190618 [SECURITY] [DSA 4465-1] linux security update
https://lists.debian.org/debian-lts-announce/2019/06/msg00011.html
MLIST [debian-lts-announce] 20190618 [SECURITY] [DLA 1824-1] linux-4.9 security update
https://lists.debian.org/debian-lts-announce/2019/06/msg00010.html
MLIST [debian-lts-announce] 20190617 [SECURITY] [DLA 1823-1] linux security update

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0

- Metasploit Modules Related To CVE-2019-10126

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.