CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  What's the CVSS score of your company?
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2019-10086

In Apache Commons Beanutils 1.9.2, a special BeanIntrospector class was added which allows suppressing the ability for an attacker to access the classloader via the class property available on all Java objects. We, however were not using this by default characteristic of the PropertyUtilsBean.
Publish Date : 2019-08-20 Last Update Date : 2021-12-14
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 502

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2020:0194: apache-commons-beanutils security update (Important) oval:com.redhat.rhsa:def:20200194 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2019-10086

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Commons Beanutils * * * * Version Details Vulnerabilities
2 Application Apache Nifi 1.14.0 * * * Version Details Vulnerabilities
3 Application Apache Nifi 1.15.0 * * * Version Details Vulnerabilities
4 OS Debian Debian Linux 8.0 * * * Version Details Vulnerabilities
5 OS Fedoraproject Fedora 30 * * * Version Details Vulnerabilities
6 OS Fedoraproject Fedora 31 * * * Version Details Vulnerabilities
7 OS Opensuse Leap 15.0 * * * Version Details Vulnerabilities
8 OS Opensuse Leap 15.1 * * * Version Details Vulnerabilities
9 Application Oracle Agile Plm 9.3.3 * * * Version Details Vulnerabilities
10 Application Oracle Agile Plm 9.3.5 * * * Version Details Vulnerabilities
11 Application Oracle Agile Plm 9.3.6 * * * Version Details Vulnerabilities
12 Application Oracle Agile Product Lifecycle Management Integration Pack 3.5 * * * Version Details Vulnerabilities
13 Application Oracle Agile Product Lifecycle Management Integration Pack 3.5 * * * Version Details Vulnerabilities
14 Application Oracle Agile Product Lifecycle Management Integration Pack 3.6 * * * Version Details Vulnerabilities
15 Application Oracle Agile Product Lifecycle Management Integration Pack 3.6 * * * Version Details Vulnerabilities
16 Application Oracle Application Testing Suite 13.3.0.1 * * * Version Details Vulnerabilities
17 Application Oracle Banking Platform 2.4.0 * * * Version Details Vulnerabilities
18 Application Oracle Banking Platform 2.7.1 * * * Version Details Vulnerabilities
19 Application Oracle Banking Platform 2.9.0 * * * Version Details Vulnerabilities
20 Application Oracle Communications Billing And Revenue Management 7.5 * * * Version Details Vulnerabilities
21 Application Oracle Communications Billing And Revenue Management 12.0.0.3.0 * * * Version Details Vulnerabilities
22 Application Oracle Communications Billing And Revenue Management Elastic Charging Engine 11.3.0.9 * * * Version Details Vulnerabilities
23 Application Oracle Communications Billing And Revenue Management Elastic Charging Engine 12.0.0.3 * * * Version Details Vulnerabilities
24 Application Oracle Communications Cloud Native Core Console 1.4.0 * * * Version Details Vulnerabilities
25 Application Oracle Communications Cloud Native Core Policy 1.9.0 * * * Version Details Vulnerabilities
26 Application Oracle Communications Cloud Native Core Unified Data Repository 1.6.0 * * * Version Details Vulnerabilities
27 Application Oracle Communications Evolved Communications Application Server 7.1 * * * Version Details Vulnerabilities
28 Application Oracle Communications Metasolv Solution 6.3.0 * * * Version Details Vulnerabilities
29 Application Oracle Communications Metasolv Solution 6.3.1 * * * Version Details Vulnerabilities
30 Application Oracle Communications Performance Intelligence Center 10.4.0.3 * * * Version Details Vulnerabilities
31 Application Oracle Communications Pricing Design Center 12.0.0.3.0 * * * Version Details Vulnerabilities
32 Application Oracle Communications Unified Inventory Management 7.3.4 * * * Version Details Vulnerabilities
33 Application Oracle Communications Unified Inventory Management 7.3.5 * * * Version Details Vulnerabilities
34 Application Oracle Communications Unified Inventory Management 7.4.0 * * * Version Details Vulnerabilities
35 Application Oracle Communications Unified Inventory Management 7.4.1 * * * Version Details Vulnerabilities
36 Application Oracle Customer Management And Segmentation Foundation 18.0 * * * Version Details Vulnerabilities
37 Application Oracle Enterprise Manager For Virtualization 13.4.0.0 * * * Version Details Vulnerabilities
38 Application Oracle Financial Services Revenue Management And Billing Analytics 2.7 * * * Version Details Vulnerabilities
39 Application Oracle Financial Services Revenue Management And Billing Analytics 2.8 * * * Version Details Vulnerabilities
40 Application Oracle Flexcube Private Banking 12.0.0 * * * Version Details Vulnerabilities
41 Application Oracle Flexcube Private Banking 12.1.0 * * * Version Details Vulnerabilities
42 Application Oracle Fusion Middleware 11.1.1.9 * * * Version Details Vulnerabilities
43 Application Oracle Fusion Middleware 12.2.1.3.0 * * * Version Details Vulnerabilities
44 Application Oracle Fusion Middleware 12.2.1.4.0 * * * Version Details Vulnerabilities
45 Application Oracle Healthcare Foundation 7.1.5 * * * Version Details Vulnerabilities
46 Application Oracle Healthcare Foundation 7.2.2 * * * Version Details Vulnerabilities
47 Application Oracle Healthcare Foundation 7.3.0 * * * Version Details Vulnerabilities
48 Application Oracle Healthcare Foundation 7.3.1 * * * Version Details Vulnerabilities
49 Application Oracle Healthcare Foundation 8.0.1 * * * Version Details Vulnerabilities
50 Application Oracle Hospitality Opera 5 5.5 * * * Version Details Vulnerabilities
51 Application Oracle Hospitality Opera 5 5.6 * * * Version Details Vulnerabilities
52 Application Oracle Insurance Data Gateway 1.0.2.3 * * * Version Details Vulnerabilities
53 Application Oracle Jd Edwards Enterpriseone Orchestrator * * * * Version Details Vulnerabilities
54 Application Oracle Jd Edwards Enterpriseone Orchestrator 9.2.5.3 * * * Version Details Vulnerabilities
55 Application Oracle Jd Edwards Enterpriseone Tools * * * * Version Details Vulnerabilities
56 Application Oracle Jd Edwards Enterpriseone Tools 9.2.5.3 * * * Version Details Vulnerabilities
57 Application Oracle Peoplesoft Enterprise Peopletools 8.56 * * * Version Details Vulnerabilities
58 Application Oracle Peoplesoft Enterprise Peopletools 8.57 * * * Version Details Vulnerabilities
59 Application Oracle Peoplesoft Enterprise Pt Peopletools 8.56 * * * Version Details Vulnerabilities
60 Application Oracle Peoplesoft Enterprise Pt Peopletools 8.57 * * * Version Details Vulnerabilities
61 Application Oracle Peoplesoft Enterprise Pt Peopletools 8.58 * * * Version Details Vulnerabilities
62 Application Oracle Primavera Gateway * * * * Version Details Vulnerabilities
63 Application Oracle Real-time Decisions Solutions 3.2.0.0 * * * Version Details Vulnerabilities
64 Application Oracle Retail Advanced Inventory Planning 14.1 * * * Version Details Vulnerabilities
65 Application Oracle Retail Back Office 14.1 * * * Version Details Vulnerabilities
66 Application Oracle Retail Central Office 14.1 * * * Version Details Vulnerabilities
67 Application Oracle Retail Merchandising System 5.0.3.1 * * * Version Details Vulnerabilities
68 Application Oracle Retail Point-of-service 14.1 * * * Version Details Vulnerabilities
69 Application Oracle Retail Predictive Application Server 16.0 * * * Version Details Vulnerabilities
70 Application Oracle Retail Price Management 14.0 * * * Version Details Vulnerabilities
71 Application Oracle Retail Price Management 14.0.1 * * * Version Details Vulnerabilities
72 Application Oracle Retail Price Management 15.0 * * * Version Details Vulnerabilities
73 Application Oracle Retail Price Management 16.0 * * * Version Details Vulnerabilities
74 Application Oracle Retail Returns Management 14.1 * * * Version Details Vulnerabilities
75 Application Oracle Retail Xstore Point Of Service 7.1 * * * Version Details Vulnerabilities
76 Application Oracle Retail Xstore Point Of Service 15.0 * * * Version Details Vulnerabilities
77 Application Oracle Retail Xstore Point Of Service 16.0 * * * Version Details Vulnerabilities
78 Application Oracle Retail Xstore Point Of Service 17.0 * * * Version Details Vulnerabilities
79 Application Oracle Retail Xstore Point Of Service 18.0 * * * Version Details Vulnerabilities
80 Application Oracle Service Bus 11.1.1.9.0 * * * Version Details Vulnerabilities
81 Application Oracle Service Bus 12.2.1.3.0 * * * Version Details Vulnerabilities
82 Application Oracle Service Bus 12.2.1.4.0 * * * Version Details Vulnerabilities
83 Application Oracle Solaris Cluster 4.4 * * * Version Details Vulnerabilities
84 Application Oracle Utilities Framework * * * * Version Details Vulnerabilities
85 Application Oracle Utilities Framework 4.2.0.2.0 * * * Version Details Vulnerabilities
86 Application Oracle Utilities Framework 4.2.0.3.0 * * * Version Details Vulnerabilities
87 Application Oracle Utilities Framework 4.4.0.0.0 * * * Version Details Vulnerabilities
88 Application Oracle Utilities Framework 4.4.0.2.0 * * * Version Details Vulnerabilities
89 Application Oracle Utilities Framework 4.4.0.3.0 * * * Version Details Vulnerabilities
90 Application Oracle Weblogic Server 10.3.6.0.0 * * * Version Details Vulnerabilities
91 OS Redhat Enterprise Linux Desktop 7.0 * * * Version Details Vulnerabilities
92 OS Redhat Enterprise Linux Eus 7.7 * * * Version Details Vulnerabilities
93 OS Redhat Enterprise Linux Server 7.0 * * * Version Details Vulnerabilities
94 OS Redhat Enterprise Linux Server Aus 7.7 * * * Version Details Vulnerabilities
95 OS Redhat Enterprise Linux Server Tus 7.7 * * * Version Details Vulnerabilities
96 OS Redhat Enterprise Linux Workstation 7.0 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Commons Beanutils 1
Apache Nifi 2
Debian Debian Linux 1
Fedoraproject Fedora 2
Opensuse Leap 2
Oracle Agile Plm 3
Oracle Agile Product Lifecycle Management Integration Pack 4
Oracle Application Testing Suite 1
Oracle Banking Platform 3
Oracle Communications Billing And Revenue Management 2
Oracle Communications Billing And Revenue Management Elastic Charging Engine 2
Oracle Communications Cloud Native Core Console 1
Oracle Communications Cloud Native Core Policy 1
Oracle Communications Cloud Native Core Unified Data Repository 1
Oracle Communications Evolved Communications Application Server 1
Oracle Communications Metasolv Solution 2
Oracle Communications Performance Intelligence Center 1
Oracle Communications Pricing Design Center 1
Oracle Communications Unified Inventory Management 4
Oracle Customer Management And Segmentation Foundation 1
Oracle Enterprise Manager For Virtualization 1
Oracle Financial Services Revenue Management And Billing Analytics 2
Oracle Flexcube Private Banking 2
Oracle Fusion Middleware 3
Oracle Healthcare Foundation 5
Oracle Hospitality Opera 5 2
Oracle Insurance Data Gateway 1
Oracle Jd Edwards Enterpriseone Orchestrator 2
Oracle Jd Edwards Enterpriseone Tools 2
Oracle Peoplesoft Enterprise Peopletools 2
Oracle Peoplesoft Enterprise Pt Peopletools 3
Oracle Primavera Gateway 1
Oracle Real-time Decisions Solutions 1
Oracle Retail Advanced Inventory Planning 1
Oracle Retail Back Office 1
Oracle Retail Central Office 1
Oracle Retail Merchandising System 1
Oracle Retail Point-of-service 1
Oracle Retail Predictive Application Server 1
Oracle Retail Price Management 4
Oracle Retail Returns Management 1
Oracle Retail Xstore Point Of Service 5
Oracle Service Bus 3
Oracle Solaris Cluster 1
Oracle Utilities Framework 6
Oracle Weblogic Server 1
Redhat Enterprise Linux Desktop 1
Redhat Enterprise Linux Eus 1
Redhat Enterprise Linux Server 1
Redhat Enterprise Linux Server Aus 1
Redhat Enterprise Linux Server Tus 1
Redhat Enterprise Linux Workstation 1

- References For CVE-2019-10086

https://lists.apache.org/thread.html/2fd61dc89df9aeab738d2b49f48d42c76f7d53b980ba04e1d48bce48@%3Cdev.shiro.apache.org%3E
MLIST [shiro-dev] 20191001 [jira] [Created] (SHIRO-723) Provide Minor Shiro Release that includes CVE-2019-10086 Fiix
https://lists.apache.org/thread.html/d6ca9439c53374b597f33b7ec180001625597db48ea30356af01145f@%3Cdev.shiro.apache.org%3E
MLIST [shiro-dev] 20191001 [jira] [Updated] (SHIRO-723) Provide Minor Shiro Release that includes CVE-2019-10086 Fix
https://lists.apache.org/thread.html/c94bc9649d5109a663b2129371dc45753fbdeacd340105548bbe93c3@%3Cdev.shiro.apache.org%3E
MLIST [shiro-dev] 20191001 [jira] [Commented] (SHIRO-723) Provide Minor Shiro Release that includes CVE-2019-10086 Fix
https://lists.apache.org/thread.html/rb1f76c2c0a4d6efb8a3523974f9d085d5838b73e7bffdf9a8f212997@%3Cissues.nifi.apache.org%3E
MLIST [nifi-issues] 20210915 [jira] [Updated] (NIFI-9170) Upgrade commons-beanutils to 1.9.4 to mitigate CVE-2019-10086
https://lists.apache.org/thread.html/rd2d2493f4f1af6980d265b8d84c857e2b7ab80a46e1423710c448957@%3Cissues.nifi.apache.org%3E
MLIST [nifi-issues] 20210908 [GitHub] [nifi] naddym commented on pull request #5351: NIFI-9170 Upgrade commons-beanutils to 1.9.4 to mitigate CVE-2019-10086
https://lists.apache.org/thread.html/ra41fd0ad4b7e1d675c03a5081a16a6603085a4e37d30b866067566fe@%3Cissues.nifi.apache.org%3E
MLIST [nifi-issues] 20210907 [GitHub] [nifi] asfgit closed pull request #5351: NIFI-9170 Upgrade commons-beanutils to 1.9.4 to mitigate CVE-2019-10086
https://lists.apache.org/thread.html/re3cd7cb641d7fc6684e4fc3c336a8bad4a01434bb5625a06e3600fd1@%3Cissues.nifi.apache.org%3E
MLIST [nifi-issues] 20210907 [jira] [Commented] (NIFI-9170) Upgrade commons-beanutils to 1.9.4 to mitigate CVE-2019-10086
https://lists.apache.org/thread.html/re2028d4d76ba1db3e3c3a722d6c6034e801cc3b309f69cc166eaa32b@%3Ccommits.nifi.apache.org%3E
MLIST [nifi-commits] 20210907 [nifi] branch main updated: NIFI-9170 Upgrade commons-beanutils to 1.9.4 to mitigate CVE-2019-10086 NIFI-9170 Add two more 1.9.4 references to close out the few things identified by the Maven dependency plugin.
https://lists.apache.org/thread.html/r2d5f1d88c39bd615271abda63964a0bee9b2b57fef1f84cb4c43032e@%3Cissues.nifi.apache.org%3E
MLIST [nifi-issues] 20210907 [GitHub] [nifi] MikeThomsen commented on pull request #5351: NIFI-9170 Upgrade commons-beanutils to 1.9.4 to mitigate CVE-2019-10086
https://lists.apache.org/thread.html/rec74f3a94dd850259c730b4ba6f7b6211222b58900ec088754aa0534@%3Cissues.nifi.apache.org%3E
MLIST [nifi-issues] 20210827 [jira] [Created] (NIFI-9170) Upgrade commons-beanutils to 1.9.4 to mitigate CVE-2019-10086
https://lists.apache.org/thread.html/r46e536fc98942dce99fadd2e313aeefe90c1a769c5cd85d98df9d098@%3Cissues.nifi.apache.org%3E
MLIST [nifi-issues] 20210827 [GitHub] [nifi] naddym opened a new pull request #5351: NIFI-9170 Upgrade commons-beanutils to 1.9.4 to mitigate CVE-2019-10086
https://www.oracle.com//security-alerts/cpujul2021.html
N/A N/A
https://lists.apache.org/thread.html/rcc029be4edaaf5b8bb85818aab494e16f312fced07a0f4a202771ba2@%3Cissues.nifi.apache.org%3E
MLIST [nifi-issues] 20210827 [jira] [Updated] (NIFI-9170) Upgrade commons-beanutils to 1.9.4 to mitigate CVE-2019-10086
https://www.oracle.com/security-alerts/cpuApr2021.html
https://lists.apache.org/thread.html/r513a7a21c422170318115463b399dd58ab447fe0990b13e5884f0825@%3Ccommits.dolphinscheduler.apache.org%3E
MLIST [dolphinscheduler-commits] 20210121 [GitHub] [incubator-dolphinscheduler] lgcareer commented on pull request #4525: [Improvement-4506][LICENSE] upgrade the version of the commons-beanutils
https://www.oracle.com/security-alerts/cpujan2021.html
https://lists.apache.org/thread.html/ra9a139fdc0999750dcd519e81384bc1fe3946f311b1796221205f51c@%3Ccommits.dolphinscheduler.apache.org%3E
MLIST [dolphinscheduler-commits] 20210121 [GitHub] [incubator-dolphinscheduler] c-f-cooper commented on pull request #4525: [Improvement-4506][LICENSE] upgrade the version of the commons-beanutils
https://lists.apache.org/thread.html/rb8dac04cb7e9cc5dedee8dabaa1c92614f590642e5ebf02a145915ba@%3Ccommits.atlas.apache.org%3E
MLIST [atlas-commits] 20201023 [atlas] 01/05: ATLAS-4002 : Upgrade commons-beanutils to 1.9.4 due to CVE-2019-10086
https://lists.apache.org/thread.html/r6194ced4828deb32023cd314e31f41c61d388b58935d102c7de91f58@%3Cdev.atlas.apache.org%3E
MLIST [atlas-dev] 20201023 [jira] [Commented] (ATLAS-4002) Upgrade commons-beanutils to 1.9.4 due to CVE-2019-10086
https://lists.apache.org/thread.html/r306c0322aa5c0da731e03f3ce9f07f4745c052c6b73f4e78faf232ca@%3Cdev.atlas.apache.org%3E
MLIST [atlas-dev] 20201026 [jira] [Updated] (ATLAS-4002) Upgrade commons-beanutils to 1.9.4 due to CVE-2019-10086
https://lists.apache.org/thread.html/racd3e7b2149fa2f255f016bd6bffab0fea77b6fb81c50db9a17f78e6@%3Cdev.atlas.apache.org%3E
MLIST [atlas-dev] 20201023 [jira] [Commented] (ATLAS-4002) Upgrade commons-beanutils to 1.9.4 due to CVE-2019-10086
https://lists.apache.org/thread.html/r967953a14e05016bc4bcae9ef3dd92e770181158b4246976ed8295c9@%3Cdev.brooklyn.apache.org%3E
MLIST [brooklyn-dev] 20200420 [GitHub] [brooklyn-server] duncangrant opened a new pull request #1091: Update library versions due to CVEs
https://www.oracle.com/security-alerts/cpujul2020.html
https://lists.apache.org/thread.html/rae81e0c8ebdf47ffaa85a01240836bfece8a990c48f55c7933162b5c@%3Cdev.atlas.apache.org%3E
MLIST [atlas-dev] 20201022 [jira] [Created] (ATLAS-4002) Upgrade commons-beanutils to 1.9.4 due to CVE-2019-10086
https://www.oracle.com/security-alerts/cpujan2020.html
https://access.redhat.com/errata/RHSA-2019:4317
REDHAT RHSA-2019:4317
https://lists.apache.org/thread.html/ra87ac17410a62e813cba901fdd4e9a674dd53daaf714870f28e905f1@%3Cdev.atlas.apache.org%3E
MLIST [atlas-dev] 20201023 [jira] [Updated] (ATLAS-4002) Upgrade commons-beanutils to 1.9.4 due to CVE-2019-10086
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/JIUYSL2RSIWZVNSUIXJTIFPIPIF6OAIO/
FEDORA FEDORA-2019-79b5790566
https://lists.apache.org/thread.html/reee57101464cf7622d640ae013b2162eb864f603ec4093de8240bb8f@%3Cdev.atlas.apache.org%3E
MLIST [atlas-dev] 20201022 Re: Review Request 72983: ATLAS-4002 : Upgrade commons-beanutils to 1.9.4 due to CVE-2019-10086
https://access.redhat.com/errata/RHSA-2020:0806
REDHAT RHSA-2020:0806
https://access.redhat.com/errata/RHSA-2020:0811
REDHAT RHSA-2020:0811
https://access.redhat.com/errata/RHSA-2020:0804
REDHAT RHSA-2020:0804
https://access.redhat.com/errata/RHSA-2020:0805
REDHAT RHSA-2020:0805
https://www.oracle.com/security-alerts/cpuapr2020.html
N/A N/A
https://access.redhat.com/errata/RHSA-2020:0194
REDHAT RHSA-2020:0194
https://lists.apache.org/thread.html/r43de02fd4a4f52c4bdeff8c02f09625d83cd047498009c1cdab857db@%3Cdev.rocketmq.apache.org%3E
MLIST [rocketmq-dev] 20201223 [GitHub] [rocketmq] crazywen opened a new pull request #2515: Update pom.xml
https://www.oracle.com/security-alerts/cpuoct2021.html
https://access.redhat.com/errata/RHSA-2020:0057
REDHAT RHSA-2020:0057
https://lists.apache.org/thread.html/5261066cd7adee081ee05c8bf0e96cf0b2eeaced391e19117ae4daa6@%3Cdev.shiro.apache.org%3E
MLIST [shiro-dev] 20191023 [jira] [Assigned] (SHIRO-723) Provide Minor Shiro Release that includes CVE-2019-10086 Fix
https://lists.apache.org/thread.html/a684107d3a78e431cf0fbb90629e8559a36ff8fe94c3a76e620b39fa@%3Cdev.shiro.apache.org%3E
MLIST [shiro-dev] 20191105 [jira] [Resolved] (SHIRO-723) Provide Minor Shiro Release that includes CVE-2019-10086 Fix
https://lists.apache.org/thread.html/r18d8b4f9263e5cad3bbaef0cdba0e2ccdf9201316ac4b85e23eb7ee4@%3Cdev.atlas.apache.org%3E
MLIST [atlas-dev] 20201023 Re: Review Request 72983: ATLAS-4002 : Upgrade commons-beanutils to 1.9.4 due to CVE-2019-10086
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4APPGLBWMFAS4WHNLR4LIJ65DJGPV7TF/
FEDORA FEDORA-2019-bcad44b5d6
https://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d2869b4d798e13cc@%3Cissues.drill.apache.org%3E
MLIST [drill-issues] 20191021 [jira] [Created] (DRILL-7416) Updates required to dependencies to resolve potential security vulnerabilities
https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e2f07864b5108f@%3Cdev.drill.apache.org%3E
MLIST [drill-dev] 20191021 [jira] [Created] (DRILL-7416) Updates required to dependencies to resolve potential security vulnerabilities
http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00007.html
SUSE openSUSE-SU-2019:2058
https://lists.apache.org/thread.html/1f78f1e32cc5614ec0c5b822ba4bd7fc8e8b5c46c8e038b6bd609cb5@%3Cissues.commons.apache.org%3E
MLIST [commons-issues] 20190906 [jira] [Closed] (CONFIGURATION-755) [CVE-2014-0114] Update Apache Commons BeanUtils from 1.9.3 to 1.9.4.
https://lists.apache.org/thread.html/956995acee0d8bc046f1df0a55b7fbeb65dd2f82864e5de1078bacb0@%3Cissues.commons.apache.org%3E
MLIST [commons-issues] 20190906 [jira] [Updated] (CONFIGURATION-755) [CVE-2014-0114] Update Apache Commons BeanUtils from 1.9.3 to 1.9.4.
https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12ee199f5b0c1442@%3Cdev.drill.apache.org%3E
MLIST [drill-dev] 20191017 Dependencies used by Drill contain known vulnerabilities
https://lists.apache.org/thread.html/02094ad226dbc17a2368beaf27e61d8b1432f5baf77d0ca995bb78bc@%3Cissues.commons.apache.org%3E
MLIST [commons-issues] 20190925 [GitHub] [commons-validator] jeff-schram opened a new pull request #18: Update pom.xml
https://lists.apache.org/thread.html/3d1ed1a1596c08c4d5fea97b36c651ce167b773f1afc75251ce7a125@%3Ccommits.tinkerpop.apache.org%3E
MLIST [tinkerpop-commits] 20190829 [tinkerpop] branch master updated: Bump commons-beanutils to 1.9.4 for CVE-2019-10086 - CTR
http://mail-archives.apache.org/mod_mbox/www-announce/201908.mbox/%3cC628798F-315D-4428-8CB1-4ED1ECC958E4@apache.org%3e
MLIST [www-announce] 20190815 [SECURITY] CVE-2019-10086. Apache Commons Beanutils does not suppresses the class property in PropertyUtilsBean by default.
https://lists.debian.org/debian-lts-announce/2019/08/msg00030.html
MLIST [debian-lts-announce] 20190824 [SECURITY] [DLA 1896-1] commons-beanutils security update

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0

- Metasploit Modules Related To CVE-2019-10086

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.