CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  What's the CVSS score of your company?
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2018-10237

Unbounded memory allocation in Google Guava 11.0 through 24.x before 24.1.1 allows remote attackers to conduct denial of service attacks against servers that depend on this library and deserialize attacker-provided data, because the AtomicDoubleArray class (when serialized with Java serialization) and the CompoundOrdering class (when serialized with GWT serialization) perform eager allocation without appropriate checks on what a client has sent and whether the data size is reasonable.
Publish Date : 2018-04-26 Last Update Date : 2021-10-20
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 770

- Products Affected By CVE-2018-10237

# Product Type Vendor Product Version Update Edition Language
1 Application Google Guava * * * * Version Details Vulnerabilities
2 Application Oracle Banking Payments * * * * Version Details Vulnerabilities
3 Application Oracle Communications Ip Service Activator 7.3.0 * * * Version Details Vulnerabilities
4 Application Oracle Communications Ip Service Activator 7.4.0 * * * Version Details Vulnerabilities
5 Application Oracle Customer Management And Segmentation Foundation 18.0 * * * Version Details Vulnerabilities
6 Application Oracle Database Server 12.2.0.1 * * * Version Details Vulnerabilities
7 Application Oracle Database Server 18C * * * Version Details Vulnerabilities
8 Application Oracle Database Server 19C * * * Version Details Vulnerabilities
9 Application Oracle Flexcube Investor Servicing 12.1.0 * * * Version Details Vulnerabilities
10 Application Oracle Flexcube Investor Servicing 12.3.0 * * * Version Details Vulnerabilities
11 Application Oracle Flexcube Investor Servicing 12.4.0 * * * Version Details Vulnerabilities
12 Application Oracle Flexcube Investor Servicing 14.0.0 * * * Version Details Vulnerabilities
13 Application Oracle Flexcube Investor Servicing 14.1.0 * * * Version Details Vulnerabilities
14 Application Oracle Flexcube Private Banking 12.0.0 * * * Version Details Vulnerabilities
15 Application Oracle Flexcube Private Banking 12.1.0 * * * Version Details Vulnerabilities
16 Application Oracle Retail Integration Bus 15.0 * * * Version Details Vulnerabilities
17 Application Oracle Retail Integration Bus 16.0 * * * Version Details Vulnerabilities
18 Application Oracle Retail Xstore Point Of Service 7.1 * * * Version Details Vulnerabilities
19 Application Oracle Retail Xstore Point Of Service 15.0 * * * Version Details Vulnerabilities
20 Application Oracle Retail Xstore Point Of Service 16.0 * * * Version Details Vulnerabilities
21 Application Oracle Retail Xstore Point Of Service 17.0 * * * Version Details Vulnerabilities
22 Application Oracle Weblogic Server 12.2.1.3.0 * * * Version Details Vulnerabilities
23 Application Redhat Openshift Container Platform 3.11 * * * Version Details Vulnerabilities
24 Application Redhat Openstack 13 * * * Version Details Vulnerabilities
25 Application Redhat Satellite 6.4 * * * Version Details Vulnerabilities
26 Application Redhat Satellite Capsule 6.4 * * * Version Details Vulnerabilities
27 Application Redhat Virtualization 4.2 * * * Version Details Vulnerabilities
28 Application Redhat Virtualization Host 4.0 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Google Guava 1
Oracle Banking Payments 1
Oracle Communications Ip Service Activator 2
Oracle Customer Management And Segmentation Foundation 1
Oracle Database Server 3
Oracle Flexcube Investor Servicing 5
Oracle Flexcube Private Banking 2
Oracle Retail Integration Bus 2
Oracle Retail Xstore Point Of Service 4
Oracle Weblogic Server 1
Redhat Openshift Container Platform 1
Redhat Openstack 1
Redhat Satellite 1
Redhat Satellite Capsule 1
Redhat Virtualization 1
Redhat Virtualization Host 1

- References For CVE-2018-10237

https://access.redhat.com/errata/RHSA-2018:2743
REDHAT RHSA-2018:2743
https://access.redhat.com/errata/RHSA-2018:2740
REDHAT RHSA-2018:2740
http://www.securitytracker.com/id/1041707
SECTRACK 1041707
https://access.redhat.com/errata/RHSA-2018:2425
REDHAT RHSA-2018:2425
https://access.redhat.com/errata/RHSA-2018:2424
REDHAT RHSA-2018:2424
https://access.redhat.com/errata/RHSA-2018:2423
REDHAT RHSA-2018:2423
https://www.oracle.com/security-alerts/cpuoct2021.html
https://lists.apache.org/thread.html/r3c3b33ee5bef0c67391d27a97cbfd89d44f328cf072b601b58d4e748@%3Ccommits.pulsar.apache.org%3E
MLIST [pulsar-commits] 20210406 [GitHub] [pulsar] lhotari opened a new pull request #10149: Upgrade jclouds to 2.3.0 to fix security vulnerabilities
https://access.redhat.com/errata/RHSA-2018:2927
REDHAT RHSA-2018:2927
https://lists.apache.org/thread.html/cc48fe770c45a74dc3b37ed0817393e0c96701fc49bc431ed922f3cc@%3Chdfs-dev.hadoop.apache.org%3E
MLIST [hadoop-hdfs-dev] 20190401 Update guava to 27.0-jre in hadoop-project
https://lists.apache.org/thread.html/r30e7d7b6bfa630dacc41649a0e96dad75165d50474c1241068aa0f94@%3Cissues.storm.apache.org%3E
MLIST [storm-issues] 20210315 [jira] [Created] (STORM-3754) Upgrade Guava version because of security vulnerability
https://lists.apache.org/thread.html/r841c5e14e1b55281523ebcde661ece00b38a0569e00ef5e12bd5f6ba@%3Cissues.maven.apache.org%3E
MLIST [maven-issues] 20210122 [GitHub] [maven-indexer] akurtakov opened a new pull request #75: Remove guava dependency from indexer-core
https://lists.apache.org/thread.html/r352e40ca9874d1beb4ad95403792adca7eb295e6bc3bd7b65fabcc21@%3Ccommits.samza.apache.org%3E
MLIST [samza-commits] 20210310 [GitHub] [samza] Telesia opened a new pull request #1471: SAMZA-2630: Upgrade dependencies for security fixes
https://lists.apache.org/thread.html/rd01f5ff0164c468ec7abc96ff7646cea3cce6378da2e4aa29c6bcb95@%3Cgithub.arrow.apache.org%3E
MLIST [arrow-github] 20210610 [GitHub] [arrow] projjal opened a new pull request #10501: ARROW-13032: Update guava version
https://access.redhat.com/errata/RHSA-2018:2643
REDHAT RHSA-2018:2643
https://lists.apache.org/thread.html/rb3da574c34bc6bd37972d2266af3093b90d7e437460423c24f477919@%3Cissues.lucene.apache.org%3E
MLIST [lucene-issues] 20201022 [jira] [Updated] (SOLR-14960) Solr-clustering is bringing in CVE-2018-10237 vulnerable guava
https://lists.apache.org/thread.html/r223bc776a077d0795786c38cbc6e7dd808fce1a9161b00ba9c0a5d55@%3Cissues.lucene.apache.org%3E
MLIST [lucene-issues] 20201022 [jira] [Resolved] (SOLR-14960) Solr-clustering is bringing in CVE-2018-10237 vulnerable guava
https://www.oracle.com/security-alerts/cpujan2021.html
https://lists.apache.org/thread.html/ra4f44016926dcb034b3b230280a18102062f94ae55b8a31bb92fed84@%3Cissues.lucene.apache.org%3E
MLIST [lucene-issues] 20201022 [jira] [Created] (SOLR-14960) Solr-clustering is bringing in CVE-2018-10237 vulnerable guava
https://lists.apache.org/thread.html/ra8906723927aef2a599398c238eacfc845b74d812e0093ec2fc70a7d@%3Cissues.flink.apache.org%3E
MLIST [flink-issues] 20200814 [jira] [Commented] (FLINK-18841) CVE-2018-10237 and CWE-400 occurred in flink dependency
https://lists.apache.org/thread.html/r50fc0bcc734dd82e691d36d209258683141bfc0083739a77e56ad92d@%3Cdev.flink.apache.org%3E
MLIST [flink-dev] 20200806 [jira] [Created] (FLINK-18841) CVE-2018-10237 and CWE-400 occurred in flink dependency
https://lists.apache.org/thread.html/r02e39d7beb32eebcdbb4b516e95f67d71c90d5d462b26f4078d21eeb@%3Cuser.flink.apache.org%3E
MLIST [flink-user] 20200806 Dependency vulnerabilities with Apache Flink 1.10.1 version
https://lists.apache.org/thread.html/r02e39d7beb32eebcdbb4b516e95f67d71c90d5d462b26f4078d21eeb@%3Cdev.flink.apache.org%3E
MLIST [flink-dev] 20200806 Dependency vulnerabilities with Apache Flink 1.10.1 version
https://lists.apache.org/thread.html/rdc56c15693c236e31e1e95f847b8e5e74fc0a05741d47488e7fc8c45@%3Cissues.flink.apache.org%3E
MLIST [flink-issues] 20200806 [jira] [Created] (FLINK-18841) CVE-2018-10237 and CWE-400 occurred in flink dependency
https://lists.apache.org/thread.html/rc8467f357b943ceaa86f289f8bc1a5d1c7955b75d3bac1426f2d4ac1@%3Ccommon-dev.hadoop.apache.org%3E
MLIST [hadoop-common-dev] 20200623 Update guava to 27.0-jre in hadoop branch-2.10
https://www.oracle.com/security-alerts/cpujul2020.html
https://lists.apache.org/thread.html/r38e2ab87528d3c904e7fac496e8fd766b9277656ff95b97d6b6b6dcd@%3Cdev.cxf.apache.org%3E
MLIST [cxf-dev] 20200420 [GitHub] [cxf] reta commented on a change in pull request #638: upgrade guava, CVE-2018-10237
https://lists.apache.org/thread.html/r2ea4e5e5aa8ad73b001a466c582899620961f47d77a40af712c1fdf9@%3Cdev.cxf.apache.org%3E
MLIST [cxf-dev] 20200420 [GitHub] [cxf] andrei-ivanov commented on a change in pull request #638: upgrade guava, CVE-2018-10237
https://lists.apache.org/thread.html/r43491b25b2e5c368c34b106a82eff910a5cea3e90de82ad75cc16540@%3Cdev.syncope.apache.org%3E
MLIST [syncope-dev] 20200423 Re: Time to cut 2.1.6 / 2.0.15?
https://www.oracle.com/security-alerts/cpuapr2020.html
N/A N/A
https://lists.apache.org/thread.html/rd0c8ec6e044aa2958dd0549ebf8ecead7f5968c9474ba73a504161b2@%3Cdev.cxf.apache.org%3E
MLIST [cxf-dev] 20200420 [GitHub] [cxf] coheigea commented on a change in pull request #638: upgrade guava, CVE-2018-10237
https://lists.apache.org/thread.html/ra0adb9653c7de9539b93cc8434143b655f753b9f60580ff260becb2b@%3Cusers.kafka.apache.org%3E
MLIST [kafka-users] 20200413 CVEs for the dependency software guava and rocksdbjni of Kafka
https://lists.apache.org/thread.html/r27eb79a87a760335226dbfa6a7b7bffea539a535f8e80c41e482106d@%3Cdev.cxf.apache.org%3E
MLIST [cxf-dev] 20200206 [GitHub] [cxf] davidkarlsen opened a new pull request #638: upgrade guava, CVE-2018-10237
https://lists.apache.org/thread.html/r95799427b335807a4c54776908125c3e66597b65845ae50096d9278a@%3Cdev.cxf.apache.org%3E
MLIST [cxf-dev] 20200206 [GitHub] [cxf] reta commented on a change in pull request #638: upgrade guava, CVE-2018-10237
https://lists.apache.org/thread.html/rc78f6e84f82cc662860e96526d8ab969f34dbe12dc560e22d9d147a3@%3Cdev.cxf.apache.org%3E
MLIST [cxf-dev] 20200211 [GitHub] [cxf] coheigea commented on a change in pull request #638: upgrade guava, CVE-2018-10237
https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12ee199f5b0c1442@%3Cdev.drill.apache.org%3E
MLIST [drill-dev] 20191017 Dependencies used by Drill contain known vulnerabilities
https://access.redhat.com/errata/RHSA-2019:3149
REDHAT RHSA-2019:3149
https://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d2869b4d798e13cc@%3Cissues.drill.apache.org%3E
MLIST [drill-issues] 20191021 [jira] [Created] (DRILL-7416) Updates required to dependencies to resolve potential security vulnerabilities
https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e2f07864b5108f@%3Cdev.drill.apache.org%3E
MLIST [drill-dev] 20191021 [jira] [Created] (DRILL-7416) Updates required to dependencies to resolve potential security vulnerabilities
https://lists.apache.org/thread.html/3d5dbdd92ac9ceaef90e40f78599f9109f2f345252e0ac9d98e7e084@%3Cgitbox.activemq.apache.org%3E
MLIST [activemq-gitbox] 20190530 [GitHub] [activemq-artemis] brusdev opened a new pull request #2687: ARTEMIS-2359 Upgrade to Guava 24.1
https://lists.apache.org/thread.html/33c6bccfeb7adf644d4d79894ca8f09370be6ed4b20632c2e228d085@%3Ccommits.cassandra.apache.org%3E
MLIST [cassandra-commits] 20190612 [jira] [Assigned] (CASSANDRA-14760) CVE-2018-10237 Security vulnerability in 3.11.3
https://lists.apache.org/thread.html/053d9ce4d579b02203db18545fee5e33f35f2932885459b74d1e4272@%3Cissues.activemq.apache.org%3E
MLIST [activemq-issues] 20190820 [jira] [Created] (AMQ-7279) Security Vulnerabilities in Libraries - jackson-databind-2.9.8.jar, tomcat-servlet-api-8.0.53.jar, tomcat-websocket-api-8.0.53.jar, zookeeper-3.4.6.jar, guava-18.0.jar, jetty-all-9.2.26.v20180806.jar, scala-library-2.11.0.jar
https://access.redhat.com/errata/RHSA-2019:2858
REDHAT RHSA-2019:2858
https://lists.apache.org/thread.html/ff8dcfe29377088ab655fda9d585dccd5b1f07fabd94ae84fd60a7f8@%3Ccommits.pulsar.apache.org%3E
MLIST [pulsar-commits] 20190416 [GitHub] [pulsar] one70six opened a new issue #4057: Security Vulnerabilities - Black Duck Scan - Pulsar v.2.3.1
https://groups.google.com/d/topic/guava-announce/xqWALw4W1vs/discussion CONFIRM
https://lists.apache.org/thread.html/r22c8173b804cd4a420c43064ba4e363d0022aa421008b1989f7354d4@%3Cissues.flink.apache.org%3E
MLIST [flink-issues] 20210212 [jira] [Closed] (FLINK-18841) CVE-2018-10237 and CWE-400 occurred in flink dependency
https://lists.apache.org/thread.html/3ddd79c801edd99c0978e83dbe2168ebd36fd42acfa5dac38fb03dd6@%3Cissues.activemq.apache.org%3E
MLIST [activemq-issues] 20190516 [jira] [Created] (AMQ-7208) Security Issue related to Guava 18.0
https://lists.apache.org/thread.html/19fa48533bc7ea1accf6b12746a74ed888ae6e49a5cf81ae4f807495@%3Ccommon-dev.hadoop.apache.org%3E
MLIST [hadoop-common-dev] 20190401 Update guava to 27.0-jre in hadoop-project
https://access.redhat.com/errata/RHSA-2018:2741
REDHAT RHSA-2018:2741
https://access.redhat.com/errata/RHSA-2018:2742
REDHAT RHSA-2018:2742
https://access.redhat.com/errata/RHSA-2018:2428
REDHAT RHSA-2018:2428
https://access.redhat.com/errata/RHSA-2018:2598
REDHAT RHSA-2018:2598

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0

- Metasploit Modules Related To CVE-2018-10237

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.