CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2017-14867

Git before 2.10.5, 2.11.x before 2.11.4, 2.12.x before 2.12.5, 2.13.x before 2.13.6, and 2.14.x before 2.14.2 uses unsafe Perl scripts to support subcommands such as cvsserver, which allows attackers to execute arbitrary OS commands via shell metacharacters in a module name. The vulnerable code is reachable via git-shell even without CVS support.
Publish Date : 2017-09-29 Last Update Date : 2021-01-26
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.0
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication ???
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 78

- Products Affected By CVE-2017-14867

# Product Type Vendor Product Version Update Edition Language
1 OS Debian Debian Linux 8.0 * * * Version Details Vulnerabilities
2 OS Debian Debian Linux 9.0 * * * Version Details Vulnerabilities
3 Application Git-scm GIT * * * * Version Details Vulnerabilities
4 Application Git-scm GIT 2.11.0 * * * Version Details Vulnerabilities
5 Application Git-scm GIT 2.11.1 * * * Version Details Vulnerabilities
6 Application Git-scm GIT 2.11.2 * * * Version Details Vulnerabilities
7 Application Git-scm GIT 2.11.3 * * * Version Details Vulnerabilities
8 Application Git-scm GIT 2.12.0 * * * Version Details Vulnerabilities
9 Application Git-scm GIT 2.12.1 * * * Version Details Vulnerabilities
10 Application Git-scm GIT 2.12.2 * * * Version Details Vulnerabilities
11 Application Git-scm GIT 2.12.3 * * * Version Details Vulnerabilities
12 Application Git-scm GIT 2.12.4 * * * Version Details Vulnerabilities
13 Application Git-scm GIT 2.13.0 * * * Version Details Vulnerabilities
14 Application Git-scm GIT 2.13.1 * * * Version Details Vulnerabilities
15 Application Git-scm GIT 2.13.2 * * * Version Details Vulnerabilities
16 Application Git-scm GIT 2.13.3 * * * Version Details Vulnerabilities
17 Application Git-scm GIT 2.13.4 * * * Version Details Vulnerabilities
18 Application Git-scm GIT 2.13.5 * * * Version Details Vulnerabilities
19 Application Git-scm GIT 2.14.0 * * * Version Details Vulnerabilities
20 Application Git-scm GIT 2.14.1 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Debian Debian Linux 2
Git-scm GIT 18

- References For CVE-2017-14867

https://bugs.debian.org/876854 CONFIRM
http://www.openwall.com/lists/oss-security/2017/09/26/9 CONFIRM
https://www.debian.org/security/2017/dsa-3984
DEBIAN DSA-3984
https://public-inbox.org/git/xmqqy3p29ekj.fsf@gitster.mtv.corp.google.com/T/#u CONFIRM
http://www.securitytracker.com/id/1039431
SECTRACK 1039431
http://www.securityfocus.com/bid/101060
BID 101060 Git CVE-2017-14867 OS Command Injection Vulnerability Release Date:2017-09-28
https://lists.debian.org/debian-security-announce/2017/msg00246.html CONFIRM

- Metasploit Modules Related To CVE-2017-14867

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.