CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  What's the CVSS score of your company?
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2017-12234

Multiple vulnerabilities in the implementation of the Common Industrial Protocol (CIP) feature in Cisco IOS 12.4 through 15.6 could allow an unauthenticated, remote attacker to cause an affected device to reload, resulting in a denial of service (DoS) condition. The vulnerabilities are due to the improper parsing of crafted CIP packets destined to an affected device. An attacker could exploit these vulnerabilities by sending crafted CIP packets to be processed by an affected device. A successful exploit could allow the attacker to cause the affected device to reload, resulting in a DoS condition. Cisco Bug IDs: CSCvc43709.
Publish Date : 2017-09-29 Last Update Date : 2019-10-09
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.8
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 20

- Products Affected By CVE-2017-12234

# Product Type Vendor Product Version Update Edition Language
1 OS Cisco IOS 12.4\(25e\)jap9 * * * Version Details Vulnerabilities
2 OS Cisco IOS 12.4\(25e\)jao20s * * * Version Details Vulnerabilities
3 OS Cisco IOS 12.4\(25e\)jao3a * * * Version Details Vulnerabilities
4 OS Cisco IOS 12.4\(25e\)jap1n * * * Version Details Vulnerabilities
5 OS Cisco IOS 15.0\(2\)sqd7 * * * Version Details Vulnerabilities
6 OS Cisco IOS 15.1\(2\)sg7a * * * Version Details Vulnerabilities
7 OS Cisco IOS 15.2\(2\)eb2 * * * Version Details Vulnerabilities
8 OS Cisco IOS 15.2\(2\)eb1 * * * Version Details Vulnerabilities
9 OS Cisco IOS 15.2\(4\)ec * * * Version Details Vulnerabilities
10 OS Cisco IOS 15.2\(5\)e2b * * * Version Details Vulnerabilities
11 OS Cisco IOS 15.2\(2\)eb * * * Version Details Vulnerabilities
12 OS Cisco IOS 15.2\(5a\)e1 * * * Version Details Vulnerabilities
13 OS Cisco IOS 15.2\(4\)ec1 * * * Version Details Vulnerabilities
14 OS Cisco IOS 15.2\(5\)e * * * Version Details Vulnerabilities
15 OS Cisco IOS 15.2\(4\)ec2 * * * Version Details Vulnerabilities
16 OS Cisco IOS 15.2\(3\)ex * * * Version Details Vulnerabilities
17 OS Cisco IOS 15.2\(5\)e2a * * * Version Details Vulnerabilities
18 OS Cisco IOS 15.2\(2\)e5b * * * Version Details Vulnerabilities
19 OS Cisco IOS 15.2\(2\)e3 * * * Version Details Vulnerabilities
20 OS Cisco IOS 15.3\(3\)jda3 * * * Version Details Vulnerabilities
21 OS Cisco IOS 15.3\(3\)jnc4 * * * Version Details Vulnerabilities
22 OS Cisco IOS 15.3\(3\)jnp2 * * * Version Details Vulnerabilities
23 OS Cisco IOS 15.3\(3\)je1 * * * Version Details Vulnerabilities
24 OS Cisco IOS 15.3\(3\)jbb6a * * * Version Details Vulnerabilities
25 OS Cisco IOS 15.3\(3\)jc51 * * * Version Details Vulnerabilities
26 OS Cisco IOS 15.3\(3\)jc50 * * * Version Details Vulnerabilities
27 OS Cisco IOS 15.3\(3\)jpb2 * * * Version Details Vulnerabilities
28 OS Cisco IOS 15.3\(3\)jc7 * * * Version Details Vulnerabilities
29 OS Cisco IOS 15.3\(3\)jnd2 * * * Version Details Vulnerabilities
30 OS Cisco IOS 15.3\(3\)jpb * * * Version Details Vulnerabilities
31 OS Cisco IOS 15.3\(3\)jpc3 * * * Version Details Vulnerabilities
32 OS Cisco IOS 15.3\(3\)jca7 * * * Version Details Vulnerabilities
33 OS Cisco IOS 15.6\(2\)s2 * * * Version Details Vulnerabilities
34 OS Cisco IOS 15.6\(2\)s3 * * * Version Details Vulnerabilities
35 OS Cisco IOS 15.6\(1\)s1a * * * Version Details Vulnerabilities
36 OS Cisco IOS 15.6\(2\)sp2a * * * Version Details Vulnerabilities
37 OS Cisco IOS 15.6\(2\)s0a * * * Version Details Vulnerabilities
38 OS Cisco IOS 15.6\(2\)sp1b * * * Version Details Vulnerabilities
39 OS Cisco IOS 15.6\(2\)sp1c * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Cisco IOS 39

- References For CVE-2017-12234

http://www.securityfocus.com/bid/101038
BID 101038 Cisco IOS Software Common Industrial Protocol Multiple Denial of Service Vulnerabilities Release Date:2017-09-27
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20170927-cip CONFIRM
http://www.securitytracker.com/id/1039459
SECTRACK 1039459

- Metasploit Modules Related To CVE-2017-12234

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.