CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2016-5385

PHP through 7.0.8 does not attempt to address RFC 3875 section 4.1.18 namespace conflicts and therefore does not protect applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect an application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, as demonstrated by (1) an application that makes a getenv('HTTP_PROXY') call or (2) a CGI configuration of PHP, aka an "httpoxy" issue.
Publish Date : 2016-07-19 Last Update Date : 2021-09-29
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.1
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity High (Specialized access conditions exist. It is hard to exploit and several special conditions must be satisfied to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 284

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2016:1609: php security update (Moderate) oval:com.redhat.rhsa:def:20161609 unix
RHSA-2016:1613: php security and bug fix update (Moderate) oval:com.redhat.rhsa:def:20161613 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2016-5385

# Product Type Vendor Product Version Update Edition Language
1 OS Debian Debian Linux 8.0 * * * Version Details Vulnerabilities
2 Application Drupal Drupal * * * * Version Details Vulnerabilities
3 OS Fedoraproject Fedora 23 * * * Version Details Vulnerabilities
4 OS Fedoraproject Fedora 24 * * * Version Details Vulnerabilities
5 Application HP System Management Homepage * * * * Version Details Vulnerabilities
6 OS Opensuse Leap 42.1 * * * Version Details Vulnerabilities
7 Application Oracle Communications User Data Repository 10.0.0 * * * Version Details Vulnerabilities
8 Application Oracle Communications User Data Repository 10.0.1 * * * Version Details Vulnerabilities
9 Application Oracle Communications User Data Repository 12.0.0 * * * Version Details Vulnerabilities
10 Application Oracle Enterprise Manager Ops Center 12.2.2 * * * Version Details Vulnerabilities
11 Application Oracle Enterprise Manager Ops Center 12.3.2 * * * Version Details Vulnerabilities
12 OS Oracle Linux 6 - * * Version Details Vulnerabilities
13 OS Oracle Linux 7 - * * Version Details Vulnerabilities
14 Application PHP PHP * * * * Version Details Vulnerabilities
15 OS Redhat Enterprise Linux Desktop 6.0 * * * Version Details Vulnerabilities
16 OS Redhat Enterprise Linux Server 6.0 * * * Version Details Vulnerabilities
17 OS Redhat Enterprise Linux Workstation 6.0 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Debian Debian Linux 1
Drupal Drupal 1
Fedoraproject Fedora 2
HP System Management Homepage 1
Opensuse Leap 1
Oracle Communications User Data Repository 3
Oracle Enterprise Manager Ops Center 2
Oracle Linux 2
PHP PHP 1
Redhat Enterprise Linux Desktop 1
Redhat Enterprise Linux Server 1
Redhat Enterprise Linux Workstation 1

- References For CVE-2016-5385

https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05320149 CONFIRM
https://bugzilla.redhat.com/show_bug.cgi?id=1353794 CONFIRM
https://h20566.www2.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbhf03770en_us CONFIRM
https://www.drupal.org/SA-CORE-2016-003 CONFIRM
https://github.com/guzzle/guzzle/releases/tag/6.2.1 CONFIRM
https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05333297 CONFIRM
https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05390722 CONFIRM
http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.html CONFIRM
http://www.securitytracker.com/id/1036335
SECTRACK 1036335
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KZOIUYZDBWNDDHC6XTOLZYRMRXZWTJCP/
FEDORA FEDORA-2016-4e7db3d437
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GXFEIMZPSVGZQQAYIQ7U7DFVX3IBSDLF/
FEDORA FEDORA-2016-9c8cf5912c
http://www.oracle.com/technetwork/topics/security/linuxbulletinjul2016-3090544.html CONFIRM
http://lists.opensuse.org/opensuse-updates/2016-08/msg00003.html
SUSE openSUSE-SU-2016:1922
http://www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html CONFIRM
http://rhn.redhat.com/errata/RHSA-2016-1610.html
REDHAT RHSA-2016:1610
http://rhn.redhat.com/errata/RHSA-2016-1609.html
REDHAT RHSA-2016:1609
http://www.debian.org/security/2016/dsa-3631
DEBIAN DSA-3631
http://rhn.redhat.com/errata/RHSA-2016-1613.html
REDHAT RHSA-2016:1613
http://rhn.redhat.com/errata/RHSA-2016-1612.html
REDHAT RHSA-2016:1612
http://www.securityfocus.com/bid/91821
BID 91821 PHP CVE-2016-5385 Security Bypass Vulnerability Release Date:2018-01-18
http://rhn.redhat.com/errata/RHSA-2016-1611.html
REDHAT RHSA-2016:1611
https://security.gentoo.org/glsa/201611-22
GENTOO GLSA-201611-22
http://www.kb.cert.org/vuls/id/797896
CERT-VN VU#797896
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/7RMYXAVNYL2MOBJTFATE73TOVOEZYC5R/
FEDORA FEDORA-2016-8eb11666aa
https://httpoxy.org/

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0

- Metasploit Modules Related To CVE-2016-5385

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.