CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2016-3712

Integer overflow in the VGA module in QEMU allows local guest OS users to cause a denial of service (out-of-bounds read and QEMU process crash) by editing VGA registers in VBE mode.
Publish Date : 2016-05-11 Last Update Date : 2020-05-14
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
2.1
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of ServiceOverflow
CWE ID 190

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2016:2585: qemu-kvm security, bug fix, and enhancement update (Moderate) oval:com.redhat.rhsa:def:20162585 unix
RHSA-2017:0621: qemu-kvm security and bug fix update (Moderate) oval:com.redhat.rhsa:def:20170621 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2016-3712

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 12.04 * * * Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 14.04 * * * Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 15.10 * * * Version Details Vulnerabilities
4 OS Canonical Ubuntu Linux 16.04 * * * Version Details Vulnerabilities
5 Application Citrix Xenserver * * * * Version Details Vulnerabilities
6 OS Debian Debian Linux 8.0 * * * Version Details Vulnerabilities
7 OS Oracle Vm Server 3.3 * * * Version Details Vulnerabilities
8 OS Oracle Vm Server 3.4 * * * Version Details Vulnerabilities
9 Application Qemu Qemu * * * * Version Details Vulnerabilities
10 Application Qemu Qemu 2.6.0 RC1 * * Version Details Vulnerabilities
11 Application Qemu Qemu 2.6.0 RC2 * * Version Details Vulnerabilities
12 Application Qemu Qemu 2.6.0 RC3 * * Version Details Vulnerabilities
13 Application Qemu Qemu 2.6.0 RC4 * * Version Details Vulnerabilities
14 Application Qemu Qemu 2.6.0 RC0 * * Version Details Vulnerabilities
15 OS Redhat Enterprise Linux Desktop 6.0 * * * Version Details Vulnerabilities
16 OS Redhat Enterprise Linux Desktop 7.0 * * * Version Details Vulnerabilities
17 OS Redhat Enterprise Linux Server 6.0 * * * Version Details Vulnerabilities
18 OS Redhat Enterprise Linux Server 7.0 * * * Version Details Vulnerabilities
19 OS Redhat Enterprise Linux Server Aus 7.3 * * * Version Details Vulnerabilities
20 OS Redhat Enterprise Linux Server Aus 7.4 * * * Version Details Vulnerabilities
21 OS Redhat Enterprise Linux Server Aus 7.6 * * * Version Details Vulnerabilities
22 OS Redhat Enterprise Linux Server Aus 7.7 * * * Version Details Vulnerabilities
23 OS Redhat Enterprise Linux Server Eus 7.3 * * * Version Details Vulnerabilities
24 OS Redhat Enterprise Linux Server Eus 7.4 * * * Version Details Vulnerabilities
25 OS Redhat Enterprise Linux Server Eus 7.5 * * * Version Details Vulnerabilities
26 OS Redhat Enterprise Linux Server Eus 7.6 * * * Version Details Vulnerabilities
27 OS Redhat Enterprise Linux Server Eus 7.7 * * * Version Details Vulnerabilities
28 OS Redhat Enterprise Linux Server Tus 7.3 * * * Version Details Vulnerabilities
29 OS Redhat Enterprise Linux Server Tus 7.6 * * * Version Details Vulnerabilities
30 OS Redhat Enterprise Linux Server Tus 7.7 * * * Version Details Vulnerabilities
31 OS Redhat Enterprise Linux Workstation 6.0 * * * Version Details Vulnerabilities
32 OS Redhat Enterprise Linux Workstation 7.0 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 4
Citrix Xenserver 1
Debian Debian Linux 1
Oracle Vm Server 2
Qemu Qemu 6
Redhat Enterprise Linux Desktop 2
Redhat Enterprise Linux Server 2
Redhat Enterprise Linux Server Aus 4
Redhat Enterprise Linux Server Eus 5
Redhat Enterprise Linux Server Tus 3
Redhat Enterprise Linux Workstation 2

- References For CVE-2016-3712

http://rhn.redhat.com/errata/RHSA-2016-2585.html
REDHAT RHSA-2016:2585
http://rhn.redhat.com/errata/RHSA-2017-0621.html
REDHAT RHSA-2017:0621
http://support.citrix.com/article/CTX212736 CONFIRM
http://www.oracle.com/technetwork/topics/security/ovmbulletinjul2016-3090546.html CONFIRM
http://www.securityfocus.com/bid/90314
BID 90314 QEMU VGA Module CVE-2016-3712 Multiple Denial of Service Vulnerabilities Release Date:2017-03-31
http://www.openwall.com/lists/oss-security/2016/05/09/4
MLIST [oss-security] 20160509 CVE-2016-3712 Qemu: vga: out-of-bounds read and integer overflow issues
http://www.debian.org/security/2016/dsa-3573
DEBIAN DSA-3573
http://xenbits.xen.org/xsa/advisory-179.html CONFIRM
http://www.ubuntu.com/usn/USN-2974-1
UBUNTU USN-2974-1
https://lists.gnu.org/archive/html/qemu-devel/2016-05/msg01196.html
MLIST [Qemu-devel] 20160509 [PULL 5/5] vga: make sure vga register setup for vbe stays intact (CVE-2016-3712).
http://www.securitytracker.com/id/1035794
SECTRACK 1035794

- Metasploit Modules Related To CVE-2016-3712

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.