CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  What's the CVSS score of your company?
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2016-2857

The net_checksum_calculate function in net/checksum.c in QEMU allows local guest OS users to cause a denial of service (out-of-bounds heap read and crash) via the payload length in a crafted packet.
Publish Date : 2016-04-12 Last Update Date : 2021-08-04
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
3.6
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of ServiceOverflow
CWE ID 119

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2017:0083: qemu-kvm security and bug fix update (Low) oval:com.redhat.rhsa:def:20170083 unix
RHSA-2017:0309: qemu-kvm security and bug fix update (Important) oval:com.redhat.rhsa:def:20170309 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2016-2857

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 12.04 * * * Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 14.04 * * * Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 15.10 * * * Version Details Vulnerabilities
4 OS Canonical Ubuntu Linux 16.04 * * * Version Details Vulnerabilities
5 OS Debian Debian Linux 8.0 * * * Version Details Vulnerabilities
6 Application Qemu Qemu * * * * Version Details Vulnerabilities
7 OS Redhat Enterprise Linux Desktop 6.0 * * * Version Details Vulnerabilities
8 OS Redhat Enterprise Linux Desktop 7.0 * * * Version Details Vulnerabilities
9 OS Redhat Enterprise Linux Eus 7.3 * * * Version Details Vulnerabilities
10 OS Redhat Enterprise Linux Eus 7.4 * * * Version Details Vulnerabilities
11 OS Redhat Enterprise Linux Eus 7.5 * * * Version Details Vulnerabilities
12 OS Redhat Enterprise Linux Eus 7.6 * * * Version Details Vulnerabilities
13 OS Redhat Enterprise Linux Eus 7.7 * * * Version Details Vulnerabilities
14 OS Redhat Enterprise Linux Server 6.0 * * * Version Details Vulnerabilities
15 OS Redhat Enterprise Linux Server 7.0 * * * Version Details Vulnerabilities
16 OS Redhat Enterprise Linux Server Aus 7.3 * * * Version Details Vulnerabilities
17 OS Redhat Enterprise Linux Server Aus 7.4 * * * Version Details Vulnerabilities
18 OS Redhat Enterprise Linux Server Aus 7.6 * * * Version Details Vulnerabilities
19 OS Redhat Enterprise Linux Server Aus 7.7 * * * Version Details Vulnerabilities
20 OS Redhat Enterprise Linux Server Tus 7.3 * * * Version Details Vulnerabilities
21 OS Redhat Enterprise Linux Server Tus 7.6 * * * Version Details Vulnerabilities
22 OS Redhat Enterprise Linux Server Tus 7.7 * * * Version Details Vulnerabilities
23 OS Redhat Enterprise Linux Workstation 6.0 * * * Version Details Vulnerabilities
24 OS Redhat Enterprise Linux Workstation 7.0 * * * Version Details Vulnerabilities
25 Application Redhat Openstack 6.0 * * * Version Details Vulnerabilities
26 Application Redhat Openstack 7.0 * * * Version Details Vulnerabilities
27 Application Redhat Openstack 8 * * * Version Details Vulnerabilities
28 Application Redhat Openstack 9 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 4
Debian Debian Linux 1
Qemu Qemu 1
Redhat Enterprise Linux Desktop 2
Redhat Enterprise Linux Eus 5
Redhat Enterprise Linux Server 2
Redhat Enterprise Linux Server Aus 4
Redhat Enterprise Linux Server Tus 3
Redhat Enterprise Linux Workstation 2
Redhat Openstack 4

- References For CVE-2016-2857

https://lists.debian.org/debian-lts-announce/2018/11/msg00038.html
MLIST [debian-lts-announce] 20181130 [SECURITY] [DLA 1599-1] qemu security update
http://rhn.redhat.com/errata/RHSA-2016-2670.html
REDHAT RHSA-2016:2670
http://rhn.redhat.com/errata/RHSA-2016-2705.html
REDHAT RHSA-2016:2705
http://rhn.redhat.com/errata/RHSA-2016-2704.html
REDHAT RHSA-2016:2704
http://rhn.redhat.com/errata/RHSA-2016-2671.html
REDHAT RHSA-2016:2671
http://www.securityfocus.com/bid/84130
BID 84130 QEMU Out of Bounds Denial of Service Vulnerability Release Date:2017-03-02
http://rhn.redhat.com/errata/RHSA-2017-0350.html
REDHAT RHSA-2017:0350
http://www.openwall.com/lists/oss-security/2016/03/03/9
MLIST [oss-security] 20160303 CVE request Qemu: net: out of bounds read in net_checksum_calculate
http://www.openwall.com/lists/oss-security/2016/03/07/3
MLIST [oss-security] 20160306 Re: CVE request Qemu: net: out of bounds read in net_checksum_calculate
http://rhn.redhat.com/errata/RHSA-2016-2706.html
REDHAT RHSA-2016:2706
http://rhn.redhat.com/errata/RHSA-2017-0083.html
REDHAT RHSA-2017:0083
http://rhn.redhat.com/errata/RHSA-2017-0309.html
REDHAT RHSA-2017:0309
http://rhn.redhat.com/errata/RHSA-2017-0334.html
REDHAT RHSA-2017:0334
http://rhn.redhat.com/errata/RHSA-2017-0344.html
REDHAT RHSA-2017:0344
http://www.ubuntu.com/usn/USN-2974-1
UBUNTU USN-2974-1
http://git.qemu.org/?p=qemu.git;a=commitdiff;h=362786f14a753d8a5256ef97d7c10ed576d6572b CONFIRM

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0
Vulnerability is valid if product versions listed below are used 0

- Metasploit Modules Related To CVE-2016-2857

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.