CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2015-3340

Xen 4.2.x through 4.5.x does not initialize certain fields, which allows certain remote service domains to obtain sensitive information from memory via a (1) XEN_DOMCTL_gettscinfo or (2) XEN_SYSCTL_getdomaininfolist request.
Publish Date : 2015-04-28 Last Update Date : 2018-10-30
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
2.9
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Obtain Information
CWE ID 200

- Products Affected By CVE-2015-3340

# Product Type Vendor Product Version Update Edition Language
1 OS Debian Debian Linux 7.0 * * * Version Details Vulnerabilities
2 OS Debian Debian Linux 8.0 * * * Version Details Vulnerabilities
3 OS Fedoraproject Fedora 20 * * * Version Details Vulnerabilities
4 OS Fedoraproject Fedora 21 * * * Version Details Vulnerabilities
5 OS Fedoraproject Fedora 22 * * * Version Details Vulnerabilities
6 OS Opensuse Opensuse 13.1 * * * Version Details Vulnerabilities
7 OS Suse Linux Enterprise Desktop 12 * * * Version Details Vulnerabilities
8 OS Suse Linux Enterprise Software Development Kit 12 * * * Version Details Vulnerabilities
9 OS Suse Suse Linux Enterprise Desktop 11.0 SP3 * * Version Details Vulnerabilities
10 OS Suse Suse Linux Enterprise Server 11.0 SP3 * * Version Details Vulnerabilities
11 OS Suse Suse Linux Enterprise Server 12 * * * Version Details Vulnerabilities
12 Application Suse Suse Linux Enterprise Software Development Kit 11.0 SP3 * * Version Details Vulnerabilities
13 OS XEN XEN 4.2.0 * * * Version Details Vulnerabilities
14 OS XEN XEN 4.2.1 * * * Version Details Vulnerabilities
15 OS XEN XEN 4.2.2 * * * Version Details Vulnerabilities
16 OS XEN XEN 4.2.3 * * * Version Details Vulnerabilities
17 OS XEN XEN 4.2.4 * * * Version Details Vulnerabilities
18 OS XEN XEN 4.2.5 * * * Version Details Vulnerabilities
19 OS XEN XEN 4.3.0 * * * Version Details Vulnerabilities
20 OS XEN XEN 4.3.1 * * * Version Details Vulnerabilities
21 OS XEN XEN 4.3.2 * * * Version Details Vulnerabilities
22 OS XEN XEN 4.3.3 * * * Version Details Vulnerabilities
23 OS XEN XEN 4.3.4 * * * Version Details Vulnerabilities
24 OS XEN XEN 4.4.0 * * * Version Details Vulnerabilities
25 OS XEN XEN 4.4.1 * * * Version Details Vulnerabilities
26 OS XEN XEN 4.4.2 * * * Version Details Vulnerabilities
27 OS XEN XEN 4.5.0 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Debian Debian Linux 2
Fedoraproject Fedora 3
Opensuse Opensuse 1
Suse Linux Enterprise Desktop 1
Suse Linux Enterprise Software Development Kit 1
Suse Suse Linux Enterprise Desktop 1
Suse Suse Linux Enterprise Server 2
Suse Suse Linux Enterprise Software Development Kit 1
XEN XEN 15

- References For CVE-2015-3340

http://lists.opensuse.org/opensuse-security-announce/2015-06/msg00001.html
SUSE openSUSE-SU-2015:0983
http://www.debian.org/security/2015/dsa-3414
DEBIAN DSA-3414
https://security.gentoo.org/glsa/201604-03
GENTOO GLSA-201604-03
http://lists.opensuse.org/opensuse-security-announce/2015-05/msg00018.html
SUSE SUSE-SU-2015:0923
http://lists.fedoraproject.org/pipermail/package-announce/2015-May/156979.html
FEDORA FEDORA-2015-6670
http://lists.opensuse.org/opensuse-security-announce/2015-05/msg00019.html
SUSE SUSE-SU-2015:0927
http://www.securitytracker.com/id/1032158
SECTRACK 1032158
http://lists.fedoraproject.org/pipermail/package-announce/2015-April/156005.html
FEDORA FEDORA-2015-6569
http://www.securityfocus.com/bid/74248
BID 74248 Xen CVE-2015-3340 Information Disclosure Vulnerability Release Date:2015-06-04
http://lists.fedoraproject.org/pipermail/package-announce/2015-May/157006.html
FEDORA FEDORA-2015-6583
http://xenbits.xen.org/xsa/advisory-132.html CONFIRM

- Metasploit Modules Related To CVE-2015-3340

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.