CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  What's the CVSS score of your company?
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2015-3165

Double free vulnerability in PostgreSQL before 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2 allows remote attackers to cause a denial of service (crash) by closing an SSL session at a time when the authentication timeout will expire during the session shutdown sequence.
Publish Date : 2015-05-28 Last Update Date : 2018-01-05
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID CWE id is not defined for this vulnerability

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2015:1194: postgresql security update (Moderate) oval:com.redhat.rhsa:def:20151194 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2015-3165

# Product Type Vendor Product Version Update Edition Language
1 OS Apple Mac Os X Server 5.0.2 * * * Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 12.04 * * * Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 14.04 * * * Version Details Vulnerabilities
4 OS Canonical Ubuntu Linux 14.10 * * * Version Details Vulnerabilities
5 OS Canonical Ubuntu Linux 15.04 * * * Version Details Vulnerabilities
6 OS Debian Debian Linux 7.0 * * * Version Details Vulnerabilities
7 OS Debian Debian Linux 8.0 * * * Version Details Vulnerabilities
8 Application Postgresql Postgresql * * * * Version Details Vulnerabilities
9 Application Postgresql Postgresql 9.1 * * * Version Details Vulnerabilities
10 Application Postgresql Postgresql 9.1.1 * * * Version Details Vulnerabilities
11 Application Postgresql Postgresql 9.1.2 * * * Version Details Vulnerabilities
12 Application Postgresql Postgresql 9.1.3 * * * Version Details Vulnerabilities
13 Application Postgresql Postgresql 9.1.4 * * * Version Details Vulnerabilities
14 Application Postgresql Postgresql 9.1.5 * * * Version Details Vulnerabilities
15 Application Postgresql Postgresql 9.1.6 * * * Version Details Vulnerabilities
16 Application Postgresql Postgresql 9.1.7 * * * Version Details Vulnerabilities
17 Application Postgresql Postgresql 9.1.8 * * * Version Details Vulnerabilities
18 Application Postgresql Postgresql 9.1.9 * * * Version Details Vulnerabilities
19 Application Postgresql Postgresql 9.1.10 * * * Version Details Vulnerabilities
20 Application Postgresql Postgresql 9.1.11 * * * Version Details Vulnerabilities
21 Application Postgresql Postgresql 9.1.12 * * * Version Details Vulnerabilities
22 Application Postgresql Postgresql 9.1.13 * * * Version Details Vulnerabilities
23 Application Postgresql Postgresql 9.1.14 * * * Version Details Vulnerabilities
24 Application Postgresql Postgresql 9.1.15 * * * Version Details Vulnerabilities
25 Application Postgresql Postgresql 9.2 * * * Version Details Vulnerabilities
26 Application Postgresql Postgresql 9.2.1 * * * Version Details Vulnerabilities
27 Application Postgresql Postgresql 9.2.2 * * * Version Details Vulnerabilities
28 Application Postgresql Postgresql 9.2.3 * * * Version Details Vulnerabilities
29 Application Postgresql Postgresql 9.2.4 * * * Version Details Vulnerabilities
30 Application Postgresql Postgresql 9.2.5 * * * Version Details Vulnerabilities
31 Application Postgresql Postgresql 9.2.6 * * * Version Details Vulnerabilities
32 Application Postgresql Postgresql 9.2.7 * * * Version Details Vulnerabilities
33 Application Postgresql Postgresql 9.2.8 * * * Version Details Vulnerabilities
34 Application Postgresql Postgresql 9.2.9 * * * Version Details Vulnerabilities
35 Application Postgresql Postgresql 9.2.10 * * * Version Details Vulnerabilities
36 Application Postgresql Postgresql 9.3 * * * Version Details Vulnerabilities
37 Application Postgresql Postgresql 9.3.1 * * * Version Details Vulnerabilities
38 Application Postgresql Postgresql 9.3.2 * * * Version Details Vulnerabilities
39 Application Postgresql Postgresql 9.3.3 * * * Version Details Vulnerabilities
40 Application Postgresql Postgresql 9.3.4 * * * Version Details Vulnerabilities
41 Application Postgresql Postgresql 9.3.5 * * * Version Details Vulnerabilities
42 Application Postgresql Postgresql 9.3.6 * * * Version Details Vulnerabilities
43 Application Postgresql Postgresql 9.4.0 * * * Version Details Vulnerabilities
44 Application Postgresql Postgresql 9.4.1 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apple Mac Os X Server 1
Canonical Ubuntu Linux 4
Debian Debian Linux 2
Postgresql Postgresql 37

- References For CVE-2015-3165

http://rhn.redhat.com/errata/RHSA-2015-1196.html
REDHAT RHSA-2015:1196
http://rhn.redhat.com/errata/RHSA-2015-1194.html
REDHAT RHSA-2015:1194
http://rhn.redhat.com/errata/RHSA-2015-1195.html
REDHAT RHSA-2015:1195
http://www.postgresql.org/docs/9.0/static/release-9-0-20.html CONFIRM
http://www.debian.org/security/2015/dsa-3269
DEBIAN DSA-3269
http://www.ubuntu.com/usn/USN-2621-1
UBUNTU USN-2621-1
http://www.postgresql.org/docs/9.4/static/release-9-4-2.html CONFIRM
http://www.debian.org/security/2015/dsa-3270
DEBIAN DSA-3270
http://www.postgresql.org/docs/9.3/static/release-9-3-7.html CONFIRM
http://lists.apple.com/archives/security-announce/2015/Sep/msg00004.html
APPLE APPLE-SA-2015-09-16-4
https://security.gentoo.org/glsa/201507-20
GENTOO GLSA-201507-20
https://support.apple.com/HT205219 CONFIRM
http://www.postgresql.org/docs/9.1/static/release-9-1-16.html CONFIRM
http://www.postgresql.org/docs/9.2/static/release-9-2-11.html CONFIRM
http://www.securityfocus.com/bid/74787
BID 74787 PostgreSQL CVE-2015-3165 Remote Denial Of Service Vulnerability Release Date:2015-07-22
http://www.postgresql.org/about/news/1587/ CONFIRM

- Metasploit Modules Related To CVE-2015-3165

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.