CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2007-5631

Multiple PHP remote file inclusion vulnerabilities in PeopleAggregator 1.2pre6, when register_globals is enabled, allow remote attackers to execute arbitrary PHP code via a URL in the current_blockmodule_path parameter to (1) AudiosMediaGalleryModule/AudiosMediaGalleryModule.php, (2) ImagesMediaGalleryModule/ImagesMediaGalleryModule.php, (3) MembersFacewallModule/MembersFacewallModule.php, (4) NewestGroupsModule/NewestGroupsModule.php, (5) UploadMediaModule/UploadMediaModule.php, and (6) VideosMediaGalleryModule/VideosMediaGalleryModule.php in BetaBlockModules/; and (7) the path_prefix parameter to several components.
Publish Date : 2007-10-23 Last Update Date : 2018-10-15
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.8
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute CodeFile Inclusion
CWE ID 94

- Products Affected By CVE-2007-5631

# Product Type Vendor Product Version Update Edition Language
1 Application Peopleaggregator Peopleaggregator 1.2pre6 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Peopleaggregator Peopleaggregator 1

- References For CVE-2007-5631

http://osvdb.org/45500
OSVDB 45500
http://osvdb.org/45501
OSVDB 45501
http://osvdb.org/45497
OSVDB 45497
http://osvdb.org/45496
OSVDB 45496
http://osvdb.org/45495
OSVDB 45495
http://www.myelin.co.nz/post/2007/11/12/#200711121 CONFIRM
http://www.securityfocus.com/bid/26147
BID 26147 Broadband Mechanics PeopleAggregator Multiple Remote File Include Vulnerabilities Release Date:2007-11-15
http://osvdb.org/45498
OSVDB 45498
http://osvdb.org/45499
OSVDB 45499
https://exchange.xforce.ibmcloud.com/vulnerabilities/37349
XF peopleaggregator-pathprefix-file-include(37349)
https://www.exploit-db.com/exploits/4551
EXPLOIT-DB 4551
http://www.securityfocus.com/archive/1/483571/100/0/threaded
BUGTRAQ 20071111 PeopleAggregatory security advisory - re CVE-2007-5631

- Metasploit Modules Related To CVE-2007-5631

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.