CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2005-3389

The parse_str function in PHP 4.x up to 4.4.0 and 5.x up to 5.0.5, when called with only one parameter, allows remote attackers to enable the register_globals directive via inputs that cause a request to be terminated due to the memory_limit setting, which causes PHP to set an internal flag that enables register_globals and allows attackers to exploit vulnerabilities in PHP applications that would otherwise be protected.
Publish Date : 2005-11-01 Last Update Date : 2018-10-30
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID CWE id is not defined for this vulnerability

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat low 2005-10-31 2005-10-31
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2005-3389 oval:org.opensuse.security:def:20053389 unix
RHSA-2005:831: php security update (Moderate) oval:com.redhat.rhsa:def:20050831 unix
RHSA-2005:831: php security update (Moderate) oval:com.redhat.rhsa:def:2005831 unix
The parse_str function in PHP 4.x up to 4.4.0 and 5.x up to 5.0.5, when called with only one parameter, allows remote at... oval:org.mitre.oval:def:11481 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2005-3389

# Product Type Vendor Product Version Update Edition Language
1 Application PHP PHP 4.0.0 * * * Version Details Vulnerabilities
2 Application PHP PHP 4.0.1 * * * Version Details Vulnerabilities
3 Application PHP PHP 4.0.1 Patch1 * * Version Details Vulnerabilities
4 Application PHP PHP 4.0.1 Patch2 * * Version Details Vulnerabilities
5 Application PHP PHP 4.0.2 * * * Version Details Vulnerabilities
6 Application PHP PHP 4.0.3 * * * Version Details Vulnerabilities
7 Application PHP PHP 4.0.3 Patch1 * * Version Details Vulnerabilities
8 Application PHP PHP 4.0.4 * * * Version Details Vulnerabilities
9 Application PHP PHP 4.0.5 * * * Version Details Vulnerabilities
10 Application PHP PHP 4.0.6 * * * Version Details Vulnerabilities
11 Application PHP PHP 4.0.7 RC1 * * Version Details Vulnerabilities
12 Application PHP PHP 4.0.7 RC3 * * Version Details Vulnerabilities
13 Application PHP PHP 4.0.7 * * * Version Details Vulnerabilities
14 Application PHP PHP 4.0.7 RC2 * * Version Details Vulnerabilities
15 Application PHP PHP 4.1.0 * * * Version Details Vulnerabilities
16 Application PHP PHP 4.1.1 * * * Version Details Vulnerabilities
17 Application PHP PHP 4.1.2 * * * Version Details Vulnerabilities
18 Application PHP PHP 4.2 * DEV * Version Details Vulnerabilities
19 Application PHP PHP 4.2.0 * * * Version Details Vulnerabilities
20 Application PHP PHP 4.2.1 * * * Version Details Vulnerabilities
21 Application PHP PHP 4.2.2 * * * Version Details Vulnerabilities
22 Application PHP PHP 4.2.3 * * * Version Details Vulnerabilities
23 Application PHP PHP 4.3.0 * * * Version Details Vulnerabilities
24 Application PHP PHP 4.3.1 * * * Version Details Vulnerabilities
25 Application PHP PHP 4.3.2 * * * Version Details Vulnerabilities
26 Application PHP PHP 4.3.3 * * * Version Details Vulnerabilities
27 Application PHP PHP 4.3.4 * * * Version Details Vulnerabilities
28 Application PHP PHP 4.3.5 * * * Version Details Vulnerabilities
29 Application PHP PHP 4.3.6 * * * Version Details Vulnerabilities
30 Application PHP PHP 4.3.7 * * * Version Details Vulnerabilities
31 Application PHP PHP 4.3.8 * * * Version Details Vulnerabilities
32 Application PHP PHP 4.3.9 * * * Version Details Vulnerabilities
33 Application PHP PHP 4.3.10 * * * Version Details Vulnerabilities
34 Application PHP PHP 4.3.11 * * * Version Details Vulnerabilities
35 Application PHP PHP 4.4.0 * * * Version Details Vulnerabilities
36 Application PHP PHP 5.0.0 RC3 * * Version Details Vulnerabilities
37 Application PHP PHP 5.0.0 Beta1 * * Version Details Vulnerabilities
38 Application PHP PHP 5.0.0 Beta4 * * Version Details Vulnerabilities
39 Application PHP PHP 5.0.0 Beta2 * * Version Details Vulnerabilities
40 Application PHP PHP 5.0.0 RC1 * * Version Details Vulnerabilities
41 Application PHP PHP 5.0.0 Beta3 * * Version Details Vulnerabilities
42 Application PHP PHP 5.0.0 RC2 * * Version Details Vulnerabilities
43 Application PHP PHP 5.0.0 * * * Version Details Vulnerabilities
44 Application PHP PHP 5.0.1 * * * Version Details Vulnerabilities
45 Application PHP PHP 5.0.2 * * * Version Details Vulnerabilities
46 Application PHP PHP 5.0.3 * * * Version Details Vulnerabilities
47 Application PHP PHP 5.0.4 * * * Version Details Vulnerabilities
48 Application PHP PHP 5.0.5 * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
PHP PHP 48

- References For CVE-2005-3389

http://www.gentoo.org/security/en/glsa/glsa-200511-08.xml
GENTOO GLSA-200511-08
http://support.avaya.com/elmodocs2/security/ASA-2006-037.htm CONFIRM
http://secunia.com/advisories/18669
SECUNIA 18669
http://secunia.com/advisories/21252
SECUNIA 21252
http://www.novell.com/linux/security/advisories/2005_27_sr.html
SUSE SUSE-SR:2005:027
http://secunia.com/advisories/17490
SECUNIA 17490
http://secunia.com/advisories/17510
SECUNIA 17510
http://secunia.com/advisories/17531
SECUNIA 17531
http://secunia.com/advisories/17557
SECUNIA 17557
http://www.redhat.com/support/errata/RHSA-2005-838.html
REDHAT RHSA-2005:838
http://www.redhat.com/support/errata/RHSA-2005-831.html
REDHAT RHSA-2005:831
http://www.openpkg.org/security/OpenPKG-SA-2005.027-php.html
OPENPKG OpenPKG-SA-2005.027
http://secunia.com/advisories/18054
SECUNIA 18054
http://secunia.com/advisories/18198
SECUNIA 18198
http://secunia.com/advisories/17559
SECUNIA 17559
http://www.fedoralegacy.org/updates/FC2/2005-11-28-FLSA_2005_166943__Updated_php_packages_fix_security_issues.html
FEDORA FLSA:166943
http://www.securityfocus.com/archive/1/415291
BUGTRAQ 20051031 Advisory 19/2005: PHP register_globals Activation Vulnerability in parse_str()
http://secunia.com/advisories/17371
SECUNIA 17371
http://securitytracker.com/id?1015131
SECTRACK 1015131
http://www.securityfocus.com/bid/15249
BID 15249 PHP Parse_Str Register_Globals Activation Weakness Release Date:2006-11-23
http://www.php.net/release_4_4_1.php CONFIRM
http://www.hardened-php.net/advisory_192005.78.html
http://rhn.redhat.com/errata/RHSA-2006-0549.html
REDHAT RHSA-2006:0549
http://secunia.com/advisories/22691
SECUNIA 22691
http://www.turbolinux.com/security/2006/TLSA-2006-38.txt
TURBO TLSA-2006-38
http://www.mandriva.com/security/advisories?name=MDKSA-2005:213
MANDRIVA MDKSA-2005:213
http://securityreason.com/securityalert/134
SREASON 134
http://www.vupen.com/english/advisories/2005/2254
VUPEN ADV-2005-2254
http://www.vupen.com/english/advisories/2006/4320
VUPEN ADV-2006-4320
http://itrc.hp.com/service/cki/docDisplay.do?docId=c00786522
HP SSRT061238
https://www.ubuntu.com/usn/usn-232-1/
UBUNTU USN-232-1
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11481
OVAL oval:org.mitre.oval:def:11481
http://www.securityfocus.com/archive/1/419504/100/0/threaded
SUSE SUSE-SA:2005:069

- Metasploit Modules Related To CVE-2005-3389

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.