CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  What's the CVSS score of your company?
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2005-2708

The search_binary_handler function in exec.c in Linux 2.4 kernel on 64-bit x86 architectures does not check a return code for a particular function call when virtual memory is low, which allows local users to cause a denial of service (panic), as demonstrated by running a process using the bash ulimit -v command.
Publish Date : 2005-10-25 Last Update Date : 2018-10-19
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
2.1
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 399

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat important 2005-06-28 2005-06-28
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2006:0140: kernel security update (Important) oval:com.redhat.rhsa:def:20060140 unix
The search_binary_handler function in exec.c in Linux 2.4 kernel on 64-bit x86 architectures does not check a return cod... oval:org.mitre.oval:def:10649 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2005-2708

# Product Type Vendor Product Version Update Edition Language
1 OS Linux Linux Kernel 2.4.0 Test1 * * Version Details Vulnerabilities
2 OS Linux Linux Kernel 2.4.0 Test8 * * Version Details Vulnerabilities
3 OS Linux Linux Kernel 2.4.0 Test2 * * Version Details Vulnerabilities
4 OS Linux Linux Kernel 2.4.0 Test12 * * Version Details Vulnerabilities
5 OS Linux Linux Kernel 2.4.0 Test10 * * Version Details Vulnerabilities
6 OS Linux Linux Kernel 2.4.0 Test9 * * Version Details Vulnerabilities
7 OS Linux Linux Kernel 2.4.0 * * * Version Details Vulnerabilities
8 OS Linux Linux Kernel 2.4.0 Test3 * * Version Details Vulnerabilities
9 OS Linux Linux Kernel 2.4.0 Test6 * * Version Details Vulnerabilities
10 OS Linux Linux Kernel 2.4.0 Test4 * * Version Details Vulnerabilities
11 OS Linux Linux Kernel 2.4.0 Test7 * * Version Details Vulnerabilities
12 OS Linux Linux Kernel 2.4.0 Test5 * * Version Details Vulnerabilities
13 OS Linux Linux Kernel 2.4.0 Test11 * * Version Details Vulnerabilities
14 OS Linux Linux Kernel 2.4.1 * * * Version Details Vulnerabilities
15 OS Linux Linux Kernel 2.4.2 * * * Version Details Vulnerabilities
16 OS Linux Linux Kernel 2.4.3 * * * Version Details Vulnerabilities
17 OS Linux Linux Kernel 2.4.4 * * * Version Details Vulnerabilities
18 OS Linux Linux Kernel 2.4.5 * * * Version Details Vulnerabilities
19 OS Linux Linux Kernel 2.4.6 * * * Version Details Vulnerabilities
20 OS Linux Linux Kernel 2.4.7 * * * Version Details Vulnerabilities
21 OS Linux Linux Kernel 2.4.8 * * * Version Details Vulnerabilities
22 OS Linux Linux Kernel 2.4.9 * * * Version Details Vulnerabilities
23 OS Linux Linux Kernel 2.4.10 * * * Version Details Vulnerabilities
24 OS Linux Linux Kernel 2.4.11 * * * Version Details Vulnerabilities
25 OS Linux Linux Kernel 2.4.12 * * * Version Details Vulnerabilities
26 OS Linux Linux Kernel 2.4.13 * * * Version Details Vulnerabilities
27 OS Linux Linux Kernel 2.4.14 * * * Version Details Vulnerabilities
28 OS Linux Linux Kernel 2.4.15 * * * Version Details Vulnerabilities
29 OS Linux Linux Kernel 2.4.16 * * * Version Details Vulnerabilities
30 OS Linux Linux Kernel 2.4.17 * * * Version Details Vulnerabilities
31 OS Linux Linux Kernel 2.4.18 * X86 * Version Details Vulnerabilities
32 OS Linux Linux Kernel 2.4.18 Pre3 * * Version Details Vulnerabilities
33 OS Linux Linux Kernel 2.4.18 Pre7 * * Version Details Vulnerabilities
34 OS Linux Linux Kernel 2.4.18 Pre4 * * Version Details Vulnerabilities
35 OS Linux Linux Kernel 2.4.18 Pre1 * * Version Details Vulnerabilities
36 OS Linux Linux Kernel 2.4.18 Pre8 * * Version Details Vulnerabilities
37 OS Linux Linux Kernel 2.4.18 Pre2 * * Version Details Vulnerabilities
38 OS Linux Linux Kernel 2.4.18 Pre5 * * Version Details Vulnerabilities
39 OS Linux Linux Kernel 2.4.18 * * * Version Details Vulnerabilities
40 OS Linux Linux Kernel 2.4.18 Pre6 * * Version Details Vulnerabilities
41 OS Linux Linux Kernel 2.4.19 Pre4 * * Version Details Vulnerabilities
42 OS Linux Linux Kernel 2.4.19 Pre5 * * Version Details Vulnerabilities
43 OS Linux Linux Kernel 2.4.19 Pre2 * * Version Details Vulnerabilities
44 OS Linux Linux Kernel 2.4.19 Pre6 * * Version Details Vulnerabilities
45 OS Linux Linux Kernel 2.4.19 Pre3 * * Version Details Vulnerabilities
46 OS Linux Linux Kernel 2.4.19 * * * Version Details Vulnerabilities
47 OS Linux Linux Kernel 2.4.19 Pre1 * * Version Details Vulnerabilities
48 OS Linux Linux Kernel 2.4.20 * * * Version Details Vulnerabilities
49 OS Linux Linux Kernel 2.4.21 Pre7 * * Version Details Vulnerabilities
50 OS Linux Linux Kernel 2.4.21 * * * Version Details Vulnerabilities
51 OS Linux Linux Kernel 2.4.21 Pre1 * * Version Details Vulnerabilities
52 OS Linux Linux Kernel 2.4.21 Pre4 * * Version Details Vulnerabilities
53 OS Linux Linux Kernel 2.4.22 * * * Version Details Vulnerabilities
54 OS Linux Linux Kernel 2.4.23 Pre9 * * Version Details Vulnerabilities
55 OS Linux Linux Kernel 2.4.23 Ow2 * * * Version Details Vulnerabilities
56 OS Linux Linux Kernel 2.4.23 * * * Version Details Vulnerabilities
57 OS Linux Linux Kernel 2.4.24 * * * Version Details Vulnerabilities
58 OS Linux Linux Kernel 2.4.24 Ow1 * * * Version Details Vulnerabilities
59 OS Linux Linux Kernel 2.4.25 * * * Version Details Vulnerabilities
60 OS Linux Linux Kernel 2.4.26 * * * Version Details Vulnerabilities
61 OS Linux Linux Kernel 2.4.27 Pre5 * * Version Details Vulnerabilities
62 OS Linux Linux Kernel 2.4.27 Pre1 * * Version Details Vulnerabilities
63 OS Linux Linux Kernel 2.4.27 Pre2 * * Version Details Vulnerabilities
64 OS Linux Linux Kernel 2.4.27 Pre3 * * Version Details Vulnerabilities
65 OS Linux Linux Kernel 2.4.27 Pre4 * * Version Details Vulnerabilities
66 OS Linux Linux Kernel 2.4.27 * * * Version Details Vulnerabilities
67 OS Linux Linux Kernel 2.4.28 * * * Version Details Vulnerabilities
68 OS Linux Linux Kernel 2.4.29 RC1 * * Version Details Vulnerabilities
69 OS Linux Linux Kernel 2.4.29 RC2 * * Version Details Vulnerabilities
70 OS Linux Linux Kernel 2.4.29 * * * Version Details Vulnerabilities
71 OS Linux Linux Kernel 2.4.30 RC2 * * Version Details Vulnerabilities
72 OS Linux Linux Kernel 2.4.30 RC3 * * Version Details Vulnerabilities
73 OS Linux Linux Kernel 2.4.30 * * * Version Details Vulnerabilities
74 OS Linux Linux Kernel 2.4.31 Pre1 * * Version Details Vulnerabilities
75 OS Linux Linux Kernel 2.4.31 * * * Version Details Vulnerabilities
76 OS Linux Linux Kernel 2.4.32 * * * Version Details Vulnerabilities
77 OS Linux Linux Kernel 2.4.32 Pre1 * * Version Details Vulnerabilities
78 OS Linux Linux Kernel 2.4.32 Pre2 * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Linux Linux Kernel 78

- References For CVE-2005-2708

http://www.securityfocus.com/bid/16320
BID 16320 Linux Kernel SEARCH_BINARY_HANDLER Local Denial of Service Vulnerability Release Date:2006-11-13
http://secunia.com/advisories/18562
SECUNIA 18562
http://secunia.com/advisories/18523
SECUNIA 18523
http://www.redhat.com/support/errata/RHSA-2006-0190.html
REDHAT RHSA-2006:0190
http://www.redhat.com/support/errata/RHSA-2006-0140.html
REDHAT RHSA-2006:0140
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161925 CONFIRM
http://secunia.com/advisories/18684
SECUNIA 18684
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10649
OVAL oval:org.mitre.oval:def:10649
http://www.securityfocus.com/archive/1/428058/100/0/threaded
FEDORA FLSA:157459-2
http://www.securityfocus.com/archive/1/428028/100/0/threaded
FEDORA FLSA:157459-1

- Metasploit Modules Related To CVE-2005-2708

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.